aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--comms/Makefile1
-rw-r--r--comms/usbmuxd/Makefile42
-rw-r--r--comms/usbmuxd/distinfo2
-rw-r--r--comms/usbmuxd/pkg-descr7
-rw-r--r--comms/usbmuxd/pkg-plist8
5 files changed, 60 insertions, 0 deletions
diff --git a/comms/Makefile b/comms/Makefile
index 14bef9e2d3e..8019becf8fc 100644
--- a/comms/Makefile
+++ b/comms/Makefile
@@ -150,6 +150,7 @@
SUBDIR += uird
SUBDIR += umcs7840
SUBDIR += unixcw
+ SUBDIR += usbmuxd
SUBDIR += uticom
SUBDIR += viewfax
SUBDIR += vrflash
diff --git a/comms/usbmuxd/Makefile b/comms/usbmuxd/Makefile
new file mode 100644
index 00000000000..5d8278cd304
--- /dev/null
+++ b/comms/usbmuxd/Makefile
@@ -0,0 +1,42 @@
+# New ports collection makefile for: usbmuxd
+# Date created: 10 June 2010
+# Whom: Alberto Villa <avilla@FreeBSD.org>
+#
+# $FreeBSD$
+
+PORTNAME= usbmuxd
+PORTVERSION= 1.0.6
+CATEGORIES= comms
+MASTER_SITES= http://marcansoft.com/uploads/${PORTNAME}/
+
+MAINTAINER= avilla@FreeBSD.org
+COMMENT= A daemon for multiplexing connections over USB to an iPhone/iPod Touch
+
+LIB_DEPENDS= plist.1:${PORTSDIR}/devel/libplist
+
+USE_BZIP2= yes
+MAKE_JOBS_SAFE= yes
+USE_CMAKE= yes
+USE_LDCONFIG= yes
+
+PORTDOCS= AUTHORS README README.devel
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 800069
+BROKEN= requires libusb 1.0
+.endif
+
+pre-configure:
+ ${REINPLACE_CMD} -e 's|$${LIB_SUFFIX}/pkgconfig|data/pkgconfig|' \
+ ${WRKSRC}/CMakeLists.txt
+
+post-install:
+.ifndef(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/comms/usbmuxd/distinfo b/comms/usbmuxd/distinfo
new file mode 100644
index 00000000000..8ee1f4594d3
--- /dev/null
+++ b/comms/usbmuxd/distinfo
@@ -0,0 +1,2 @@
+SHA256 (usbmuxd-1.0.6.tar.bz2) = b2b8a094fef7f1d250f20eba8fa8ff3cf1696b5c62543de2740b2b5dc2de40a7
+SIZE (usbmuxd-1.0.6.tar.bz2) = 58339
diff --git a/comms/usbmuxd/pkg-descr b/comms/usbmuxd/pkg-descr
new file mode 100644
index 00000000000..9bb44d96e86
--- /dev/null
+++ b/comms/usbmuxd/pkg-descr
@@ -0,0 +1,7 @@
+'usbmuxd' stands for "USB multiplexing daemon". This daemon is in
+charge of multiplexing connections over USB to an iPhone or iPod
+touch. To users, it means you can sync your music, contacts, photos,
+etc. over USB. To developers, it means you can connect to any
+listening localhost socket on the device.
+
+WWW: http://marcansoft.com/blog/iphonelinux/usbmuxd
diff --git a/comms/usbmuxd/pkg-plist b/comms/usbmuxd/pkg-plist
new file mode 100644
index 00000000000..3600fc4d03e
--- /dev/null
+++ b/comms/usbmuxd/pkg-plist
@@ -0,0 +1,8 @@
+bin/iproxy
+include/usbmuxd-proto.h
+include/usbmuxd.h
+lib/libusbmuxd.so
+lib/libusbmuxd.so.1
+lib/libusbmuxd.so.1.0.6
+libdata/pkgconfig/libusbmuxd.pc
+sbin/usbmuxd