aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/shaaft/Makefile13
1 files changed, 4 insertions, 9 deletions
diff --git a/games/shaaft/Makefile b/games/shaaft/Makefile
index 341c35e6e1b..3353f8eea19 100644
--- a/games/shaaft/Makefile
+++ b/games/shaaft/Makefile
@@ -15,7 +15,9 @@ LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
CONFLICTS= criticalmass-*
-USES= tar:bzip2
+BROKEN_sparc64= does not compile
+
+USES= tar:bzip2
USE_SDL= mixer image sdl
USE_GL= yes
USE_GCC= any
@@ -29,16 +31,9 @@ DATADIR= ${PREFIX}/share/Shaaft
PLIST_FILES= bin/Packer bin/shaaft %%DATADIR%%/resource.dat \
man/man6/shaaft.6.gz
-PLIST_DIRS= %%DATADIR%%
DESKTOP_ENTRIES="Shaaft" "" "" "${PORTNAME}" "" ""
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == "sparc64"
-BROKEN= Does not compile on sparc64
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|sdl-config|${SDL_CONFIG:T}|g ; \
s|^CXXFLAGS|#CXXFLAGS|g ; \
@@ -49,4 +44,4 @@ post-patch:
's|SDL/SDL|SDL|g'
@${REINPLACE_CMD} -e 's|== 3|>= 3|' ${WRKSRC}/utils/hashMap.hpp
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>