aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--emulators/mame-devel/Makefile4
-rw-r--r--emulators/mame/Makefile4
-rw-r--r--emulators/mess/Makefile8
-rw-r--r--emulators/sdlmame-devel/Makefile4
-rw-r--r--emulators/sdlmame/Makefile4
-rw-r--r--emulators/sdlmess/Makefile8
6 files changed, 30 insertions, 2 deletions
diff --git a/emulators/mame-devel/Makefile b/emulators/mame-devel/Makefile
index d6a571494c1..599dafc0adf 100644
--- a/emulators/mame-devel/Makefile
+++ b/emulators/mame-devel/Makefile
@@ -52,4 +52,8 @@ post-install:
USE_GCC= 4.2+
.endif
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile
+.endif
+
.include <bsd.port.post.mk>
diff --git a/emulators/mame/Makefile b/emulators/mame/Makefile
index d6a571494c1..599dafc0adf 100644
--- a/emulators/mame/Makefile
+++ b/emulators/mame/Makefile
@@ -52,4 +52,8 @@ post-install:
USE_GCC= 4.2+
.endif
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile
+.endif
+
.include <bsd.port.post.mk>
diff --git a/emulators/mess/Makefile b/emulators/mess/Makefile
index 9b7217a878d..83e50fe45e6 100644
--- a/emulators/mess/Makefile
+++ b/emulators/mess/Makefile
@@ -45,4 +45,10 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile
+.endif
+
+.include <bsd.port.post.mk>
diff --git a/emulators/sdlmame-devel/Makefile b/emulators/sdlmame-devel/Makefile
index d6a571494c1..599dafc0adf 100644
--- a/emulators/sdlmame-devel/Makefile
+++ b/emulators/sdlmame-devel/Makefile
@@ -52,4 +52,8 @@ post-install:
USE_GCC= 4.2+
.endif
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile
+.endif
+
.include <bsd.port.post.mk>
diff --git a/emulators/sdlmame/Makefile b/emulators/sdlmame/Makefile
index d6a571494c1..599dafc0adf 100644
--- a/emulators/sdlmame/Makefile
+++ b/emulators/sdlmame/Makefile
@@ -52,4 +52,8 @@ post-install:
USE_GCC= 4.2+
.endif
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile
+.endif
+
.include <bsd.port.post.mk>
diff --git a/emulators/sdlmess/Makefile b/emulators/sdlmess/Makefile
index 9b7217a878d..83e50fe45e6 100644
--- a/emulators/sdlmess/Makefile
+++ b/emulators/sdlmess/Makefile
@@ -45,4 +45,10 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${ECHO_CMD}
-.include <bsd.port.mk>
+.include <bsd.port.pre.mk>
+
+.if ${ARCH} == "sparc64"
+BROKEN= Does not compile
+.endif
+
+.include <bsd.port.post.mk>