aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Mk/bsd.port.mk12
-rw-r--r--games/inform7/Makefile1
-rw-r--r--games/inform7/pkg-plist8
-rw-r--r--net/wired/Makefile1
-rw-r--r--net/wired/pkg-plist4
-rw-r--r--www/dalbum/Makefile2
-rw-r--r--www/dalbum/pkg-plist2
7 files changed, 18 insertions, 12 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index a08a83420e4..1499103d309 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1348,6 +1348,11 @@ MAKE_ENV+= TMPDIR="${TMPDIR}"
CONFIGURE_ENV+= TMPDIR="${TMPDIR}"
.endif # defined(TMPDIR)
+# Reset value from bsd.own.mk.
+.if defined(WITH_DEBUG) && !defined(WITHOUT_DEBUG)
+STRIP= #none
+.endif
+
# Start of pre-makefile section.
.if !defined(AFTERPORTMK) && !defined(INOPTIONSMK)
@@ -1638,7 +1643,7 @@ SUB_LIST+= PREFIX=${PREFIX} LOCALBASE=${LOCALBASE} X11BASE=${X11BASE} \
WWWDIR=${WWWDIR} ETCDIR=${ETCDIR}
PLIST_REINPLACE+= dirrmtry stopdaemon rmtry
-PLIST_REINPLACE_DIRRMTRY=s!^@dirrmtry \(.*\)!@unexec rmdir %D/\1 2>/dev/null || true!
+PLIST_REINPLACE_DIRRMTRY=s!^@dirrmtry \(.*\)!@unexec rmdir "%D/\1" 2>/dev/null || true!
PLIST_REINPLACE_RMTRY=s!^@rmtry \(.*\)!@unexec rm -f %D/\1 2>/dev/null || true!
PLIST_REINPLACE_STOPDAEMON=s!^@stopdaemon \(.*\)!@unexec %D/etc/rc.d/\1 forcestop 2>/dev/null || true!
@@ -1655,7 +1660,6 @@ CFLAGS:= ${CFLAGS:C/${_CPUCFLAGS}//}
.endif
.if defined(WITH_DEBUG) && !defined(WITHOUT_DEBUG)
-STRIP= #none
STRIP_CMD= ${TRUE}
DEBUG_FLAGS?= -g
CFLAGS:= ${CFLAGS:N-O*:N-fno-strict*} ${DEBUG_FLAGS}
@@ -3571,7 +3575,7 @@ do-fetch:
SORTED_MASTER_SITES_CMD_TMP="${SORTED_MASTER_SITES_DEFAULT_CMD}" ; \
fi; \
for site in `eval $$SORTED_MASTER_SITES_CMD_TMP ${_RANDOMIZE_SITES}`; do \
- ${ECHO_MSG} "=> Attempting to fetch $${site}/$${file}"; \
+ ${ECHO_MSG} "=> Attempting to fetch $${site}$${file}"; \
CKSIZE=`alg=SIZE; ${DISTINFO_DATA}`; \
case $${file} in \
*/*) ${MKDIR} $${file%/*}; \
@@ -3623,7 +3627,7 @@ do-fetch:
SORTED_PATCH_SITES_CMD_TMP="${SORTED_PATCH_SITES_DEFAULT_CMD}" ; \
fi; \
for site in `eval $$SORTED_PATCH_SITES_CMD_TMP`; do \
- ${ECHO_MSG} "=> Attempting to fetch $${site}/$${file}"; \
+ ${ECHO_MSG} "=> Attempting to fetch $${site}$${file}"; \
CKSIZE=`alg=SIZE; ${DISTINFO_DATA}`; \
case $${file} in \
*/*) ${MKDIR} $${file%/*}; \
diff --git a/games/inform7/Makefile b/games/inform7/Makefile
index ebcfcdfb11e..239e5a6a8c0 100644
--- a/games/inform7/Makefile
+++ b/games/inform7/Makefile
@@ -7,6 +7,7 @@
PORTNAME= inform7
PORTVERSION= 6G60
+PORTREVISION= 1
CATEGORIES= games
MASTER_SITES= http://ftp.ifarchive.org/if-archive/infocom/compilers/inform7/source/:1 \
http://ifarchive.heanet.ie/if-archive/infocom/compilers/inform7/source/:1 \
diff --git a/games/inform7/pkg-plist b/games/inform7/pkg-plist
index a4832164a7e..3c2841e2c4a 100644
--- a/games/inform7/pkg-plist
+++ b/games/inform7/pkg-plist
@@ -97,9 +97,9 @@ bin/ni
@dirrmtry %%DATADIR%%/Extensions/Reserved/Templates/Classic
@dirrmtry %%DATADIR%%/Extensions/Reserved/Templates
@dirrmtry %%DATADIR%%/Extensions/Reserved
-@dirrmtry %%DATADIR%%/Extensions/Graham\ Nelson
-@dirrmtry %%DATADIR%%/Extensions/Eric\ Eve
-@dirrmtry %%DATADIR%%/Extensions/Emily\ Short
-@dirrmtry %%DATADIR%%/Extensions/David\ Fisher
+@dirrmtry %%DATADIR%%/Extensions/Graham Nelson
+@dirrmtry %%DATADIR%%/Extensions/Eric Eve
+@dirrmtry %%DATADIR%%/Extensions/Emily Short
+@dirrmtry %%DATADIR%%/Extensions/David Fisher
@dirrmtry %%DATADIR%%/Extensions
@dirrmtry %%DATADIR%%
diff --git a/net/wired/Makefile b/net/wired/Makefile
index 5ed7866327d..5588f42569e 100644
--- a/net/wired/Makefile
+++ b/net/wired/Makefile
@@ -7,6 +7,7 @@
PORTNAME= wired
PORTVERSION= 1.3.4
+PORTREVISION= 1
CATEGORIES= net
MASTER_SITES= http://mirror.mcx2.org/
diff --git a/net/wired/pkg-plist b/net/wired/pkg-plist
index bb21c99b30e..4bedb7278d1 100644
--- a/net/wired/pkg-plist
+++ b/net/wired/pkg-plist
@@ -28,8 +28,8 @@ bin/wiredctl
@dirrmtry wired/tmp
@dirrmtry wired/files/Uploads/.wired
@dirrmtry wired/files/Uploads
-@dirrmtry wired/files/Drop\ Box/.wired
-@dirrmtry wired/files/Drop\ Box
+@dirrmtry wired/files/Drop Box/.wired
+@dirrmtry wired/files/Drop Box
@dirrmtry wired/files
@dirrmtry wired/etc
@dirrmtry wired
diff --git a/www/dalbum/Makefile b/www/dalbum/Makefile
index 119b165123c..cdad2989043 100644
--- a/www/dalbum/Makefile
+++ b/www/dalbum/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dalbum
PORTVERSION= 140.152
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= www
MASTER_SITES= http://www.dalbum.org/
DISTNAME= ${PORTNAME}${PORTVERSION:S/./_/}
diff --git a/www/dalbum/pkg-plist b/www/dalbum/pkg-plist
index 9d872c59529..d4b433b9924 100644
--- a/www/dalbum/pkg-plist
+++ b/www/dalbum/pkg-plist
@@ -81,7 +81,7 @@
%%DALBUM_DIR%%/reindex.php
%%DALBUM_DIR%%/showimg.php
%%DALBUM_DIR%%/version.txt
-@dirrmtry %%DALBUM_DIR%%/pictures/Sample\ album
+@dirrmtry %%DALBUM_DIR%%/pictures/Sample album
@dirrmtry %%DALBUM_DIR%%/pictures
@dirrm %%DALBUM_DIR%%/include/lang
@dirrm %%DALBUM_DIR%%/include