aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--irc/xchat-gnome/Makefile5
-rw-r--r--irc/xchat2/Makefile5
2 files changed, 6 insertions, 4 deletions
diff --git a/irc/xchat-gnome/Makefile b/irc/xchat-gnome/Makefile
index bc40d7ea535..c4131b548f5 100644
--- a/irc/xchat-gnome/Makefile
+++ b/irc/xchat-gnome/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xchat2
PORTVERSION= 1.9.4
+PORTREVISION= 1
CATEGORIES= irc gnome ipv6
MASTER_SITES= http://xchat.org/files/source/1.9/ \
http://xchat.linuxpower.org/files/source/1.9/
@@ -24,8 +25,8 @@ USE_GNOMENG= yes
USE_GNOME= gnomeprefix gnomehack
GNU_CONFIGURE= yes
USE_REINPLACE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --enable-nls \
--enable-ipv6 \
--enable-perl
diff --git a/irc/xchat2/Makefile b/irc/xchat2/Makefile
index bc40d7ea535..c4131b548f5 100644
--- a/irc/xchat2/Makefile
+++ b/irc/xchat2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= xchat2
PORTVERSION= 1.9.4
+PORTREVISION= 1
CATEGORIES= irc gnome ipv6
MASTER_SITES= http://xchat.org/files/source/1.9/ \
http://xchat.linuxpower.org/files/source/1.9/
@@ -24,8 +25,8 @@ USE_GNOMENG= yes
USE_GNOME= gnomeprefix gnomehack
GNU_CONFIGURE= yes
USE_REINPLACE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
- LIBS="-L${LOCALBASE}/lib"
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
+ LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
CONFIGURE_ARGS= --enable-nls \
--enable-ipv6 \
--enable-perl