aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--multimedia/kino/Makefile2
-rw-r--r--multimedia/kino/distinfo6
-rw-r--r--multimedia/kino/files/patch-src::kino_common.cc16
-rw-r--r--multimedia/kino/files/patch-src__page_export_1394.cc10
-rw-r--r--multimedia/kino/files/patch-src__timfx__kino_plugin_types.h17
-rw-r--r--multimedia/kino/pkg-plist99
6 files changed, 107 insertions, 43 deletions
diff --git a/multimedia/kino/Makefile b/multimedia/kino/Makefile
index c8cb07a5a03..59c01591979 100644
--- a/multimedia/kino/Makefile
+++ b/multimedia/kino/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= kino
-PORTVERSION= 0.9.3
+PORTVERSION= 0.9.4
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/multimedia/kino/distinfo b/multimedia/kino/distinfo
index 8f67bb4e4fc..74910d7dbb5 100644
--- a/multimedia/kino/distinfo
+++ b/multimedia/kino/distinfo
@@ -1,3 +1,3 @@
-MD5 (kino-0.9.3.tar.gz) = 5ba8e3ab848eee39391c49f17b8cf226
-SHA256 (kino-0.9.3.tar.gz) = 70b98bccb2f0df81fa7244e83ed876d291fb4f95971d3a4bedd7c5bdeb9f6a39
-SIZE (kino-0.9.3.tar.gz) = 1585866
+MD5 (kino-0.9.4.tar.gz) = 7afb36c0c6d803b6d890ea5d3913bf0a
+SHA256 (kino-0.9.4.tar.gz) = 58c3812def324c02b8eee11655d883129ea710177395a458d43bb372517aa225
+SIZE (kino-0.9.4.tar.gz) = 1911931
diff --git a/multimedia/kino/files/patch-src::kino_common.cc b/multimedia/kino/files/patch-src::kino_common.cc
index 6454a81a71c..68888f3089c 100644
--- a/multimedia/kino/files/patch-src::kino_common.cc
+++ b/multimedia/kino/files/patch-src::kino_common.cc
@@ -1,6 +1,14 @@
---- src/kino_common.cc.orig Tue Apr 6 15:28:50 2004
-+++ src/kino_common.cc Tue Apr 13 18:48:18 2004
-@@ -1080,7 +1080,8 @@
+--- src/kino_common.cc.orig Fri Dec 15 09:49:52 2006
++++ src/kino_common.cc Mon Dec 25 23:46:08 2006
+@@ -34,6 +34,7 @@
+ #ifndef _GNU_SOURCE
+ #define _GNU_SOURCE
+ #endif
++#include <libgen.h>
+ #include <string.h>
+ #include <stdarg.h>
+ #include <time.h>
+@@ -1486,7 +1487,8 @@
Frame *frame = GetFramePool()->GetFrame();
if ( frame != NULL )
{
@@ -10,7 +18,7 @@
GError *gerror = NULL;
this->getPlayList()->GetFrame( this->g_currentFrame, *frame );
-@@ -1115,6 +1116,7 @@
+@@ -1521,6 +1523,7 @@
g_error_free( gerror );
}
g_object_unref( im );
diff --git a/multimedia/kino/files/patch-src__page_export_1394.cc b/multimedia/kino/files/patch-src__page_export_1394.cc
index 37c87364143..8ab73090478 100644
--- a/multimedia/kino/files/patch-src__page_export_1394.cc
+++ b/multimedia/kino/files/patch-src__page_export_1394.cc
@@ -1,5 +1,5 @@
---- src/page_export_1394.cc.orig Sun May 21 23:03:27 2006
-+++ src/page_export_1394.cc Tue Jul 18 22:59:27 2006
+--- src/page_export_1394.cc.orig Sat Dec 23 08:24:23 2006
++++ src/page_export_1394.cc Mon Dec 25 23:37:13 2006
@@ -63,6 +63,7 @@
void Export1394::start()
@@ -9,9 +9,9 @@
gchar s[ 512 ];
@@ -140,6 +141,7 @@
- );
- #endif
-
+ {
+ gtk_widget_set_sensitive ( GTK_WIDGET ( tmp ), FALSE );
+ }
+#endif
}
diff --git a/multimedia/kino/files/patch-src__timfx__kino_plugin_types.h b/multimedia/kino/files/patch-src__timfx__kino_plugin_types.h
deleted file mode 100644
index f2e6ef8c0ad..00000000000
--- a/multimedia/kino/files/patch-src__timfx__kino_plugin_types.h
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/timfx/kino_plugin_types.h.orig Mon Oct 3 05:13:13 2005
-+++ src/timfx/kino_plugin_types.h Sat Dec 17 22:00:05 2005
-@@ -2,13 +2,13 @@
- #define KINO_PLUGIN_TYPES_H
-
- #include "kino_plugin_utility.h"
-+#include <sys/types.h>
-
- #include <algorithm>
- #include <cmath>
- #include <functional>
- #include <iostream>
- #include <string>
--#include <stdint.h>
-
- namespace kino
- {
diff --git a/multimedia/kino/pkg-plist b/multimedia/kino/pkg-plist
index 429496a29ae..f306d7b542e 100644
--- a/multimedia/kino/pkg-plist
+++ b/multimedia/kino/pkg-plist
@@ -7,11 +7,19 @@ include/kino/image_create.h
include/kino/image_filters.h
include/kino/image_transitions.h
include/kino/kino_extra.h
+include/kino/kino_plugin_types.h
+include/kino/kino_plugin_utility.h
include/kino/playlist.h
+include/kino/smiltime.h
+include/kino/time_map.h
lib/kino-gtk2/libdvtitler.a
lib/kino-gtk2/libdvtitler.la
lib/kino-gtk2/libdvtitler.so
lib/kino-gtk2/libdvtitler.so.0
+lib/kino-gtk2/libkinoplus.a
+lib/kino-gtk2/libkinoplus.la
+lib/kino-gtk2/libkinoplus.so
+lib/kino-gtk2/libkinoplus.so.0
lib/kino-gtk2/libtimfx.a
lib/kino-gtk2/libtimfx.la
lib/kino-gtk2/libtimfx.so
@@ -30,6 +38,7 @@ share/gnome/kino/insert_before.png
share/gnome/kino/join.xpm
share/gnome/kino/kino.glade
share/gnome/kino/kino.png
+share/gnome/kino/kinoplus.glade
share/gnome/kino/link.xpm
share/gnome/kino/link_off.xpm
share/gnome/kino/magick.glade
@@ -58,19 +67,76 @@ share/gnome/kino/timfx.glade
share/gnome/kino/trim.png
share/gnome/kino/trim_in.xpm
share/gnome/kino/trim_out.xpm
-share/gnome/kino/help/commands.html
-share/gnome/kino/help/edit.html
-share/gnome/kino/help/export.html
-share/gnome/kino/help/fx.html
-share/gnome/kino/help/index.html
-share/gnome/kino/help/intro.html
-share/gnome/kino/help/kino_ui.png
-share/gnome/kino/help/prefs.html
-share/gnome/kino/help/publish.html
-share/gnome/kino/help/terms.html
-share/gnome/kino/help/time.html
-share/gnome/kino/help/trim.html
-share/gnome/kino/help/ui.html
+share/gnome/kino/help/en/AutoSplit.html
+share/gnome/kino/help/en/FX.html
+share/gnome/kino/help/en/GNU-FDL.html
+share/gnome/kino/help/en/appendix.html
+share/gnome/kino/help/en/aspectratio.html
+share/gnome/kino/help/en/capture.html
+share/gnome/kino/help/en/developers.html
+share/gnome/kino/help/en/docbook.css
+share/gnome/kino/help/en/dropframe.html
+share/gnome/kino/help/en/droppedframes.html
+share/gnome/kino/help/en/edit.html
+share/gnome/kino/help/en/export.html
+share/gnome/kino/help/en/export_audio.html
+share/gnome/kino/help/en/export_dv.html
+share/gnome/kino/help/en/export_export.html
+share/gnome/kino/help/en/export_ieee1394.html
+share/gnome/kino/help/en/export_other.html
+share/gnome/kino/help/en/export_selection.html
+share/gnome/kino/help/en/framedropping.html
+share/gnome/kino/help/en/fx_audio.html
+share/gnome/kino/help/en/fx_selection.html
+share/gnome/kino/help/en/fx_video.html
+share/gnome/kino/help/en/index.html
+share/gnome/kino/help/en/interfieldmotion.html
+share/gnome/kino/help/en/interlace.html
+share/gnome/kino/help/en/intro.html
+share/gnome/kino/help/en/jogshuttle.html
+share/gnome/kino/help/en/keyboard.html
+share/gnome/kino/help/en/kino.xml
+share/gnome/kino/help/en/links.html
+share/gnome/kino/help/en/locked.html
+share/gnome/kino/help/en/media/ui/kinoui.png
+share/gnome/kino/help/en/metadata.html
+share/gnome/kino/help/en/metadata_example.html
+share/gnome/kino/help/en/metanames.html
+share/gnome/kino/help/en/metavalues.html
+share/gnome/kino/help/en/mode.html
+share/gnome/kino/help/en/movie.html
+share/gnome/kino/help/en/mpeg.html
+share/gnome/kino/help/en/newprojecturi.html
+share/gnome/kino/help/en/newprojectxpath.html
+share/gnome/kino/help/en/overwrite_insert.html
+share/gnome/kino/help/en/pointclick.html
+share/gnome/kino/help/en/prefs.html
+share/gnome/kino/help/en/prefs0.html
+share/gnome/kino/help/en/prefs1.html
+share/gnome/kino/help/en/prefs2.html
+share/gnome/kino/help/en/prefs3.html
+share/gnome/kino/help/en/prefs4.html
+share/gnome/kino/help/en/prefs5.html
+share/gnome/kino/help/en/prefs7.html
+share/gnome/kino/help/en/preview.html
+share/gnome/kino/help/en/publish.html
+share/gnome/kino/help/en/render.html
+share/gnome/kino/help/en/scene.html
+share/gnome/kino/help/en/scrubbar.html
+share/gnome/kino/help/en/shuttle.html
+share/gnome/kino/help/en/stills.html
+share/gnome/kino/help/en/terms.html
+share/gnome/kino/help/en/time.html
+share/gnome/kino/help/en/timecode.html
+share/gnome/kino/help/en/timeentry.html
+share/gnome/kino/help/en/timeformats.html
+share/gnome/kino/help/en/transport.html
+share/gnome/kino/help/en/trim.html
+share/gnome/kino/help/en/trim_conclusion.html
+share/gnome/kino/help/en/trim_storyboard.html
+share/gnome/kino/help/en/trimloader.html
+share/gnome/kino/help/en/ui.html
+share/gnome/kino/help/en/vi.html
share/gnome/kino/scripts/help.sh
share/gnome/kino/scripts/dvdauthor/dvdauthor-k3b.sh
share/gnome/kino/scripts/dvdauthor/dvdauthor.sh
@@ -97,6 +163,7 @@ share/gnome/kino/scripts/exports/ffmpeg_xvid_dual.sh
share/gnome/kino/scripts/exports/mencoder.sh
share/gnome/kino/scripts/exports/mencoder_dual.sh
share/gnome/kino/scripts/exports/rawplay.sh
+share/gnome/kino/scripts/import/audio.sh
share/gnome/kino/scripts/import/media.sh
share/gnome/kino/scripts/publish/frame.sh
share/gnome/kino/scripts/publish/project.sh
@@ -133,7 +200,10 @@ share/gnome/kino/lumas/iris_circle.png
share/gnome/kino/lumas/iris_rectangle.png
share/gnome/kino/lumas/left_to_right.png
share/gnome/kino/lumas/matrix_snake_toplefthorizontal.png
+share/gnome/kino/lumas/none.png
share/gnome/kino/lumas/symmetric_clock.png
+share/gnome/pixmaps/gqview.png
+share/gnome/pixmaps/svg-viewer.svg
share/gnome/pixmaps/kino.png
share/locale/cs/LC_MESSAGES/kino.mo
share/locale/da/LC_MESSAGES/kino.mo
@@ -150,6 +220,9 @@ share/locale/sv/LC_MESSAGES/kino.mo
share/mime/packages/kino.xml
@dirrm include/kino
@dirrm lib/kino-gtk2
+@dirrm share/gnome/kino/help/en/media/ui
+@dirrm share/gnome/kino/help/en/media
+@dirrm share/gnome/kino/help/en
@dirrm share/gnome/kino/help
@dirrm share/gnome/kino/lumas
@dirrm share/gnome/kino/scripts/dvdauthor