aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Catalyst-Plugin-PageCache/Makefile29
-rw-r--r--www/p5-Catalyst-Plugin-PageCache/distinfo3
-rw-r--r--www/p5-Catalyst-Plugin-PageCache/pkg-descr10
-rw-r--r--www/p5-Catalyst-Plugin-PageCache/pkg-plist3
5 files changed, 46 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index 16c8b1afb46..fcd713d66f7 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -505,6 +505,7 @@
SUBDIR += p5-Catalyst-Plugin-FormValidator
SUBDIR += p5-Catalyst-Plugin-FormValidator-Simple
SUBDIR += p5-Catalyst-Plugin-I18N
+ SUBDIR += p5-Catalyst-Plugin-PageCache
SUBDIR += p5-Catalyst-Plugin-Pluggable
SUBDIR += p5-Catalyst-Plugin-Prototype
SUBDIR += p5-Catalyst-Plugin-Session
diff --git a/www/p5-Catalyst-Plugin-PageCache/Makefile b/www/p5-Catalyst-Plugin-PageCache/Makefile
new file mode 100644
index 00000000000..bb426be1bf8
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-PageCache/Makefile
@@ -0,0 +1,29 @@
+# Ports collection makefile for: p5-Catalyst-Plugin-PageCache
+# Date created: Dec 19, 2005
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Catalyst-Plugin-PageCache
+PORTVERSION= 0.11
+CATEGORIES= www perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= Catalyst
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Cache the output of entire pages
+
+BUILD_DEPENDS= p5-Catalyst>=5.23:${PORTSDIR}/www/p5-Catalyst
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_MODBUILD= yes
+
+MAN3= Catalyst::Plugin::PageCache.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} < 500801
+IGNORE= requires at least Perl 5.8.1. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>
diff --git a/www/p5-Catalyst-Plugin-PageCache/distinfo b/www/p5-Catalyst-Plugin-PageCache/distinfo
new file mode 100644
index 00000000000..bd2ad91618e
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-PageCache/distinfo
@@ -0,0 +1,3 @@
+MD5 (Catalyst-Plugin-PageCache-0.11.tar.gz) = 00a8a896187b33691066917d458c92da
+SHA256 (Catalyst-Plugin-PageCache-0.11.tar.gz) = ec52bbb848c24010102cdfc2edeaae679014a2ef74595b27669380634df42e7f
+SIZE (Catalyst-Plugin-PageCache-0.11.tar.gz) = 8117
diff --git a/www/p5-Catalyst-Plugin-PageCache/pkg-descr b/www/p5-Catalyst-Plugin-PageCache/pkg-descr
new file mode 100644
index 00000000000..c125054587d
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-PageCache/pkg-descr
@@ -0,0 +1,10 @@
+Many dynamic websites perform heavy processing on most pages, yet this
+information may rarely change from request to request. Using the
+PageCache plugin, you can cache the full output of different pages so
+they are served to your visitors as fast as possible. This method of
+caching is very useful for withstanding a Slashdotting, for example.
+
+This plugin requires that you also load a Cache plugin. Please see the
+Known Issues when choosing a cache backend.
+
+WWW: http://search.cpan.org/dist/Catalyst-Plugin-PageCache/
diff --git a/www/p5-Catalyst-Plugin-PageCache/pkg-plist b/www/p5-Catalyst-Plugin-PageCache/pkg-plist
new file mode 100644
index 00000000000..8f7f4e981ca
--- /dev/null
+++ b/www/p5-Catalyst-Plugin-PageCache/pkg-plist
@@ -0,0 +1,3 @@
+%%SITE_PERL%%/Catalyst/Plugin/PageCache.pm
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst/Plugin 2>/dev/null || true
+@unexec rmdir %D/%%SITE_PERL%%/Catalyst 2>/dev/null || true