aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--net/Makefile1
-rw-r--r--net/ipex/Makefile18
-rw-r--r--net/ipex/distinfo1
-rw-r--r--net/ipex/pkg-comment1
-rw-r--r--net/ipex/pkg-descr13
-rw-r--r--net/ipex/pkg-plist1
6 files changed, 35 insertions, 0 deletions
diff --git a/net/Makefile b/net/Makefile
index afac22615b8..5a5c6766a4b 100644
--- a/net/Makefile
+++ b/net/Makefile
@@ -168,6 +168,7 @@
SUBDIR += ipcalc
SUBDIR += ipcheck
SUBDIR += iperf
+ SUBDIR += ipex
SUBDIR += ipfm
SUBDIR += ipfw-graph
SUBDIR += iplog
diff --git a/net/ipex/Makefile b/net/ipex/Makefile
new file mode 100644
index 00000000000..36c3cb7bd11
--- /dev/null
+++ b/net/ipex/Makefile
@@ -0,0 +1,18 @@
+# New ports collection makefile for: ipex
+# Date created: 5 January 2002
+# Whom: C.S. Peron <maneo@bsdpro.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= ipex
+PORTVERSION= 2.3.2
+CATEGORIES= net
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ipex
+
+MAINTAINER= maneo@bsdpro.com
+
+GNU_CONFIGURE= yes
+
+.include <bsd.port.mk>
diff --git a/net/ipex/distinfo b/net/ipex/distinfo
new file mode 100644
index 00000000000..7e5aef9f73d
--- /dev/null
+++ b/net/ipex/distinfo
@@ -0,0 +1 @@
+MD5 (ipex-2.3.2.tar.gz) = 6945318ab31b078f0ce024c6df2dd601
diff --git a/net/ipex/pkg-comment b/net/ipex/pkg-comment
new file mode 100644
index 00000000000..3b8b6b95700
--- /dev/null
+++ b/net/ipex/pkg-comment
@@ -0,0 +1 @@
+Packet examination / dumper utility
diff --git a/net/ipex/pkg-descr b/net/ipex/pkg-descr
new file mode 100644
index 00000000000..3ff197c7d50
--- /dev/null
+++ b/net/ipex/pkg-descr
@@ -0,0 +1,13 @@
+The ipex program is similar to ngrep or tcpdump. It
+allows you to dump packet contents in hexidecimal or
+plaintext. A very handy tool for debugging network proto-
+cols. ipex also gives you the option of running in daemon
+mode while dumping contents to a specified file. It also
+allows you to supply a regex RC pattern for printing pack-
+ets wich contain specific patterns. This man page comes
+with some fairly descriptive examples.
+
+WWW: http://ipex.sourceforge.net
+
+- C.S. Peron
+maneo@bsdpro.com
diff --git a/net/ipex/pkg-plist b/net/ipex/pkg-plist
new file mode 100644
index 00000000000..d74fa6882df
--- /dev/null
+++ b/net/ipex/pkg-plist
@@ -0,0 +1 @@
+bin/ipex