aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--lang/modula-3-lib/scripts/configure12
1 files changed, 11 insertions, 1 deletions
diff --git a/lang/modula-3-lib/scripts/configure b/lang/modula-3-lib/scripts/configure
index 2e1002978d4..7a814e57703 100644
--- a/lang/modula-3-lib/scripts/configure
+++ b/lang/modula-3-lib/scripts/configure
@@ -1,6 +1,6 @@
#! /bin/sh
#
-# $Id: configure,v 1.1.1.1 1996/10/29 23:01:55 jdp Exp $
+# $Id: configure,v 1.2 1998/05/29 17:58:09 jdp Exp $
umask 022
@@ -17,10 +17,20 @@ else
exit 1
fi
+if [ -f /usr/lib/libgcc.a ]; then
+ libgcc=/usr/lib/libgcc.a
+elif [ -f /usr/lib/aout/libgcc.a ]; then
+ libgcc=/usr/lib/aout/libgcc.a
+else
+ echo "Cannot find a \"libgcc.a\" file" >&2
+ exit 1
+fi
+
for i in ${files_to_patch}; do
test -f ${i}.bak || cp -p ${i} ${i}.bak
rm -f ${i}
sed -e "s|/usr/local/|${temp_prefix}/|g" \
-e "s|/usr/lib/crt0\.o|${crt}|g" \
+ -e "s|/usr/lib/libgcc\.a|${libgcc}|g" \
${i}.bak >${i}
done
ss='left'>FilesLines * Update clementine-player to 1.2.3sbruno2014-05-276-79/+22 * Update clementine to deal with clan 3.4 deprecating the register keywordsbruno2014-03-192-1/+14 * Chase the move of libmtp from audio to multimedia.gerald2014-03-101-1/+1 * Update pkg-plist to handle the case where Visualisation is disabled.sbruno2014-01-202-574/+577 * Update distinfo to please portlint: remove MD5, add SIZE.mandree2014-01-141-1/+1 * NO_STAGE doesn't seem to make any difference in build failures reportedsbruno2014-01-121-1/+0 * Put back NO_STAGE that was removed in svn r338393.sbruno2014-01-121-1/+2 * Add QT imageformats to resolve issues with rendering album coverssbruno2014-01-051-2/+4 * - Changed mainteiner from vg to sbrunovg2014-01-041-1/+1 * Trying to be smart, always punishes one in the end.sbruno2014-01-021-1/+2 * Add DropBox & BOX remote file storage support and enable on bysbruno2014-01-021-27/+22 * In preparation for making libtool generate libraries with a sane name, fix allbapt2013-12-111-11/+11 * Use compiler:c++11-lib to get this port to compile on stable/9sbruno2013-12-082-1/+4 * Update to Clementine 1.2.1sbruno2013-12-042-4/+3 * Pointyhat to me.sbruno2013-12-041-4/+4 * Typo fix: s/DEBUS/DBUS/gsbruno2013-12-031-3/+3 * after review from makc@sbruno2013-12-022-14/+6 * Update audio/clementine-player to 1.2.0sbruno2013-11-3013-139/+702 * - Remove manual creation and removal of share/applications, as it's now in th...amdmi32013-10-221-1/+0 * Certain automated tools fail when @FreeBSD.org is not capitalized appropriatly.eadler2013-09-271-1/+1 * Add NO_STAGE all over the place in preparation for the staging support (cat: ...bapt2013-09-201-1/+2 * Add an explicit dependency on pkgconfantoine2013-09-081-1/+1 * - Removed support IMOBILEDEVICE because developers does not support itvg2013-08-251-13/+4 * - Added conflict with Qt3vg2013-08-102-0/+13 * - Add patch which allows to build audio/acoustid-fingerprinter andmakc2013-07-101-0/+1 * - Log:vg2013-06-261-2/+2 * Update to version 1.1.1pawel2013-06-012-4/+3 * - Chase libmtp shlib bumpmiwi2013-03-271-1/+1 * - convert USE_CMAKE to USESmakc2013-03-231-1/+1 * 1: Upgrade protobuf to 2.5.0.vanilla2013-03-181-1/+1 * - Add missing/remove useless dependenciesmakc2013-02-111-21/+10 * - Add missing deps that package links to on live systemspawel2013-02-082-5/+7 * Fix leftovers during deinstall that somehow crept in at r310095.wxs2013-01-101-1/+1 * Update to 1.1.0wxs2013-01-097-630/+193 * - Update multimedia/libxine to 1.2.2 .nox2012-06-231-1/+1 * - Convert USE_QT_VER=4 and QT_COMPONETS to USE_QT4miwi2012-06-061-2/+1 * - update png to 1.5.10dinoex2012-06-01