aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--mail/smtp-gated/Makefile3
-rw-r--r--mail/smtp-gated/files/patch-src__smtp-gated.c14
2 files changed, 16 insertions, 1 deletions
diff --git a/mail/smtp-gated/Makefile b/mail/smtp-gated/Makefile
index 1c81f7c78cf..13f2335a0a4 100644
--- a/mail/smtp-gated/Makefile
+++ b/mail/smtp-gated/Makefile
@@ -3,10 +3,11 @@
PORTNAME= smtp-gated
PORTVERSION= 1.4.20.0
+PORTREVISION= 1
CATEGORIES= mail
MASTER_SITES= http://software.klolik.org/smtp-gated/files/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= danilogondolfo@gmail.com
COMMENT= Proxy for SMTP sessions with virus and spam scan
LICENSE= GPLv2
diff --git a/mail/smtp-gated/files/patch-src__smtp-gated.c b/mail/smtp-gated/files/patch-src__smtp-gated.c
new file mode 100644
index 00000000000..150864b95d0
--- /dev/null
+++ b/mail/smtp-gated/files/patch-src__smtp-gated.c
@@ -0,0 +1,14 @@
+--- ../../smtp-gated-1.4.20.0/src/smtp-gated.c 2013-02-26 08:06:59.000000000 -0300
++++ src/smtp-gated.c 2013-02-28 09:32:47.000000000 -0300
+@@ -820,7 +820,11 @@
+ }
+ } /* cleanup() */
+
++#ifdef __clang__
++static inline void cleanup_exit(int code)
++#else
+ inline void cleanup_exit(int code)
++#endif
+ {
+ cleanup();
+ exit(code);