aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/gn/Makefile57
-rw-r--r--www/gn/distinfo1
-rw-r--r--www/gn/files/patch-aa103
-rw-r--r--www/gn/files/patch-ab94
-rw-r--r--www/gn/pkg-descr2
-rw-r--r--www/gn/pkg-plist9
-rw-r--r--www/gn/scripts/configure13
8 files changed, 0 insertions, 280 deletions
diff --git a/www/Makefile b/www/Makefile
index c1dbcda5d79..3a14094858e 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -105,7 +105,6 @@
SUBDIR += geeklog
SUBDIR += gforge
SUBDIR += glibwww
- SUBDIR += gn
SUBDIR += gnuinfo
SUBDIR += gnujsp
SUBDIR += grail
diff --git a/www/gn/Makefile b/www/gn/Makefile
deleted file mode 100644
index 23a260ff816..00000000000
--- a/www/gn/Makefile
+++ /dev/null
@@ -1,57 +0,0 @@
-# New ports collection makefile for: gn
-# Date created: 20 Sep 1994
-# Whom: adam
-#
-# $FreeBSD$
-#
-
-PORTNAME= gn
-PORTVERSION= 2.24
-CATEGORIES= www
-MASTER_SITES= ${MASTER_SITE_LOCAL} #ftp://ftp.acns.nwu.edu/pub/gn/
-MASTER_SITE_SUBDIR= trevor
-
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Gopher and http server
-
-BROKEN= "Does not compile"
-
-BUILD_DEPENDS= ${WAISDIR}/bin/waisindex:${PORTSDIR}/net/wais
-
-IS_INTERACTIVE= yes
-NO_PACKAGE= "Compiled-in hostnames"
-WAISDIR= ${PORTSDIR}/net/wais/work/freeWAIS-0.5
-
-INETD_CONF= /etc/inetd.conf
-CONF= ' stream tcp nowait nobody ${PREFIX}/libexec/gn gn'
-
-pre-build:
- @${LN} -fs ${WAISDIR}/include ${WRKSRC}/waisgn/ir
- @${LN} -fs ${WAISDIR}/bin ${WRKSRC}/waisgn
-
-pre-install:
- @${MKDIR} ${WRKSRC}/etc ${WRKSRC}/libexec ${WRKSRC}/gnroot
- @cd ${WRKSRC}/gnroot; \
- tar -cf - -C ${WRKSRC} docs | tar xpf - && \
- ${MV} docs/sample.root.menu menu
-
-post-install:
- @cd ${PREFIX}; \
- [ -s etc/gn_mime.types ] && \
- if ! cmp -s etc/gn_mime.types ${WRKSRC}/etc/gn_mime.types; then \
- ${ECHO_MSG} ${MV} etc/gn_mime.types etc/gn_mime.types.old; \
- ${MV} etc/gn_mime.types etc/gn_mime.types.old; \
- fi; \
- [ -s gnroot/menu ] && \
- if ! cmp -s gnroot/menu ${WRKSRC}/gnroot/menu; then \
- ${ECHO_MSG} ${MV} gnroot/menu gnroot/menu.old; \
- ${MV} gnroot/menu gnroot/menu.old; \
- fi; \
- tar -cf - -C ${WRKSRC} gnroot libexec bin etc | tar xpf - && \
- (cd gnroot; ${WRKSRC}/bin/mkcache -r); \
- ${AWK} '$$1 ~ /#*gopher/ && $$6 == "${PREFIX}/libexec/gn" { exit 1 }' \
- ${INETD_CONF} || { \
- ${ECHO_CMD} '#'gopher${CONF} >>${INETD_CONF}; \
- }
-
-.include <bsd.port.mk>
diff --git a/www/gn/distinfo b/www/gn/distinfo
deleted file mode 100644
index 96e2b88c1fa..00000000000
--- a/www/gn/distinfo
+++ /dev/null
@@ -1 +0,0 @@
-MD5 (gn-2.24.tar.gz) = ae5b229ad04cd2e6409cea1a3e78c04b
diff --git a/www/gn/files/patch-aa b/www/gn/files/patch-aa
deleted file mode 100644
index d52cfa7dbd7..00000000000
--- a/www/gn/files/patch-aa
+++ /dev/null
@@ -1,103 +0,0 @@
-*** Makefile.old Fri May 5 08:34:10 1995
---- Makefile Fri May 5 08:40:46 1995
-***************
-*** 7,15 ****
- #
- # Where to put the programs
- #
-! SERVBINDIR = ../bin
- BINDIR = ../bin
-! LIBDIR = ../lib
-
- #
- # Compiler Flags (-I.. *MUST* be included)
---- 7,15 ----
- #
- # Where to put the programs
- #
-! SERVBINDIR = ../libexec
- BINDIR = ../bin
-! LIBDIR = ../etc
-
- #
- # Compiler Flags (-I.. *MUST* be included)
-***************
-*** 43,49 ****
-
-
- all: gn mkcache waisgn sgn
-! install: inst-gn inst-mkcache
- gn: gn/gn
- sgn: gn/sgn
- mkcache: mkcache/mkcache
---- 43,49 ----
-
-
- all: gn mkcache waisgn sgn
-! install: inst-gn inst-mkcache inst-waisgn
- gn: gn/gn
- sgn: gn/sgn
- mkcache: mkcache/mkcache
-*** config.h.org Sat Sep 3 16:51:51 1994
---- config.h Fri Sep 23 10:06:50 1994
-***************
-*** 13,24 ****
- */
-
-
-! #define ROOT_DIR "/your/root/data/dir"
- /*
- * Enter the complete path of your root data directory here.
- */
-
-! #define SUN_OS4
- /*
- Pick one of the following Operating System types which describes
- your system and replace the SUN_OS4 value above
---- 13,24 ----
- */
-
-
-! #define ROOT_DIR "/usr/local/gnroot"
- /*
- * Enter the complete path of your root data directory here.
- */
-
-! #define OTHER
- /*
- Pick one of the following Operating System types which describes
- your system and replace the SUN_OS4 value above
-***************
-*** 48,54 ****
- */
-
-
-! #define MIME_TYPE_FILE "/path/to/src/mkcache/gn_mime.types"
- /*
- * This file contains information permitting mkcache to translate
- * ascertain the MIME "Content-type" from the suffix of a file name
---- 48,54 ----
- */
-
-
-! #define MIME_TYPE_FILE "/usr/local/etc/gn_mime.types"
- /*
- * This file contains information permitting mkcache to translate
- * ascertain the MIME "Content-type" from the suffix of a file name
-***************
-*** 109,115 ****
- * If you wish to run at a different port than 70, edit this line.
- */
-
-! #define DECOMPRESS "/usr/local/bin/zcat"
- /*
- * This is the program which does "on the fly" decompression
- */
---- 109,115 ----
- * If you wish to run at a different port than 70, edit this line.
- */
-
-! #define DECOMPRESS "/usr/bin/zcat"
- /*
- * This is the program which does "on the fly" decompression
- */
diff --git a/www/gn/files/patch-ab b/www/gn/files/patch-ab
deleted file mode 100644
index 642c017e8b2..00000000000
--- a/www/gn/files/patch-ab
+++ /dev/null
@@ -1,94 +0,0 @@
-*** Makefile.old Thu May 4 14:49:25 1995
---- Makefile Thu May 4 14:50:11 1995
-***************
-*** 53,69 ****
- @echo "Making gn"
- (cd gn; $(MAKE) CC="$(CC)" CFLAGS="$(CFLAGS)" LIBS="$(LIBS)" \
- INSTALL="$(INSTALL_STRIP)" BINDIR="$(SERVBINDIR)" )
-!
- gn/sgn: config.h
- @echo "Making sgn"
- (cd gn; $(MAKE) CC="$(CC)" CFLAGS="$(CFLAGS)" LIBS="$(LIBS)" \
- INSTALL="$(INSTALL_STRIP)" BINDIR="$(SERVBINDIR)" sgn )
-!
- mkcache/mkcache: config.h
- @echo "Making mkcache"
- (cd mkcache; $(MAKE) CC="$(CC)" CFLAGS="$(CFLAGS)" LIBS="$(LIBS)" \
- INSTALL="$(INSTALL)" BINDIR="$(BINDIR)" )
-!
- waisgn/waisgn: config.h
- @echo "Making waisgn"
- @if [ -d waisgn/ir ] ; then \
---- 53,69 ----
- @echo "Making gn"
- (cd gn; $(MAKE) CC="$(CC)" CFLAGS="$(CFLAGS)" LIBS="$(LIBS)" \
- INSTALL="$(INSTALL_STRIP)" BINDIR="$(SERVBINDIR)" )
-!
- gn/sgn: config.h
- @echo "Making sgn"
- (cd gn; $(MAKE) CC="$(CC)" CFLAGS="$(CFLAGS)" LIBS="$(LIBS)" \
- INSTALL="$(INSTALL_STRIP)" BINDIR="$(SERVBINDIR)" sgn )
-!
- mkcache/mkcache: config.h
- @echo "Making mkcache"
- (cd mkcache; $(MAKE) CC="$(CC)" CFLAGS="$(CFLAGS)" LIBS="$(LIBS)" \
- INSTALL="$(INSTALL)" BINDIR="$(BINDIR)" )
-!
- waisgn/waisgn: config.h
- @echo "Making waisgn"
- @if [ -d waisgn/ir ] ; then \
-*** gn/Makefile.old Thu May 4 15:05:12 1995
---- gn/Makefile Thu May 4 15:05:19 1995
-***************
-*** 24,30 ****
-
- clean:
- @rm -f *.o *~ gn sgn
-!
- gn.o: gn.h chkcache.h ../config.h
- sgn.o: gn.h gn.c chkcache.h ../config.h
- pselect.o: gn.h ../config.h
---- 24,30 ----
-
- clean:
- @rm -f *.o *~ gn sgn
-!
- gn.o: gn.h chkcache.h ../config.h
- sgn.o: gn.h gn.c chkcache.h ../config.h
- pselect.o: gn.h ../config.h
-*** mkcache/Makefile.old Thu May 4 15:11:06 1995
---- mkcache/Makefile Thu May 4 15:11:06 1995
-***************
-*** 8,14 ****
-
- clean:
- @rm -f *.o *~ mkcache
-!
- mkcache.o: mkcache.h ../config.h
- init.o: mkcache.h ../config.h
- content.o: mkcache.h ../config.h
---- 8,14 ----
-
- clean:
- @rm -f *.o *~ mkcache
-!
- mkcache.o: mkcache.h ../config.h
- init.o: mkcache.h ../config.h
- content.o: mkcache.h ../config.h
-*** waisgn/Makefile.old Thu May 4 15:25:59 1995
---- waisgn/Makefile Thu May 4 15:26:06 1995
-***************
-*** 9,14 ****
-
- clean:
- @rm -f *.o *~ waisgn
-!
- waisgn.o: waisgn.h ../config.h
- ../gn/www.o: ../gn/www.c ../gn/gn.h
---- 9,14 ----
-
- clean:
- @rm -f *.o *~ waisgn
-!
- waisgn.o: waisgn.h ../config.h
- ../gn/www.o: ../gn/www.c ../gn/gn.h
diff --git a/www/gn/pkg-descr b/www/gn/pkg-descr
deleted file mode 100644
index 2b853c5ef3e..00000000000
--- a/www/gn/pkg-descr
+++ /dev/null
@@ -1,2 +0,0 @@
-GN is a combined server for both gopher and http.
-It also has some nice features of its own.
diff --git a/www/gn/pkg-plist b/www/gn/pkg-plist
deleted file mode 100644
index a8e70ff76fa..00000000000
--- a/www/gn/pkg-plist
+++ /dev/null
@@ -1,9 +0,0 @@
-@cwd /usr/local
-etc/gn_mime.types
-libexec/gn
-libexec/sgn
-libexec/waisgn
-bin/mkcache
-gnroot
-@cwd ./gnroot
-@exec ../bin/mkcache -r
diff --git a/www/gn/scripts/configure b/www/gn/scripts/configure
deleted file mode 100644
index b811928e628..00000000000
--- a/www/gn/scripts/configure
+++ /dev/null
@@ -1,13 +0,0 @@
-#!/bin/sh
-#
-
-hostname=`hostname`
-echo -n "Hostname of server machine? [$hostname] "
-read answer; if [ X$answer != X ]; then hostname=$answer; fi
-maintainer="mailto:webmaster@$hostname"
-echo -n "URL to default webmaster? [$maintainer] "
-read answer; if [ X$answer != X ]; then maintainer=$answer; fi
-sed -e "/GN_HOSTNAME/s/\".*\"/\"$hostname\"/" \
- -e "/MAINTAINER/s/\".*\"/\"$maintainer\"/" \
- ${WRKSRC}/config.h >${WRKSRC}/config.h.foo
-mv ${WRKSRC}/config.h.foo ${WRKSRC}/config.h
al&id=4aef5414a36b9333faac24d5900d5502bfde588e'>Remove dependency on the python metaportsantoine2018-02-191-1/+2 * Reduce dependency on the python2 metaportantoine2018-02-1919-26/+29 * Deprecate ports broken for more than 6 monthsantoine2018-02-183-0/+8 * net-im/purple-facebook: fix typoswills2018-02-161-1/+1 * net-im/purple-facebook: create portswills2018-02-164-1/+35 * Bring back dependencies needed to prepare the update of www/gitlab to 10.4tz2018-02-164-0/+31 * Fix Gemfile for rubygem-pg 1.0.0 updatesunpoet2018-02-152-4/+6 * net-im/py-sleekxmpp: Update to 1.3.3yuri2018-02-152-8/+12 * net-im/openfire: update to 4.2.2gahr2018-02-143-18/+17 * Drop maintainershiparved2018-02-131-1/+1 * Drop Maintainershiparved2018-02-131-1/+1 * net-im/py-telepot: Update to 12.0yuri2018-02-122-6/+12 * Rename KDE4 meta portstcberner2018-02-1015-16/+17 * Switch C compiler used to compile GHC to base Clang.tcberner2018-02-101-1/+1 * net-im/purple-discord: create portswills2018-02-096-0/+49 * - Update to 1.65nivit2018-02-073-4/+14 * net-im/mastodon: Set mastodon owner/group only when necessaryjrm2018-02-074-2050/+2050 * - Limit python version, fails with python 3:amdmi32018-02-071-1/+1 * net-im/libpurple: fix PLIST after r460831gahr2018-02-051-2/+2 * Update net-im/py-fbmq to version 2.4.4.olgeni2018-02-052-4/+4 * net-im/mastodon: fix issue with assets pre-compilejrm2018-02-043-115/+133 * - Switch to USES=localbaseamdmi32018-02-042-4/+4 * - Remove bogus (in presence of USE_GITHUB) USES=tar*amdmi32018-02-031-4/+5 * Flavorize and modernize Emacs portsjrm2018-02-021-11/+9 * net-im/py-matrix-synapse: Update pkg-messagefeld2018-01-311-1/+1 * Fix with DEFAULT_VERSIONS=python=3.xantoine2018-01-311-1/+1 * net-im/py-pyxmpp: mark deprecatedrm2018-01-311-0/+3 * net-im/gajim: update to 0.6.19rm2018-01-313-92/+4 * net-im/py-nbxmpp: update to 0.6.3rm2018-01-312-4/+4 * net-im/mastodon: Update to 2.2.0jrm2018-01-309-659/+663 * Add upstream patch for compatibility with newer security/py-openssl.des2018-01-292-0/+88 * net-im/mastodon: depend on devel/rubygem-fog-core1jrm2018-01-291-2/+2 * net-im/tkabber: remove expired optional dependency on security/tclgpgrene2018-01-281-2/+1 * - Add LICENSEamdmi32018-01-271-2/+7 * - Update to 3.6.1tota2018-01-262-6/+6 * multimedia/libvpx: update 1.7.0jbeich2018-01-265-2/+5 * Fix PKGNAME collision.mat2018-01-251-1/+1 * - Update to 3.6.0tota2018-01-245-88/+105 * - Update RUN_DEPENDStota2018-01-242-5/+16 * net-im/corebird: Update to 1.7.3cpm2018-01-243-10/+10 * Update net-im/folks to 0.11.4truckman2018-01-244-6/+11 * Fix Gemfile for rubygem-goldfinger 2.1.0 and rubygem-ostatus2 2.0.3 updatesunpoet2018-01-232-5/+14 * - Update to 18.01ashish2018-01-225-184/+176 * ScudCloud is a non official open-source desktop client app for Slack.nivit2018-01-207-0/+86 * Update devel/doxygen to 1.8.14antoine2018-01-202-1/+2 * Options are already optional.mat2018-01-201-1/+3 * - fix PORTREVISIONdinoex2018-01-181-1/+1 * - set BROKEN for FreeBSD-12dinoex2018-01-181-1/+3 * devel/boost-*: update to 1.66.0jbeich2018-01-187-7/+7 * net-im/rubygem-earthquake: update to 1.0.2swills2018-01-152-4/+4 * Move devel/lua-bitop-51 to devel/lua51-bitopsunpoet2018-01-141-1/+2 * Add bitop-51 dependency.lx2018-01-131-1/+2 * net-im/telepathy-gabble: add shebangfix, and some dependenciespi2018-01-121-3/+6 * Assign to perl@adamw2018-01-121-1/+1 * Return kevlo's ports to the pool, he handed in his commit bit.rene2018-01-124-4/+4 * net-im/pidgin-skypeweb: update 1.2.2 -> 1.4pi2018-01-122-5/+4 * net-im/mastodon: Upgrade to version 2.1.3jrm2018-01-105-161/+168 * net-im/ekiga: unbreak build with Clang 6 (C++14 by default)jbeich2018-01-091-0/+39 * Bump PORTREVISION due upgrade of devel/boehm-gc to 7.6.2cpm2018-01-082-2/+2 * Set LLD_UNSAFE=yes that the port will continue to link with ld.bfdkrion2018-01-081-0/+1 * net-im/kopete-kde4, fix build with clang6tcberner2018-01-081-1/+2 * net-im/mastodon: Upgrade to version 2.1.2jrm2018-01-078-375/+503 * Fix Gemfile for rubygem-fog-core 2.0.0 updatesunpoet2018-01-062-2/+7 * net-im/py-matrix-synapse: Update to 0.26.0feld2018-01-052-4/+4 * - Update to 17.12ashish2018-01-035-220/+164 * net-im/mastodon: Fix run-time issues by updating dependenciesjrm2018-01-032-3/+12 * Change RUN_DEPENDS from rubygem-redis to rubygem-redis3sunpoet2018-01-021-2/+2 * New port: net-im/purple-hangoutspi2018-01-015-0/+52 * Update net-im/py-fbmq to version 2.4.3.olgeni2017-12-312-4/+4 * Unbreak `make configure' after r457276.rakuco2017-12-311-2/+2 * Simplify some USES=pythonantoine2017-12-291-1/+1 * Upgrade to 0.1.11.thierry2017-12-283-5/+30 * Fix Gemfile for rubygem-httplog 1.0.0 updatesunpoet2017-12-282-2/+11 * - Update to 17.11ashish2017-12-2710-203/+424 * Remove net-im/p5-Net-AIM, the AIM service was shut down on 2017-12-15rene2017-12-205-38/+0 * New port: net-im/telegram-desktop: Telegram Desktop messaging appyuri2017-12-1940-0/+1312 * Remove net-im/bsflite port that was only useful for the AIM network, which wasehaupt2017-12-184-43/+0 * net-im/mastodon: Update to version 2.1.0jrm2017-12-187-1229/+1823 * net-im/libpurple: quick fix for TLS radio button.olgeni2017-12-171-1/+1 * Remove AIM option from and bump PORTREVISION of the following ports,rene2017-12-177-18/+12 * Update net-im/py-slackclient to version 1.1.0.olgeni2017-12-172-4/+4 * Remove two unmaintained ports that were only useful for the AIM network, whichrene2017-12-165-297/+0 * Clean up the Makefile a bit.marcus2017-12-151-3/+5 * Add missing IGNORE_WITH_PHP for various pecl-ports.tz2017-12-141-1/+1 * Fix packaging with python3antoine2017-12-143-1/+3 * Change RUN_DEPENDS from rubygem-http to rubygem-http2sunpoet2017-12-121-2/+2 * net-im/openfire: update to 4.2.1gahr2017-12-122-4/+4 * Update devel/protobuf to 3.5.0sunpoet2017-12-121-1/+1 * - Those ports fail to build with python3antoine2017-12-113-4/+4 * Update net-im/py-python-telegram-bot to version 9.0.0.olgeni2017-12-092-4/+4 * net-im/openfire: update to 4.2.0gahr2017-12-073-8/+15 * Update net-im/py-fbmq to version 2.4.2.olgeni2017-12-062-4/+4 * - Add explicit FLAVOR to a few dependenciesantoine2017-12-032-10/+10 * Cleanup LIB_DEPENDS on libpngantoine2017-12-011-1/+1 * Convert Python ports to FLAVORS.mat2017-11-3025-115/+104 * For ports that are marked BROKEN on armv6, and also fail to build onlinimon2017-11-302-0/+2 * - Fix LICENSEamdmi32017-11-301-22/+17 * net-im/ricochet: Unbroke the build. ${OPENSSLDIR}/include coflicted with the ...yuri2017-11-292-11/+21 * Fix the build in some cases.thierry2017-11-292-1/+12 * net-im/qTox: Update to 1.13.0yuri2017-11-282-26/+22 * - Fix CAPTCHA functionalityashish2017-11-193-0/+10 * Upgrade to 0.8.1.thierry2017-11-184-15/+21 * Update to 0.10.0.lx2017-11-186-45/+87 * - Update to 17.09ashish2017-11-176-280/+305 * net-im/py-matrix-synapse: Update to 0.25.0feld2017-11-152-4/+4 * net-im/ricochet: add missing dependency (qt5-quickcontrols) and other changesyuri2017-11-131-11/+12 * net-im/mastodon: Handle upgrade of www/node to version 9.0.0jrm2017-11-081-2/+2 * Update net-im/py-fbmq to version 2.4.1.olgeni2017-11-072-4/+4 * GitterDone: A Qt5 front-end to the "Gitter" communications systemaraujo2017-11-065-0/+107 * Fix whitespace issues (mixed tab/spaces, alignment) in a few ports.olgeni2017-11-032-2/+2 * net-im/mastodon: Update the minimum required versions for the dependenciesjrm2017-10-261-3/+3 * Update net-im/py-fbmq to version 2.3.2.olgeni2017-10-252-4/+4 * net-im/py-matrix-synapse: Update to 0.24.1feld2017-10-242-4/+4 * net-im/py-matrix-synapse: Update to 0.24.0feld2017-10-233-118/+4 * - Update libsodium to 1.0.15 [1]vsevolod2017-10-225-3/+5 * Update net-im/qTox to 1.12.1tcberner2017-10-213-28/+19 * multimedia/ffmpeg: update to 3.4jbeich2017-10-213-2/+3 * net-im/pidgin-rocketchat: create portswills2017-10-214-0/+38 * net-im/mastodon: Update to version 2.0.0.jrm2017-10-2012-6978/+7465 * net-im/openfire: update to 4.1.6gahr2017-10-172-4/+4 * Update net-im/py-python-telegram-bot to version 8.1.1.olgeni2017-10-162-4/+4 * - Update to 3.5.12tota2017-10-153-10/+19 * Update net-im/py-python-telegram-bot to version 8.1.0.olgeni2017-10-152-4/+4 * Remove WANT_GNOME and HAVE_GNOME.mat2017-10-122-4/+1 * net-im/linux-telegram-desktop: Update from 1.1.7 to 1.1.23joneum2017-10-083-6/+11 * Remove the mention of MSN and Yahoo! from pkg-descrs.marcus2017-10-053-6/+3 * Remove non functional portbapt2017-10-046-165/+0 * net-im/py-matrix-synapse: Update to 0.23.0feld2017-10-033-5/+119 * Remove net-im/py-twistedWordssunpoet2017-09-304-35/+0 * Make sure we do not include gconf2 when we're notmarcus2017-09-282-2/+2 * net-im/mastodon: Remove Gemfile.lock in the rc scripts before starting webjrm2017-09-273-0/+3 * Update net-im/py-fbmq to version 2.3.1.olgeni2017-09-262-4/+4 * devel/boost-*: update to 1.65.1jbeich2017-09-257-7/+7 * devel/boost-*: enable C++11 featuresjbeich2017-09-257-7/+7 * net-im/mastodon: Fix install with non-default ruby versions by removingjrm2017-09-251-29/+29 * - Update to 17.08ashish2017-09-244-176/+165 * 1: upgrade to 4.0.0.vanilla2017-09-233-2/+3 * Remove USES=execinfo.mat2017-09-223-3/+3 * net-im/sayaka: unbreak build with vala 0.36cpm2017-09-201-0/+29 * Update empathy to 3.12.14.kwm2017-09-193-291/+369 * net-im/mastodon: Update to version 1.6.1jrm2017-09-194-217/+243 * Sort *_DEPENDSsunpoet2017-09-181-3/+3 * net-im/mastodon: Fix issue running database migration scriptjrm2017-09-162-5/+13 * net-im/mastodon: Update to version 1.6.0jrm2017-09-167-130/+19048 * Fix license information for portgs that use "the same license as Perl".mat2017-09-155-5/+5 * unMessage is a peer-to-peer instant messaging application designed to enhanceultima2017-09-144-0/+48 * Chase Emacs updateashish2017-09-121-1/+1 * Bump PORTREVISION for ports depending on the canonical version of GCCgerald2017-09-1114-10/+14 * Update net-im/py-slackclient to version 1.0.9.olgeni2017-09-082-4/+4 * - Update to 3.5.11tota2017-09-052-4/+4 * Change from USES=twisted to devel/py-twistedsunpoet2017-09-041-2/+5 * Mark BROKEN: fails to buildantoine2017-09-021-0/+2 * Update net-im/py-python-telegram-bot to version 8.0.olgeni2017-09-022-4/+4 * - Update to 3.5.9tota2017-08-202-9/+10 * Mark DEPRECATED and set EXPIRATION_DATE to 2017-09-30sunpoet2017-08-201-0/+3 * net-im/gloox: Update to 1.0.20swills2017-08-1814-6/+149 * Update devel/protobuf to 3.4.0sunpoet2017-08-161-1/+1 * net-im/oysttyer: update 2.9.0 -> 2.9.1pi2017-08-112-4/+4 * - Update The Glorious Glasgow Haskell Compiler to version 8.0.2tcberner2017-08-091-1/+1 * net-im/mastodon: Update to version 1.5.1jrm2017-08-073-70/+70 * net-im/mastodon: Work around www/node (node version 8) bug [1] on FreeBSDjrm2017-08-063-4/+28 * net-im/py-matrix-synapse: Forgot the PORTREVISION bumpfeld2017-08-041-1/+1 * Reserve GID for synapse userfeld2017-08-041-1/+2 * net-im/mastodon: Add run-time dependencies necessary for installing nodejrm2017-08-032-17/+5 * Update net-im/py-fbmq to version 2.1.0.olgeni2017-08-022-4/+4 * net-im/mastodon: Update to version 1.5.0jrm2017-08-012-4/+4 * net-im/mastodon: Update to 1.5.0r3jrm2017-07-315-11/+28 * Update net-im/py-python-telegram-bot to version 7.0.1.olgeni2017-07-292-4/+4 * net-im/mastodon: Update to version 1.5.0r2jrm2017-07-2910-178/+160 * Add NO_ARCHsunpoet2017-07-272-49/+50 * Update net-im/jabberd to 2.6.1mm2017-07-262-5/+4 * Update net-im/py-python-telegram-bot to version 7.0.0.olgeni2017-07-262-4/+4 * Update GStreamer1 ports to 1.12.2.kwm2017-07-221-1/+1 * net-im/oysttyer: update 2.8.1 -> 2.9.0pi2017-07-202-5/+4 * net-im/qTox: Update to 1.11.0tcberner2017-07-195-51/+45 * Change RUN_DEPENDS from rubygem-rack-cors to rubygem-rack-cors0sunpoet2017-07-171-2/+2 * Update to 2.2.8sunpoet2017-07-162-5/+4 * Update WWWsunpoet2017-07-161-1/+1 * - Import diff from ejabberd repository, commitid: d4cdc3aashish2017-07-152-3/+18 * net-im/mastodon: Fix plist and patch issues; bump PORTREVISIONjrm2017-07-123-3/+4 * Fix gemspec for rubygem-activerecord4 4.2.1 update (r389119)sunpoet2017-07-122-6/+8 * - Update to 17.07ashish2017-07-106-289/+309 * net-im/openfire: update to 4.1.5gahr2017-07-102-4/+4 * - Update to 1.5.1cpm2017-07-097-41/+11 * net-im/py-matrix-synapse: Update to 0.22.1feld2017-07-082-4/+4 * Update to 1.6.0sunpoet2017-07-072-4/+4 * Add ports for future KDE Telepathy versionstcberner2017-07-068-0/+138 * net-im/mastodon: Update to version 1.4.7jrm2017-07-066-16/+29 * Remove Perl core modulessunpoet2017-06-301-2/+2 * Remove Perl core modulessunpoet2017-06-302-16/+16 * - Silence explicitly called commandcpm2017-06-281-1/+1 * Update devel/readline to 7.0 patch 3sunpoet2017-06-274-3/+4 * Update net-im/py-slackclient to version 1.0.6.olgeni2017-06-262-4/+6 * Make ninja opt-out in cmake.mktcberner2017-06-26