aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--multimedia/totem-gstreamer/Makefile2
-rw-r--r--multimedia/totem/Makefile3
-rw-r--r--multimedia/totem/files/patch-src_totem.c14
3 files changed, 17 insertions, 2 deletions
diff --git a/multimedia/totem-gstreamer/Makefile b/multimedia/totem-gstreamer/Makefile
index 793222af0a6..ba7f4e06519 100644
--- a/multimedia/totem-gstreamer/Makefile
+++ b/multimedia/totem-gstreamer/Makefile
@@ -6,7 +6,7 @@
# $MCom: ports/multimedia/totem-gstreamer/Makefile,v 1.13 2006/03/01 04:32:55 marcus Exp $
#
-PORTREVISION= 1
+PORTREVISION= 2
PKGNAMESUFFIX= -gstreamer
MAINTAINER= gnome@FreeBSD.org
diff --git a/multimedia/totem/Makefile b/multimedia/totem/Makefile
index b4d52e8e06f..1442d360611 100644
--- a/multimedia/totem/Makefile
+++ b/multimedia/totem/Makefile
@@ -7,6 +7,7 @@
PORTNAME= totem
PORTVERSION= 2.16.2
+PORTREVISION= 1
CATEGORIES= multimedia gnome
MASTER_SITES= GNOME
DIST_SUBDIR= gnome2
@@ -67,7 +68,7 @@ CONFIGURE_ARGS+=--without-mozilla \
.if defined(WITH_GSTREAMER)
CONFIGURE_ARGS+=--enable-gstreamer=yes
-USE_GSTREAMER+= gnomevfs core gconf hal good
+USE_GSTREAMER+= gnomevfs core gconf hal good mpeg2dec ugly
WITHOUT_DVDNAV= yes
PLIST_SUB+= GSTREAMER=""
.else
diff --git a/multimedia/totem/files/patch-src_totem.c b/multimedia/totem/files/patch-src_totem.c
new file mode 100644
index 00000000000..da8b5dc31a1
--- /dev/null
+++ b/multimedia/totem/files/patch-src_totem.c
@@ -0,0 +1,14 @@
+--- src/totem.c.orig Sat Oct 21 22:10:07 2006
++++ src/totem.c Sat Oct 21 22:11:56 2006
+@@ -339,7 +339,11 @@
+
+ g_object_get (G_OBJECT (totem->bvw),
+ "mediadev", &device, NULL);
++#if defined (__FreeBSD__)
++ cmd = g_strdup_printf ("cdcontrol -f %s eject", device);
++#else
+ cmd = g_strdup_printf ("eject %s", device);
++#endif
+ g_free (device);
+
+ if (g_spawn_command_line_sync (cmd, NULL, NULL, NULL, &err) == FALSE)
10877bc3c48a07c3b0'>upgrade to 0.6ijliao2003-02-123-2/+3 * URL updates for multiple portsedwin2003-02-122-4/+4 * Use USE_GNOME = gnomehack instead of patching Makefile.in.nobutaka2003-02-112-11/+1 * Update to 1.0.10pat2003-02-113-22/+3 * Update to 1.0.11pat2003-02-115-18/+43 * Enable runtime decompression support.marcus2003-02-112-1/+5 * Changed to use REINPLACE.markp2003-02-102-3/+6 * Convert COMMENT to COMMENTFILE until these ports can be converted.kris2003-02-101-1/+1 * Set NOPRECIOUSMAKEVARS to unbreak 'make readmes'kris2003-02-101-0/+1 * (1) Make LOCALBASE clean.nobutaka2003-02-094-4/+35 * Update the Ruby/GNOME2 suite to 0.3.0.knu2003-02-093-2/+5 * Upgrade to 1.0.5.dannyboy2003-02-092-2/+2 * Fix configure with libgnomeprint-2.2.marcus2003-02-092-1/+180 * Fix a problem with Xft2 detection.marcus2003-02-091-2/+3 * Update to 0.5.4 which fixes the build with the new autotrace.marcus2003-02-093-4/+5 * Update to 2.4.6 and chase distfile.dannyboy2003-02-083-4/+4 * add tulip 1.2.2ijliao2003-02-0816-0/+256 * add meshviewer 0.1.2ijliao2003-02-088-0/+85 * upgrade to 1.7ijliao2003-02-083-3/+6 * Update to 0.30, and unbreak now that libgnomeprint support has beenmarcus2003-02-084-140/+9 * Make sure warnings are not fatal when compiling the C++ parts of thismi2003-02-081-1/+1 * o update MASTER_SITES.nork2003-02-081-9/+11 * Change CPPFLAGS+=/LDFLAGS+= to CPPFLAGS=/LDFLAGS=.nork2003-02-085-10/+10 * New port: graphics/kbarcode - barcode generator/printeredwin2003-02-086-0/+72 * Mark sodipodi as broken until it works with libgnomeprint-2-2.marcus2003-02-081-1/+3 * Chase libgnomeui's shared lib version.marcus2003-02-083-3/+6 * Chase gtk20's shared lib version.marcus2003-02-086-7/+12 * Update to GNOME 2.2.marcus2003-02-089-25/+66 * add ocaml-images 2.10ijliao2003-02-0810-0/+221 * upgrade to 0.97ijliao2003-02-072-2/+2 * Avoid usage of != variable assignment.obraun2003-02-071-8/+12 * URL updates.naddy2003-02-071-0/+1 * add sam2p 0.42ijliao2003-02-078-0/+69 * add avinfo 0.5ijliao2003-02-076-0/+57 * Update to 1.0.3.knu2003-02-072-3/+3 * upgrade to 1.4.5ijliao2003-02-063-2/+3 * upgrade to 0.10ijliao2003-02-062-2/+2 * Add missing INSTALLS_SHLIB statement.edwin2003-02-062-0/+2 * Upgrade to 0.5.vanilla2003-02-065-43/+2 * I forgot to remove needless patch files.nork2003-02-056-75/+0 * [Maintainer update]: graphics/xmedcon 0.8.8 -> 0.8.9edwin2003-02-055-42/+44 * Update x-face-e21.el (Face header support).yoichi2003-02-052-2/+2 * Fix for INDEX builds.obraun2003-02-051-1/+1 * Add hs-HOpenGL 1.04, binding for OpenGL and GLUT for the lazy functionalobraun2003-02-058-0/+509 * Maintainer update of graphcs/transcodeedwin2003-02-045-8/+51 * shlib version bump of graphics/autotraceedwin2003-02-041-1/+1 * maintainer update to version 0.31.1edwin2003-02-043-3/+3 * Update to 0.90.0.nobutaka2003-02-033-3/+6 * Update homepageedwin2003-02-031-1/+1 * Fix homepageedwin2003-02-031-1/+1 * Update homepageedwin2003-02-031-1/+1 * graphics/renderpark System for physically based photo-realistic image synthesismaho2003-02-0310-0/+335 * New port: graphics/xrml Extensible scene graph library based on VRML'97maho2003-02-039-0/+611 * New port: graphics/gmtedwin2003-02-037-0/+511 * Correct a path to a patched file.marcus2003-02-031-2/+2 * Update to 0.9.3.nork2003-02-023-4/+74 * Update to 2.20.nork2003-02-0216-591/+378 * Conditionalize libgnugetopt dependencies.nork2003-02-021-4/+9 * Add missing directory.arved2003-02-021-1/+1 * Conditionalize gnugetopt dependencies.nork2003-02-021-5/+8 * Update to 3.33.nork2003-02-025-28/+15 * Conditionalize gnugetopt dependencies and fix minor typo.nork2003-02-021-6/+9 * Conditionalize gnugetopt dependencies.nork2003-02-021-4/+10 * o Support CFLAGS properlynork2003-02-022-9/+29