aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--ftp/wget-devel/Makefile2
-rw-r--r--ftp/wget-devel/files/patch-host.c11
-rw-r--r--ftp/wget/Makefile2
-rw-r--r--ftp/wget/files/patch-host.c11
4 files changed, 24 insertions, 2 deletions
diff --git a/ftp/wget-devel/Makefile b/ftp/wget-devel/Makefile
index 1d498de7477..c188e70e41b 100644
--- a/ftp/wget-devel/Makefile
+++ b/ftp/wget-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= wget
PORTVERSION= 1.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= ftp www ipv6
MASTER_SITES= ${MASTER_SITE_GNU} \
ftp://ftp.dl.ac.uk/ccp14/ftp-mirror/wget/pub/unix/util/wget/ \
diff --git a/ftp/wget-devel/files/patch-host.c b/ftp/wget-devel/files/patch-host.c
new file mode 100644
index 00000000000..9495ff9ec25
--- /dev/null
+++ b/ftp/wget-devel/files/patch-host.c
@@ -0,0 +1,11 @@
+--- src/host.c.orig Thu Aug 9 10:11:56 2001
++++ src/host.c Thu Aug 9 10:12:27 2001
+@@ -106,7 +106,7 @@
+
+ hp = gethostbyname2(name, af);
+ if (!hp) {
+- if (inet_pton(af, name, addr) != -1) {
++ if (inet_pton(af, name, addr) == 1) {
+ switch (af) {
+ case AF_INET:
+ socksize = sizeof (struct sockaddr_in);
diff --git a/ftp/wget/Makefile b/ftp/wget/Makefile
index 1d498de7477..c188e70e41b 100644
--- a/ftp/wget/Makefile
+++ b/ftp/wget/Makefile
@@ -7,7 +7,7 @@
PORTNAME= wget
PORTVERSION= 1.7
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= ftp www ipv6
MASTER_SITES= ${MASTER_SITE_GNU} \
ftp://ftp.dl.ac.uk/ccp14/ftp-mirror/wget/pub/unix/util/wget/ \
diff --git a/ftp/wget/files/patch-host.c b/ftp/wget/files/patch-host.c
new file mode 100644
index 00000000000..9495ff9ec25
--- /dev/null
+++ b/ftp/wget/files/patch-host.c
@@ -0,0 +1,11 @@
+--- src/host.c.orig Thu Aug 9 10:11:56 2001
++++ src/host.c Thu Aug 9 10:12:27 2001
+@@ -106,7 +106,7 @@
+
+ hp = gethostbyname2(name, af);
+ if (!hp) {
+- if (inet_pton(af, name, addr) != -1) {
++ if (inet_pton(af, name, addr) == 1) {
+ switch (af) {
+ case AF_INET:
+ socksize = sizeof (struct sockaddr_in);