aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--devel/simgear/Makefile3
-rw-r--r--devel/simgear/distinfo4
-rw-r--r--devel/simgear/files/patch-CMakeModules-SimGearComponent.cmake12
-rw-r--r--devel/simgear/files/patch-simgear-canvas-ShivaVG-src-shDefs.h (renamed from games/flightgear/files/patch-src-Canvas-ShivaVG-src-shDefs.h)4
-rw-r--r--devel/simgear/pkg-plist110
-rw-r--r--games/flightgear-aircraft/Makefile34
-rw-r--r--games/flightgear-aircraft/distinfo32
-rw-r--r--games/flightgear-data/Makefile8
-rw-r--r--games/flightgear-data/distinfo4
-rw-r--r--games/flightgear/Makefile7
-rw-r--r--games/flightgear/distinfo4
-rw-r--r--games/flightgear/pkg-plist1
12 files changed, 118 insertions, 105 deletions
diff --git a/devel/simgear/Makefile b/devel/simgear/Makefile
index 1ec263953e1..092340a6c63 100644
--- a/devel/simgear/Makefile
+++ b/devel/simgear/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= simgear
-PORTVERSION= 2.8.0
-PORTREVISION= 1
+PORTVERSION= 2.10.0
CATEGORIES= devel games
MASTER_SITES= http://mirrors.ibiblio.org/pub/mirrors/simgear/ftp/Source/ \
ftp://ftp.de.flightgear.org/pub/simgear/Source/ \
diff --git a/devel/simgear/distinfo b/devel/simgear/distinfo
index 459ff0e23c8..0fee0e80529 100644
--- a/devel/simgear/distinfo
+++ b/devel/simgear/distinfo
@@ -1,2 +1,2 @@
-SHA256 (simgear-2.8.0.tar.bz2) = 24758b0d59ba6d03659398c19145d92c2179174040f42739fc2f9c03c0bf90f7
-SIZE (simgear-2.8.0.tar.bz2) = 766340
+SHA256 (simgear-2.10.0.tar.bz2) = 582c0d547a58f7dbe841a0ba9eba5a894aae2b65f14ef06361e196b12022615d
+SIZE (simgear-2.10.0.tar.bz2) = 879537
diff --git a/devel/simgear/files/patch-CMakeModules-SimGearComponent.cmake b/devel/simgear/files/patch-CMakeModules-SimGearComponent.cmake
index 8e120471f83..b5f6b51961c 100644
--- a/devel/simgear/files/patch-CMakeModules-SimGearComponent.cmake
+++ b/devel/simgear/files/patch-CMakeModules-SimGearComponent.cmake
@@ -1,9 +1,7 @@
---- CMakeModules/SimGearComponent.cmake.orig 2012-02-17 23:38:44.620896000 +0100
-+++ CMakeModules/SimGearComponent.cmake 2012-05-15 07:45:27.783988374 +0200
-@@ -1,4 +1,6 @@
-
+--- CMakeModules/SimGearComponent.cmake.orig 2013-02-21 05:58:12.000000000 +0100
++++ CMakeModules/SimGearComponent.cmake 2013-02-21 05:58:58.000000000 +0100
+@@ -1,3 +1,4 @@
+include_directories(BEFORE ${PROJECT_SOURCE_DIR})
-+
- macro(simgear_component_common name includePath sourcesList sources headers)
- if (SIMGEAR_SHARED)
+ macro(simgear_component_common name includePath sourcesList sources headers)
+ set(fc${sourcesList} ${name})
diff --git a/games/flightgear/files/patch-src-Canvas-ShivaVG-src-shDefs.h b/devel/simgear/files/patch-simgear-canvas-ShivaVG-src-shDefs.h
index 88b18b7f334..58c1c4bd4af 100644
--- a/games/flightgear/files/patch-src-Canvas-ShivaVG-src-shDefs.h
+++ b/devel/simgear/files/patch-simgear-canvas-ShivaVG-src-shDefs.h
@@ -1,5 +1,5 @@
---- src/Canvas/ShivaVG/src/shDefs.h.orig 2012-08-28 17:51:24.000000000 +0200
-+++ src/Canvas/ShivaVG/src/shDefs.h 2012-08-28 17:52:06.000000000 +0200
+--- simgear/canvas/ShivaVG/src/shDefs.h.orig 2013-02-20 17:17:38.000000000 +0100
++++ simgear/canvas/ShivaVG/src/shDefs.h 2013-02-20 17:18:16.000000000 +0100
@@ -34,7 +34,7 @@
#include <math.h>
#include <float.h>
diff --git a/devel/simgear/pkg-plist b/devel/simgear/pkg-plist
index 8322b0f5e8c..225f4d3b5c3 100644
--- a/devel/simgear/pkg-plist
+++ b/devel/simgear/pkg-plist
@@ -4,6 +4,48 @@ include/simgear/constants.h
include/simgear/sg_inlines.h
include/simgear/version.h
include/simgear/bucket/newbucket.hxx
+include/simgear/bvh/BVHPageNode.hxx
+include/simgear/bvh/BVHNearestPointVisitor.hxx
+include/simgear/bvh/BVHStaticGeometryBuilder.hxx
+include/simgear/bvh/BVHStaticLeaf.hxx
+include/simgear/bvh/BVHStaticData.hxx
+include/simgear/bvh/BVHPager.hxx
+include/simgear/bvh/BVHVisitor.hxx
+include/simgear/bvh/BVHBoundingBoxVisitor.hxx
+include/simgear/bvh/BVHTransform.hxx
+include/simgear/bvh/BVHStaticTriangle.hxx
+include/simgear/bvh/BVHStaticNode.hxx
+include/simgear/bvh/BVHNode.hxx
+include/simgear/bvh/BVHMaterial.hxx
+include/simgear/bvh/BVHLineSegmentVisitor.hxx
+include/simgear/bvh/BVHSubTreeCollector.hxx
+include/simgear/bvh/BVHPageRequest.hxx
+include/simgear/bvh/BVHStaticGeometry.hxx
+include/simgear/bvh/BVHGroup.hxx
+include/simgear/bvh/BVHMotionTransform.hxx
+include/simgear/bvh/BVHStaticBinary.hxx
+include/simgear/bvh/BVHLineGeometry.hxx
+include/simgear/canvas/CanvasMgr.hxx
+include/simgear/canvas/Canvas.hxx
+include/simgear/canvas/canvas_fwd.hxx
+include/simgear/canvas/ShivaVG/vgu.h
+include/simgear/canvas/ShivaVG/openvg.h
+include/simgear/canvas/elements/CanvasGroup.hxx
+include/simgear/canvas/elements/CanvasText.hxx
+include/simgear/canvas/elements/CanvasMap.hxx
+include/simgear/canvas/elements/CanvasImage.hxx
+include/simgear/canvas/elements/CanvasPath.hxx
+include/simgear/canvas/elements/CanvasElement.hxx
+include/simgear/canvas/CanvasPlacement.hxx
+include/simgear/canvas/ODGauge.hxx
+include/simgear/canvas/CanvasSystemAdapter.hxx
+include/simgear/canvas/MouseEvent.hxx
+include/simgear/canvas/CanvasEventListener.hxx
+include/simgear/canvas/CanvasEventVisitor.hxx
+include/simgear/canvas/CanvasEventManager.hxx
+include/simgear/canvas/VGInitOperation.hxx
+include/simgear/canvas/CanvasEventTypes.hxx
+include/simgear/canvas/CanvasEvent.hxx
include/simgear/debug/debug_types.h
include/simgear/debug/logstream.hxx
include/simgear/ephemeris/celestialBody.hxx
@@ -62,6 +104,8 @@ include/simgear/math/leastsqs.hxx
include/simgear/math/sg_geodesy.hxx
include/simgear/math/sg_types.hxx
include/simgear/math/sg_random.h
+include/simgear/math/SGRect.hxx
+include/simgear/math/SGLocation.hxx
include/simgear/misc/ResourceManager.hxx
include/simgear/misc/interpolator.hxx
include/simgear/misc/sg_dir.hxx
@@ -73,8 +117,15 @@ include/simgear/misc/strutils.hxx
include/simgear/misc/tabbed_values.hxx
include/simgear/misc/texcoord.hxx
include/simgear/misc/zfstream.hxx
+include/simgear/misc/gzcontainerfile.hxx
include/simgear/nasal/naref.h
include/simgear/nasal/nasal.h
+include/simgear/nasal/cppbind/Ghost.hxx
+include/simgear/nasal/cppbind/NasalHash.hxx
+include/simgear/nasal/cppbind/to_nasal.hxx
+include/simgear/nasal/cppbind/from_nasal_detail.hxx
+include/simgear/nasal/cppbind/from_nasal.hxx
+include/simgear/nasal/cppbind/nasal_traits.hxx
include/simgear/props/AtomicChangeListener.hxx
include/simgear/props/ExtendedPropertyAdapter.hxx
include/simgear/props/condition.hxx
@@ -84,6 +135,8 @@ include/simgear/props/props_io.hxx
include/simgear/props/propsfwd.hxx
include/simgear/props/tiedpropertylist.hxx
include/simgear/props/vectorPropTemplates.hxx
+include/simgear/props/PropertyBasedMgr.hxx
+include/simgear/props/PropertyBasedElement.hxx
include/simgear/serial/serial.hxx
include/simgear/structure/OSGUtils.hxx
include/simgear/structure/OSGVersion.hxx
@@ -121,24 +174,6 @@ include/simgear/screen/extensions.hxx
include/simgear/screen/screen-dump.hxx
include/simgear/screen/tr.h
include/simgear/screen/jpgfactory.hxx
-include/simgear/scene/bvh/BVHBoundingBoxVisitor.hxx
-include/simgear/scene/bvh/BVHDebugCollectVisitor.hxx
-include/simgear/scene/bvh/BVHGroup.hxx
-include/simgear/scene/bvh/BVHLineGeometry.hxx
-include/simgear/scene/bvh/BVHLineSegmentVisitor.hxx
-include/simgear/scene/bvh/BVHMotionTransform.hxx
-include/simgear/scene/bvh/BVHNearestPointVisitor.hxx
-include/simgear/scene/bvh/BVHNode.hxx
-include/simgear/scene/bvh/BVHStaticBinary.hxx
-include/simgear/scene/bvh/BVHStaticData.hxx
-include/simgear/scene/bvh/BVHStaticGeometry.hxx
-include/simgear/scene/bvh/BVHStaticGeometryBuilder.hxx
-include/simgear/scene/bvh/BVHStaticLeaf.hxx
-include/simgear/scene/bvh/BVHStaticNode.hxx
-include/simgear/scene/bvh/BVHStaticTriangle.hxx
-include/simgear/scene/bvh/BVHVisitor.hxx
-include/simgear/scene/bvh/BVHSubTreeCollector.hxx
-include/simgear/scene/bvh/BVHTransform.hxx
include/simgear/scene/material/Effect.hxx
include/simgear/scene/material/EffectBuilder.hxx
include/simgear/scene/material/EffectCullVisitor.hxx
@@ -170,6 +205,9 @@ include/simgear/scene/model/modellib.hxx
include/simgear/scene/model/particles.hxx
include/simgear/scene/model/persparam.hxx
include/simgear/scene/model/placement.hxx
+include/simgear/scene/model/BVHDebugCollectVisitor.hxx
+include/simgear/scene/model/BVHPageNodeOSG.hxx
+include/simgear/scene/model/PrimitiveCollector.hxx
include/simgear/scene/sky/CloudShaderGeometry.hxx
include/simgear/scene/sky/cloud.hxx
include/simgear/scene/sky/cloudfield.hxx
@@ -222,12 +260,16 @@ include/simgear/scene/util/StateAttributeFactory.hxx
include/simgear/scene/util/UpdateOnceCallback.hxx
include/simgear/scene/util/VectorArrayAdapter.hxx
include/simgear/scene/util/project.hxx
+include/simgear/scene/util/DeletionManager.hxx
+include/simgear/scene/util/parse_color.hxx
+include/simgear/scene/util/OptionsReadFileCallback.hxx
include/simgear/scene/tsync/terrasync.hxx
include/simgear/sound/sample_group.hxx
include/simgear/sound/sample_openal.hxx
include/simgear/sound/sample_queue.hxx
include/simgear/sound/soundmgr_openal.hxx
include/simgear/sound/xmlsound.hxx
+include/simgear/sound/readwav.hxx
@dirrm include/simgear/xml
@dirrm include/simgear/timing
@dirrm include/simgear/threads
@@ -241,9 +283,9 @@ include/simgear/sound/xmlsound.hxx
@dirrm include/simgear/scene/sky
@dirrm include/simgear/scene/model
@dirrm include/simgear/scene/material
-@dirrm include/simgear/scene/bvh
@dirrm include/simgear/scene
@dirrm include/simgear/props
+@dirrm include/simgear/nasal/cppbind
@dirrm include/simgear/nasal
@dirrm include/simgear/misc
@dirrm include/simgear/math
@@ -252,29 +294,11 @@ include/simgear/sound/xmlsound.hxx
@dirrm include/simgear/ephemeris
@dirrm include/simgear/environment
@dirrm include/simgear/debug
+@dirrm include/simgear/canvas/elements
+@dirrm include/simgear/canvas/ShivaVG
+@dirrm include/simgear/canvas
+@dirrm include/simgear/bvh
@dirrm include/simgear/bucket
@dirrm include/simgear
-lib/libsgmisc.a
-lib/libsgscreen.a
-lib/libsgprops.a
-lib/libsgmodel.a
-lib/libsgmath.a
-lib/libsgmaterial.a
-lib/libsgtgdb.a
-lib/libsgtsync.a
-lib/libsgmagvar.a
-lib/libsgstructure.a
-lib/libsgdebug.a
-lib/libsgnasal.a
-lib/libsgsky.a
-lib/libsgserial.a
-lib/libsgutil.a
-lib/libsgtiming.a
-lib/libsgxml.a
-lib/libsgbvh.a
-lib/libsgsound.a
-lib/libsgio.a
-lib/libsgenvironment.a
-lib/libsgbucket.a
-lib/libsgephem.a
-lib/libsgthreads.a
+lib/libSimGearCore.a
+lib/libSimGearScene.a
diff --git a/games/flightgear-aircraft/Makefile b/games/flightgear-aircraft/Makefile
index b180be93dc1..56ac8eb4171 100644
--- a/games/flightgear-aircraft/Makefile
+++ b/games/flightgear-aircraft/Makefile
@@ -1,24 +1,20 @@
-# New ports collection makefile for: flightgear-aircrafts
-# Date created: 19 Sep 2005
-# Whom: Jean-Yves Lefort <jylefort@FreeBSD.org>
-#
+# Created by: Jean-Yves Lefort <jylefort@FreeBSD.org>
# $FreeBSD$
-#
PORTNAME= flightgear-aircraft
-PORTVERSION= 20120830
+PORTVERSION= 20130221
CATEGORIES= games
# see http://www.flightgear.org/templates.js
-MASTER_SITES= http://mirrors.ibiblio.org/pub/mirrors/flightgear/ftp/Aircraft-2.8/ \
- http://ftp.linux.kiev.ua/pub/mirrors/ftp.flightgear.org/flightgear/Aircraft-2.8/ \
- ftp://ftp.kingmont.com/flightsims/flightgear/Aircraft-2.8/ \
- ftp://ftp.de.flightgear.org/pub/fgfs/Aircraft-2.8/ \
- ftp://flightgear.wo0t.de/flightgear-ftp/ftp/Aircraft-2.8/
+MASTER_SITES= http://mirrors.ibiblio.org/pub/mirrors/flightgear/ftp/Aircraft-2.10/ \
+ http://ftp.linux.kiev.ua/pub/mirrors/ftp.flightgear.org/flightgear/Aircraft-2.10/ \
+ ftp://ftp.kingmont.com/flightsims/flightgear/Aircraft-2.10/ \
+ ftp://ftp.de.flightgear.org/pub/fgfs/Aircraft-2.10/ \
+ ftp://flightgear.wo0t.de/flightgear-ftp/ftp/Aircraft-2.10/
# Selection of production-ready/well-known planes
# (planes already included in flightgear-data are excluded)
# Please contact the MAINTAINER if a plane is missing
DISTFILES= 737-200_20120506.zip \
- A-10_20120717.zip \
+ A-10_20121203.zip \
A300_20120717.zip \
Alouette-II_20120506.zip \
Alphajet_20120506.zip \
@@ -28,28 +24,28 @@ DISTFILES= 737-200_20120506.zip \
Caravelle_20120506.zip \
Caudron-G3_20120506.zip \
F80C_20120717.zip \
- Hurricane_20120806.zip \
+ Hurricane_20130117.zip \
IL-2_20110311.zip \
- Lightning_20120717.zip \
+ Lightning_20121005.zip \
Lockheed1049h_1.0.zip \
Messerschmitt-P1101_20101005.zip \
MirageIII_20120222.zip \
PaperAirplane_20101229.zip \
Pond-Racer_20120506.zip \
R44_20120506.zip \
- Spitfire_20120717.zip \
+ Spitfire_20130117.zip \
Stieglitz_20091025.zip \
Super-Etendard_20120501.zip \
Supermarine-S.6B_20110114.zip \
Superwal_20100330.zip \
airwaveXtreme150_July-2012.zip \
- asw20_20081019.zip \
+ asw20_20130115.zip \
bf109_20120717.zip \
- c310_20120307.zip \
+ c310_20130209.zip \
dhc3_20120506.zip \
- f16_20120717.zip \
+ f16_20120812.zip \
harrier_20120717.zip \
- pa24-250_20120717.zip \
+ pa24-250_20121128.zip \
tu154_20081221.zip \
wrightFlyer1903_20070710.zip
DIST_SUBDIR= ${PORTNAME}
diff --git a/games/flightgear-aircraft/distinfo b/games/flightgear-aircraft/distinfo
index 87b424a608d..989a9932fc5 100644
--- a/games/flightgear-aircraft/distinfo
+++ b/games/flightgear-aircraft/distinfo
@@ -1,7 +1,7 @@
SHA256 (flightgear-aircraft/737-200_20120506.zip) = 8aadefbd4cd6fec5297176fe08bbc15206388da5d4d55c4b277909c92f335f5c
SIZE (flightgear-aircraft/737-200_20120506.zip) = 12401593
-SHA256 (flightgear-aircraft/A-10_20120717.zip) = 92ef4c82f40c54d1a6b159ca9d3461bc8ecb701a7e6589e9ede49ebd33d5cc72
-SIZE (flightgear-aircraft/A-10_20120717.zip) = 8871714
+SHA256 (flightgear-aircraft/A-10_20121203.zip) = 0e6dc3c1243419fb3df4bd3a2c80185178951b1192750a08778f4de949d2992d
+SIZE (flightgear-aircraft/A-10_20121203.zip) = 9328046
SHA256 (flightgear-aircraft/A300_20120717.zip) = 913236da87fd3abe1177b7e59d2dff69d8ee9803a3f60192f071f507eb23107d
SIZE (flightgear-aircraft/A300_20120717.zip) = 386184
SHA256 (flightgear-aircraft/Alouette-II_20120506.zip) = 755bc4bc620d1cceb208def0d979f4c4535667df42abcd0adb30dbf317d1b42c
@@ -20,12 +20,12 @@ SHA256 (flightgear-aircraft/Caudron-G3_20120506.zip) = 191a68c00fa75a034ee0d6f75
SIZE (flightgear-aircraft/Caudron-G3_20120506.zip) = 4531626
SHA256 (flightgear-aircraft/F80C_20120717.zip) = 633016a2ea70f9be59927d5201c48af985ef7d2414888ddff3488f25261526d5
SIZE (flightgear-aircraft/F80C_20120717.zip) = 1528349
-SHA256 (flightgear-aircraft/Hurricane_20120806.zip) = 7483ee6d5d2de37ab3e61d86edffa51c05b42bb10bf4902b4d77b11f10478289
-SIZE (flightgear-aircraft/Hurricane_20120806.zip) = 11957844
+SHA256 (flightgear-aircraft/Hurricane_20130117.zip) = d5a547b321245ff9533413d3eb8f75254f394ff9771473f409909b09c23b08c8
+SIZE (flightgear-aircraft/Hurricane_20130117.zip) = 12062365
SHA256 (flightgear-aircraft/IL-2_20110311.zip) = 1c7e126956247f7a6ed93cd4fc2abe65c756b07275559ed1f0bd03d731a51ee0
SIZE (flightgear-aircraft/IL-2_20110311.zip) = 3933481
-SHA256 (flightgear-aircraft/Lightning_20120717.zip) = 94135bb7f65a01f1502e99f8cdb25ba9bb2292b4713c5aec5476be0571e8f441
-SIZE (flightgear-aircraft/Lightning_20120717.zip) = 4854327
+SHA256 (flightgear-aircraft/Lightning_20121005.zip) = 6f8a27edf887aceef8da17465c658c110cf6b1d55c10ba023cb2660dd61a66ab
+SIZE (flightgear-aircraft/Lightning_20121005.zip) = 4784876
SHA256 (flightgear-aircraft/Lockheed1049h_1.0.zip) = 7374e32aab617e466c228262004d1c292d9667375e74481d74f7a5210dfd60fd
SIZE (flightgear-aircraft/Lockheed1049h_1.0.zip) = 7529096
SHA256 (flightgear-aircraft/Messerschmitt-P1101_20101005.zip) = 76c1a79348a59fa2eccd0a6eb1218db4d706ba967b7d626ddc263abda6d12ed1
@@ -38,8 +38,8 @@ SHA256 (flightgear-aircraft/Pond-Racer_20120506.zip) = 707d8401d394095475e0f3442
SIZE (flightgear-aircraft/Pond-Racer_20120506.zip) = 3063526
SHA256 (flightgear-aircraft/R44_20120506.zip) = 4a8534af61ceb7749b7596cae6b30edbac23d2ee6c1473dd40277423ad9ad097
SIZE (flightgear-aircraft/R44_20120506.zip) = 11161383
-SHA256 (flightgear-aircraft/Spitfire_20120717.zip) = 87d268fb56110a869916c31458676d509ba07a314f1b529b23d1ff030ddc7f7c
-SIZE (flightgear-aircraft/Spitfire_20120717.zip) = 19022040
+SHA256 (flightgear-aircraft/Spitfire_20130117.zip) = 30641c30d53f437447ae7cecf1c4dd38ce01587a394d427984ca0beda5b98d40
+SIZE (flightgear-aircraft/Spitfire_20130117.zip) = 21051159
SHA256 (flightgear-aircraft/Stieglitz_20091025.zip) = 05393d31f11bc718bbbe43d539f18020b2ab9ed34b68c6bf7dff8c543b6fb3bd
SIZE (flightgear-aircraft/Stieglitz_20091025.zip) = 4499810
SHA256 (flightgear-aircraft/Super-Etendard_20120501.zip) = e89f96034f2ee64f34917a8062e6e87f75674ff7f595be5a884ae4b4904a5eb5
@@ -50,20 +50,20 @@ SHA256 (flightgear-aircraft/Superwal_20100330.zip) = cd013f6c6ab073cea4c5eef59ac
SIZE (flightgear-aircraft/Superwal_20100330.zip) = 2654839
SHA256 (flightgear-aircraft/airwaveXtreme150_July-2012.zip) = 9c20e9bd435c35921003aae82954e7538636710c1f3f0c34665bd670acf33b3e
SIZE (flightgear-aircraft/airwaveXtreme150_July-2012.zip) = 1208012
-SHA256 (flightgear-aircraft/asw20_20081019.zip) = 8e74533447a4d35f00117c86b65cee4661a69230f3acc726678399a4d4f741ae
-SIZE (flightgear-aircraft/asw20_20081019.zip) = 286802
+SHA256 (flightgear-aircraft/asw20_20130115.zip) = 3dc1529520d468dd5c357e56637cf3f42f425be757239964a6d6774ddbf9b2b3
+SIZE (flightgear-aircraft/asw20_20130115.zip) = 2576605
SHA256 (flightgear-aircraft/bf109_20120717.zip) = a34162707163a871cf5456559a3bf0f8a161cbbdb635d395ce924cdd1b2e13ec
SIZE (flightgear-aircraft/bf109_20120717.zip) = 24201651
-SHA256 (flightgear-aircraft/c310_20120307.zip) = 86a587fe250823ce26ff756ec3893631cde8b6164663c8a100b641ab9c1146b9
-SIZE (flightgear-aircraft/c310_20120307.zip) = 615092
+SHA256 (flightgear-aircraft/c310_20130209.zip) = 07d765eac4a6cb9bc115dc4d302fed972776f5148cb1154f666b6a7f3c27543a
+SIZE (flightgear-aircraft/c310_20130209.zip) = 615078
SHA256 (flightgear-aircraft/dhc3_20120506.zip) = 808215533d23b9e2a23b0249bacff9504b72a8e4263a562058dea9c6060c12f9
SIZE (flightgear-aircraft/dhc3_20120506.zip) = 20789012
-SHA256 (flightgear-aircraft/f16_20120717.zip) = bde84953b96b67269f5553b521a877534f9861d7b192d7ad36daa42a919c1e24
-SIZE (flightgear-aircraft/f16_20120717.zip) = 19551059
+SHA256 (flightgear-aircraft/f16_20120812.zip) = c4782fbcfeba7fea5204d048a0cb36499e0901b1ef514c8c638b14928ce7396a
+SIZE (flightgear-aircraft/f16_20120812.zip) = 19445799
SHA256 (flightgear-aircraft/harrier_20120717.zip) = 588a6a3ac42975426c63b754b56c8d26e1789c9772ceb6848a2b9857481d7ec6
SIZE (flightgear-aircraft/harrier_20120717.zip) = 4208120
-SHA256 (flightgear-aircraft/pa24-250_20120717.zip) = 448292aa10e3466cb66e8892417f4d6c03bfa69ad8f415af512799046d50ab10
-SIZE (flightgear-aircraft/pa24-250_20120717.zip) = 2100101
+SHA256 (flightgear-aircraft/pa24-250_20121128.zip) = dd78878bfbf21bb77405a3f5c1586f1043487c6d8499ec28361fbc3131500952
+SIZE (flightgear-aircraft/pa24-250_20121128.zip) = 2100194
SHA256 (flightgear-aircraft/tu154_20081221.zip) = e52dae4b16fee2844417f91f76f12a5f8907dca780d553282a9f1326e60c4079
SIZE (flightgear-aircraft/tu154_20081221.zip) = 1387134
SHA256 (flightgear-aircraft/wrightFlyer1903_20070710.zip) = cc03ae8c61c11ab9d0fa4d4ae7192bbf0a0f579d4b42a40082be5060232dabe8
diff --git a/games/flightgear-data/Makefile b/games/flightgear-data/Makefile
index 0a9663eb367..2645974e53a 100644
--- a/games/flightgear-data/Makefile
+++ b/games/flightgear-data/Makefile
@@ -1,12 +1,8 @@
-# New ports collection makefile for: flightgear
-# Date created: 26 June 1999
-# Whom: Brian Buchanan <brian@CSUA.Berkeley.EDU>
-#
+# Created by: Brian Buchanan <brian@CSUA.Berkeley.EDU>
# $FreeBSD$
-#
PORTNAME= flightgear-data
-PORTVERSION= 2.8.0
+PORTVERSION= 2.10.0
CATEGORIES= games
# see http://www.flightgear.org/templates.js
MASTER_SITES= http://mirrors.ibiblio.org/pub/mirrors/flightgear/ftp/Shared/ \
diff --git a/games/flightgear-data/distinfo b/games/flightgear-data/distinfo
index eeef12e9d69..056a54a0cc0 100644
--- a/games/flightgear-data/distinfo
+++ b/games/flightgear-data/distinfo
@@ -1,2 +1,2 @@
-SHA256 (FlightGear-data-2.8.0.tar.bz2) = ad9ba1d12b5c771193561d452ec300e4c9321749d478dd6c1f59976932ba8d74
-SIZE (FlightGear-data-2.8.0.tar.bz2) = 685330156
+SHA256 (FlightGear-data-2.10.0.tar.bz2) = 2fa0280ea9a1a0bee3eab27f034ec45d4cf44a2b818a7036b481da6668f7229f
+SIZE (FlightGear-data-2.10.0.tar.bz2) = 758115094
diff --git a/games/flightgear/Makefile b/games/flightgear/Makefile
index 283add2214c..4afd3d6e5b9 100644
--- a/games/flightgear/Makefile
+++ b/games/flightgear/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= flightgear
-PORTVERSION= 2.8.0
-PORTREVISION= 1
+PORTVERSION= 2.10.0
CATEGORIES= games
# see http://www.flightgear.org/templates.js
MASTER_SITES= http://mirrors.ibiblio.org/pub/mirrors/flightgear/ftp/Source/ \
@@ -22,9 +21,9 @@ LIB_DEPENDS= jpeg:${PORTSDIR}/graphics/jpeg \
fltk:${PORTSDIR}/x11-toolkits/fltk \
osg:${PORTSDIR}/graphics/osg
BUILD_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
- ${LOCALBASE}/lib/libsgmisc.a:${PORTSDIR}/devel/simgear
+ ${LOCALBASE}/lib/libSimGearCore.a:${PORTSDIR}/devel/simgear
RUN_DEPENDS= ${LOCALBASE}/lib/libplibsl.a:${PORTSDIR}/x11-toolkits/plib \
- ${LOCALBASE}/lib/libsgmisc.a:${PORTSDIR}/devel/simgear \
+ ${LOCALBASE}/lib/libSimGearCore.a:${PORTSDIR}/devel/simgear \
${LOCALBASE}/share/flightgear/version:${PORTSDIR}/games/flightgear-data
USE_BZIP2= yes
diff --git a/games/flightgear/distinfo b/games/flightgear/distinfo
index 8ec8b59e4d3..018386cd911 100644
--- a/games/flightgear/distinfo
+++ b/games/flightgear/distinfo
@@ -1,2 +1,2 @@
-SHA256 (flightgear-2.8.0.tar.bz2) = bfda4f269d90128f4e4cb828de692a49dc0b93db41fe20a2b5272f3f271f3a01
-SIZE (flightgear-2.8.0.tar.bz2) = 2311023
+SHA256 (flightgear-2.10.0.tar.bz2) = 067e24acb69a21721a97e48c1a088a2982bd08b8084a9073c90a5dde3db7055f
+SIZE (flightgear-2.10.0.tar.bz2) = 3378859
diff --git a/games/flightgear/pkg-plist b/games/flightgear/pkg-plist
index 5a5d06292a3..22375934367 100644
--- a/games/flightgear/pkg-plist
+++ b/games/flightgear/pkg-plist
@@ -12,3 +12,4 @@ bin/MIDGsmooth
bin/UGsmooth
bin/fgadmin
bin/fgpanel
+bin/fgelev