aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--x11/kde4-baseapps/Makefile2
-rw-r--r--x11/kde4-runtime/Makefile2
-rw-r--r--x11/kde4-workspace/Makefile2
-rw-r--r--x11/kdebase2/Makefile2
-rw-r--r--x11/kdebase3/Makefile2
-rw-r--r--x11/kdebase4-runtime/Makefile2
-rw-r--r--x11/kdebase4-workspace/Makefile2
-rw-r--r--x11/kdebase4/Makefile2
8 files changed, 16 insertions, 0 deletions
diff --git a/x11/kde4-baseapps/Makefile b/x11/kde4-baseapps/Makefile
index 36a0e07a75d..cda7136c2f6 100644
--- a/x11/kde4-baseapps/Makefile
+++ b/x11/kde4-baseapps/Makefile
@@ -28,4 +28,6 @@ CONFIGURE_ARGS+="--with-xdmdir=${X11BASE}/lib/X11/xdm" \
CONFIGURE_ENV+= MOC="${MOC}"
USE_GMAKE= yes
+FORBIDDEN= "Local buffer overflow yielding gid nogroup"
+
.include <bsd.port.mk>
diff --git a/x11/kde4-runtime/Makefile b/x11/kde4-runtime/Makefile
index 36a0e07a75d..cda7136c2f6 100644
--- a/x11/kde4-runtime/Makefile
+++ b/x11/kde4-runtime/Makefile
@@ -28,4 +28,6 @@ CONFIGURE_ARGS+="--with-xdmdir=${X11BASE}/lib/X11/xdm" \
CONFIGURE_ENV+= MOC="${MOC}"
USE_GMAKE= yes
+FORBIDDEN= "Local buffer overflow yielding gid nogroup"
+
.include <bsd.port.mk>
diff --git a/x11/kde4-workspace/Makefile b/x11/kde4-workspace/Makefile
index 36a0e07a75d..cda7136c2f6 100644
--- a/x11/kde4-workspace/Makefile
+++ b/x11/kde4-workspace/Makefile
@@ -28,4 +28,6 @@ CONFIGURE_ARGS+="--with-xdmdir=${X11BASE}/lib/X11/xdm" \
CONFIGURE_ENV+= MOC="${MOC}"
USE_GMAKE= yes
+FORBIDDEN= "Local buffer overflow yielding gid nogroup"
+
.include <bsd.port.mk>
diff --git a/x11/kdebase2/Makefile b/x11/kdebase2/Makefile
index 36a0e07a75d..cda7136c2f6 100644
--- a/x11/kdebase2/Makefile
+++ b/x11/kdebase2/Makefile
@@ -28,4 +28,6 @@ CONFIGURE_ARGS+="--with-xdmdir=${X11BASE}/lib/X11/xdm" \
CONFIGURE_ENV+= MOC="${MOC}"
USE_GMAKE= yes
+FORBIDDEN= "Local buffer overflow yielding gid nogroup"
+
.include <bsd.port.mk>
diff --git a/x11/kdebase3/Makefile b/x11/kdebase3/Makefile
index 36a0e07a75d..cda7136c2f6 100644
--- a/x11/kdebase3/Makefile
+++ b/x11/kdebase3/Makefile
@@ -28,4 +28,6 @@ CONFIGURE_ARGS+="--with-xdmdir=${X11BASE}/lib/X11/xdm" \
CONFIGURE_ENV+= MOC="${MOC}"
USE_GMAKE= yes
+FORBIDDEN= "Local buffer overflow yielding gid nogroup"
+
.include <bsd.port.mk>
diff --git a/x11/kdebase4-runtime/Makefile b/x11/kdebase4-runtime/Makefile
index 36a0e07a75d..cda7136c2f6 100644
--- a/x11/kdebase4-runtime/Makefile
+++ b/x11/kdebase4-runtime/Makefile
@@ -28,4 +28,6 @@ CONFIGURE_ARGS+="--with-xdmdir=${X11BASE}/lib/X11/xdm" \
CONFIGURE_ENV+= MOC="${MOC}"
USE_GMAKE= yes
+FORBIDDEN= "Local buffer overflow yielding gid nogroup"
+
.include <bsd.port.mk>
diff --git a/x11/kdebase4-workspace/Makefile b/x11/kdebase4-workspace/Makefile
index 36a0e07a75d..cda7136c2f6 100644
--- a/x11/kdebase4-workspace/Makefile
+++ b/x11/kdebase4-workspace/Makefile
@@ -28,4 +28,6 @@ CONFIGURE_ARGS+="--with-xdmdir=${X11BASE}/lib/X11/xdm" \
CONFIGURE_ENV+= MOC="${MOC}"
USE_GMAKE= yes
+FORBIDDEN= "Local buffer overflow yielding gid nogroup"
+
.include <bsd.port.mk>
diff --git a/x11/kdebase4/Makefile b/x11/kdebase4/Makefile
index 36a0e07a75d..cda7136c2f6 100644
--- a/x11/kdebase4/Makefile
+++ b/x11/kdebase4/Makefile
@@ -28,4 +28,6 @@ CONFIGURE_ARGS+="--with-xdmdir=${X11BASE}/lib/X11/xdm" \
CONFIGURE_ENV+= MOC="${MOC}"
USE_GMAKE= yes
+FORBIDDEN= "Local buffer overflow yielding gid nogroup"
+
.include <bsd.port.mk>