aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--audio/xsidplay/Makefile4
-rw-r--r--audio/xsidplay/files/patch-src-songlendb-File.cpp22
2 files changed, 22 insertions, 4 deletions
diff --git a/audio/xsidplay/Makefile b/audio/xsidplay/Makefile
index 6d3e680156c..5d40ad9021b 100644
--- a/audio/xsidplay/Makefile
+++ b/audio/xsidplay/Makefile
@@ -38,10 +38,6 @@ MAN1= xsidplay.1
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
.if ${MACHINE_ARCH} == "alpha"
CFLAGS+= -O0
.endif
diff --git a/audio/xsidplay/files/patch-src-songlendb-File.cpp b/audio/xsidplay/files/patch-src-songlendb-File.cpp
new file mode 100644
index 00000000000..b6b8df16cae
--- /dev/null
+++ b/audio/xsidplay/files/patch-src-songlendb-File.cpp
@@ -0,0 +1,22 @@
+--- src/songlendb/File.cpp.orig Sun Mar 3 19:00:03 2002
++++ src/songlendb/File.cpp Thu Feb 17 22:46:43 2005
+@@ -29,6 +29,7 @@
+ #endif
+ using namespace std;
+
++#include <sys/types.h>
+ #include "File.h"
+
+ // String comparison functor for sort function.
+@@ -126,9 +127,9 @@
+ streampos fileLen = myIn.tellg();
+ #endif
+ #ifdef XSID_HAVE_NOTHROW
+- pDB = new(std::nothrow) char[fileLen+1L];
++ pDB = new(std::nothrow) char[(off_t)fileLen+1L];
+ #else
+- pDB = new char[fileLen+1L];
++ pDB = new char[(off_t)fileLen+1L];
+ #endif
+ if ( pDB == 0 )
+ {