aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--misc/tinderbox/Makefile5
-rw-r--r--misc/tinderbox/files/patch-create22
-rw-r--r--misc/tinderbox/files/patch-setup.sh0
-rw-r--r--ports-mgmt/tinderbox-devel/Makefile5
-rw-r--r--ports-mgmt/tinderbox-devel/files/patch-create22
-rw-r--r--ports-mgmt/tinderbox-devel/files/patch-setup.sh0
-rw-r--r--ports-mgmt/tinderbox/Makefile5
-rw-r--r--ports-mgmt/tinderbox/files/patch-create22
-rw-r--r--ports-mgmt/tinderbox/files/patch-setup.sh0
9 files changed, 72 insertions, 9 deletions
diff --git a/misc/tinderbox/Makefile b/misc/tinderbox/Makefile
index affee6e2ef7..57157c771f7 100644
--- a/misc/tinderbox/Makefile
+++ b/misc/tinderbox/Makefile
@@ -6,15 +6,14 @@
PORTNAME= tinderbox
PORTVERSION= 2.3.2
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= http://tinderbox.marcuscom.com/
MAINTAINER= itetcu@FreeBSD.org
COMMENT= Port build tinderbox system
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net \
- ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB \
+RUN_DEPENDS= ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB \
OPTIONS= PGSQL "With pgsql" Off \
MYSQL "With mysql" On \
diff --git a/misc/tinderbox/files/patch-create b/misc/tinderbox/files/patch-create
new file mode 100644
index 00000000000..e3b3b75bae4
--- /dev/null
+++ b/misc/tinderbox/files/patch-create
@@ -0,0 +1,22 @@
+Index: create
+===================================================================
+RCS file: /space/cvs/marcuscom-cvs/portstools/tinderbox/Attic/create,v
+retrieving revision 1.5.2.3
+diff -u -r1.5.2.3 create
+--- create 6 Apr 2006 05:18:24 -0000 1.5.2.3
++++ create 13 Sep 2006 19:51:46 -0000
+@@ -49,7 +49,13 @@
+
+ tcExists () {
+ list=$(${pb}/scripts/tc list$1 2>/dev/null)
+- echo ${list} | grep -qw $2
++ for obj in ${list}; do
++ if [ x"${obj}" = x"$2" ]; then
++ return 0
++ fi
++ done
++
++ return 1
+ }
+
+ cleanDirs () {
diff --git a/misc/tinderbox/files/patch-setup.sh b/misc/tinderbox/files/patch-setup.sh
new file mode 100644
index 00000000000..e69de29bb2d
--- /dev/null
+++ b/misc/tinderbox/files/patch-setup.sh
diff --git a/ports-mgmt/tinderbox-devel/Makefile b/ports-mgmt/tinderbox-devel/Makefile
index affee6e2ef7..57157c771f7 100644
--- a/ports-mgmt/tinderbox-devel/Makefile
+++ b/ports-mgmt/tinderbox-devel/Makefile
@@ -6,15 +6,14 @@
PORTNAME= tinderbox
PORTVERSION= 2.3.2
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= http://tinderbox.marcuscom.com/
MAINTAINER= itetcu@FreeBSD.org
COMMENT= Port build tinderbox system
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net \
- ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB \
+RUN_DEPENDS= ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB \
OPTIONS= PGSQL "With pgsql" Off \
MYSQL "With mysql" On \
diff --git a/ports-mgmt/tinderbox-devel/files/patch-create b/ports-mgmt/tinderbox-devel/files/patch-create
new file mode 100644
index 00000000000..e3b3b75bae4
--- /dev/null
+++ b/ports-mgmt/tinderbox-devel/files/patch-create
@@ -0,0 +1,22 @@
+Index: create
+===================================================================
+RCS file: /space/cvs/marcuscom-cvs/portstools/tinderbox/Attic/create,v
+retrieving revision 1.5.2.3
+diff -u -r1.5.2.3 create
+--- create 6 Apr 2006 05:18:24 -0000 1.5.2.3
++++ create 13 Sep 2006 19:51:46 -0000
+@@ -49,7 +49,13 @@
+
+ tcExists () {
+ list=$(${pb}/scripts/tc list$1 2>/dev/null)
+- echo ${list} | grep -qw $2
++ for obj in ${list}; do
++ if [ x"${obj}" = x"$2" ]; then
++ return 0
++ fi
++ done
++
++ return 1
+ }
+
+ cleanDirs () {
diff --git a/ports-mgmt/tinderbox-devel/files/patch-setup.sh b/ports-mgmt/tinderbox-devel/files/patch-setup.sh
new file mode 100644
index 00000000000..e69de29bb2d
--- /dev/null
+++ b/ports-mgmt/tinderbox-devel/files/patch-setup.sh
diff --git a/ports-mgmt/tinderbox/Makefile b/ports-mgmt/tinderbox/Makefile
index affee6e2ef7..57157c771f7 100644
--- a/ports-mgmt/tinderbox/Makefile
+++ b/ports-mgmt/tinderbox/Makefile
@@ -6,15 +6,14 @@
PORTNAME= tinderbox
PORTVERSION= 2.3.2
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= http://tinderbox.marcuscom.com/
MAINTAINER= itetcu@FreeBSD.org
COMMENT= Port build tinderbox system
-RUN_DEPENDS= ${SITE_PERL}/${PERL_ARCH}/Digest/MD5.pm:${PORTSDIR}/security/p5-Digest-MD5 \
- ${SITE_PERL}/Net/SMTP.pm:${PORTSDIR}/net/p5-Net \
- ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB \
+RUN_DEPENDS= ${LOCALBASE}/share/pear/DB.php:${PORTSDIR}/databases/pear-DB \
OPTIONS= PGSQL "With pgsql" Off \
MYSQL "With mysql" On \
diff --git a/ports-mgmt/tinderbox/files/patch-create b/ports-mgmt/tinderbox/files/patch-create
new file mode 100644
index 00000000000..e3b3b75bae4
--- /dev/null
+++ b/ports-mgmt/tinderbox/files/patch-create
@@ -0,0 +1,22 @@
+Index: create
+===================================================================
+RCS file: /space/cvs/marcuscom-cvs/portstools/tinderbox/Attic/create,v
+retrieving revision 1.5.2.3
+diff -u -r1.5.2.3 create
+--- create 6 Apr 2006 05:18:24 -0000 1.5.2.3
++++ create 13 Sep 2006 19:51:46 -0000
+@@ -49,7 +49,13 @@
+
+ tcExists () {
+ list=$(${pb}/scripts/tc list$1 2>/dev/null)
+- echo ${list} | grep -qw $2
++ for obj in ${list}; do
++ if [ x"${obj}" = x"$2" ]; then
++ return 0
++ fi
++ done
++
++ return 1
+ }
+
+ cleanDirs () {
diff --git a/ports-mgmt/tinderbox/files/patch-setup.sh b/ports-mgmt/tinderbox/files/patch-setup.sh
new file mode 100644
index 00000000000..e69de29bb2d
--- /dev/null
+++ b/ports-mgmt/tinderbox/files/patch-setup.sh