aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--deskutils/kbirthday/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/deskutils/kbirthday/Makefile b/deskutils/kbirthday/Makefile
index 32ae2a68468..b7438e20d79 100644
--- a/deskutils/kbirthday/Makefile
+++ b/deskutils/kbirthday/Makefile
@@ -16,6 +16,7 @@ COMMENT= KDE kicker-applet that reminds you of birthdays and anniversaries
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_KDELIBS_VER=3
+USE_REINPLACE= yes
INSTALLS_SHLIB= yes
USE_INC_LIBTOOL_VER= 13
# may or may not solve the alpha compilation issue....
@@ -24,4 +25,7 @@ CONFIGURE_ARGS= --with-pic
# necesary to access the second master site by getting rid of the default switch -A
FETCH_CMD ?=/usr/bin/fetch -Rr
+post-patch:
+ ${REINPLACE_CMD} -e "s,-Wmissing-prototypes,-fPIC," ${WRKSRC}/configure
+
.include <bsd.port.mk>