aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/sarg/Makefile4
-rw-r--r--www/sarg/files/patch-log.c31
2 files changed, 33 insertions, 2 deletions
diff --git a/www/sarg/Makefile b/www/sarg/Makefile
index 2ad80cc2d56..2fdb12322bb 100644
--- a/www/sarg/Makefile
+++ b/www/sarg/Makefile
@@ -7,9 +7,9 @@
PORTNAME= sarg
PORTVERSION= 2.2.2
+PORTREVISION= 1
CATEGORIES= www
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= SF
MAINTAINER= garga@FreeBSD.org
COMMENT= Squid log analyzer and HTML report generator
diff --git a/www/sarg/files/patch-log.c b/www/sarg/files/patch-log.c
new file mode 100644
index 00000000000..636c6c94e4b
--- /dev/null
+++ b/www/sarg/files/patch-log.c
@@ -0,0 +1,31 @@
+--- log.c Tue Aug 29 14:09:32 2006
++++ log.c Wed Aug 30 01:34:18 2006
+@@ -772,7 +772,7 @@
+ while( fgets(bufz,sizeof(bufz),fp_in) != NULL ) recs1++;
+ rewind(fp_in);
+
+- printf("SARG: Records in file: %d, reading: %3.2f%%\r",recs1,(float) 0);
++ printf("SARG: Records in file: %lli, reading: %3.2f%%\r",recs1,(float) 0);
+ fflush( stdout ) ;
+ }
+
+@@ -781,7 +781,7 @@
+ if( bool_ShowReadStatistics && ! --OutputNonZero) {
+ perc = recs2 * 100 ;
+ perc = perc / recs1 ;
+- printf("SARG: Records in file: %d, reading: %3.2f%%\r",recs1,perc);
++ printf("SARG: Records in file: %lli, reading: %3.2f%%\r",recs1,perc);
+ fflush (stdout);
+ OutputNonZero = REPORT_EVERY_X_LINES ;
+ }
+@@ -1267,7 +1267,7 @@
+ }
+ }
+ if( bool_ShowReadStatistics )
+- printf("SARG: Records in file: %d, reading: %3.2f%%\n",recs1, (float) 100 );
++ printf("SARG: Records in file: %lli, reading: %3.2f%%\n",recs1, (float) 100 );
+ }
+
+ if ( fp_Download_Unsort )
+
+