aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--games/super_methane_brothers/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/games/super_methane_brothers/Makefile b/games/super_methane_brothers/Makefile
index 2857f5f4388..1d404103781 100644
--- a/games/super_methane_brothers/Makefile
+++ b/games/super_methane_brothers/Makefile
@@ -14,8 +14,8 @@ COMMENT= Port of the Amiga platform game of the same name
LICENSE= GPLv2
-LIB_DEPENDS= clan23Core:${PORTSDIR}/devel/clanlib \
- execinfo:${PORTSDIR}/devel/libexecinfo
+LIB_DEPENDS= libclan23Core.so:${PORTSDIR}/devel/clanlib \
+ libexecinfo.so:${PORTSDIR}/devel/libexecinfo
USES= gmake pkgconfig
USE_GCC= yes
@@ -29,8 +29,6 @@ LDFLAGS+= -L${LOCALBASE}/lib -lexecinfo
PORTDOCS= *
PLIST_FILES= bin/methane
-NO_STAGE= yes
-
OPTIONS_DEFINE= DOCS
.include <bsd.port.options.mk>
@@ -44,12 +42,12 @@ post-patch:
s|gcc|$${CXX}|' ${WRKSRC}/Makefile
do-install:
- (cd ${WRKDIR}/${DISTNAME} && ${INSTALL_PROGRAM} methane ${PREFIX}/bin)
- ${CHGRP} games ${PREFIX}/bin/methane
- ${CHMOD} g+s ${PREFIX}/bin/methane
+ (cd ${WRKDIR}/${DISTNAME} && ${INSTALL_PROGRAM} methane ${STAGEDIR}${PREFIX}/bin)
+ ${CHGRP} games ${STAGEDIR}${PREFIX}/bin/methane
+ ${CHMOD} g+s ${STAGEDIR}${PREFIX}/bin/methane
.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- @(cd ${WRKDIR}/${DISTNAME}/docs && ${COPYTREE_SHARE} . ${DOCSDIR})
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ @(cd ${WRKDIR}/${DISTNAME}/docs && ${COPYTREE_SHARE} . ${STAGEDIR}${DOCSDIR})
.endif
@${SETENV} PKG_PREFIX=${PREFIX} \
${SH} ${PKGREQ} ${PKGNAME} POST-INSTALL