aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/oggvideotools/Makefile32
-rw-r--r--multimedia/oggvideotools/distinfo3
-rw-r--r--multimedia/oggvideotools/pkg-descr11
4 files changed, 47 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index b60e28b4897..ebc341acf52 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -208,6 +208,7 @@
SUBDIR += netshow
SUBDIR += noatun-plugins
SUBDIR += nxtvepg
+ SUBDIR += oggvideotools
SUBDIR += ogle
SUBDIR += ogle-gui
SUBDIR += ogmrip
diff --git a/multimedia/oggvideotools/Makefile b/multimedia/oggvideotools/Makefile
new file mode 100644
index 00000000000..756bd12290a
--- /dev/null
+++ b/multimedia/oggvideotools/Makefile
@@ -0,0 +1,32 @@
+# Ports collection makefile for: oggvideotools
+# Date created: Sat Feb 28, 2010
+# Whom: Jille Timmermans (jille@quis.cx)
+# $FreeBSD$
+
+PORTNAME= oggvideotools
+PORTVERSION= 0.8
+CATEGORIES= multimedia
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR= oggvideotools/oggvideotools/${DISTNAME}
+
+MAINTAINER= jille@quis.cx
+COMMENT= A toolbox for manipulating Ogg video files
+
+LIB_DEPENDS= gd.4:${PORTSDIR}/graphics/gd \
+ ogg.6:${PORTSDIR}/audio/libogg \
+ theora.0:${PORTSDIR}/multimedia/libtheora \
+ vorbis.4:${PORTSDIR}/audio/libvorbis
+
+USE_SDL= sdl
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include
+MAKEFILE= makefile
+
+.for app in oggSplit oggDump oggJoin oggCut oggCat oggLength oggSlideshow oggThumb oggResize oggSilence oggScroll mkThumbs mkSlideshow
+PLIST_FILES+= bin/${app}
+.endfor
+.for app in oggResize oggSlideshow oggThumb oggSplit oggJoin oggCut oggCat oggSilence
+MAN1+= ${app}.1
+.endfor
+
+.include <bsd.port.mk>
diff --git a/multimedia/oggvideotools/distinfo b/multimedia/oggvideotools/distinfo
new file mode 100644
index 00000000000..4084b1ea775
--- /dev/null
+++ b/multimedia/oggvideotools/distinfo
@@ -0,0 +1,3 @@
+MD5 (oggvideotools-0.8.tar.gz) = d735b6a4cdb5557340cc4b7d558f1052
+SHA256 (oggvideotools-0.8.tar.gz) = c33f33b400d6c01d12490a063e29347ac36fb59eac00892256552cafb0d4c93a
+SIZE (oggvideotools-0.8.tar.gz) = 476044
diff --git a/multimedia/oggvideotools/pkg-descr b/multimedia/oggvideotools/pkg-descr
new file mode 100644
index 00000000000..662eb5741f7
--- /dev/null
+++ b/multimedia/oggvideotools/pkg-descr
@@ -0,0 +1,11 @@
+The "Ogg Video Tools" is a toolbox for manipulating Ogg video files,
+which usually consist of a video stream (Theora) and an audio stream
+(Vorbis). It includes a number of handy command line tools for
+creating an manipulating these video files, such as for splitting the
+different streams.
+
+At the moment there are the following tools available: oggResize,
+oggThumb, oggSlideshow, oggCut, oggCat, oggSplit, oggJoin, oggDump,
+oggLength, oggSilence and oggScroll.
+
+WWW: http://dev.streamnik.de/oggvideotools.html