aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--www/Makefile1
-rw-r--r--www/p5-Plack-Middleware-Precompressed/Makefile26
-rw-r--r--www/p5-Plack-Middleware-Precompressed/distinfo2
-rw-r--r--www/p5-Plack-Middleware-Precompressed/pkg-descr13
-rw-r--r--www/p5-Plack-Middleware-Precompressed/pkg-plist4
5 files changed, 46 insertions, 0 deletions
diff --git a/www/Makefile b/www/Makefile
index a4fa865e3d0..2bb2560de92 100644
--- a/www/Makefile
+++ b/www/Makefile
@@ -1143,6 +1143,7 @@
SUBDIR += p5-Plack-Middleware-Header
SUBDIR += p5-Plack-Middleware-IEnosniff
SUBDIR += p5-Plack-Middleware-JSConcat
+ SUBDIR += p5-Plack-Middleware-Precompressed
SUBDIR += p5-Plack-Middleware-ReverseProxy
SUBDIR += p5-Plack-Middleware-Session
SUBDIR += p5-Plack-Middleware-Status
diff --git a/www/p5-Plack-Middleware-Precompressed/Makefile b/www/p5-Plack-Middleware-Precompressed/Makefile
new file mode 100644
index 00000000000..b01054e8323
--- /dev/null
+++ b/www/p5-Plack-Middleware-Precompressed/Makefile
@@ -0,0 +1,26 @@
+# New ports collection makefile for: Plack::Middleware::Precompressed
+# Date created: 26 Feb 2011
+# Whom: Jun Kuriyama <kuriyama@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= Plack-Middleware-Precompressed
+PORTVERSION= 1.003
+CATEGORIES= www perl5
+MASTER_SITES= CPAN
+MASTER_SITE_SUBDIR= ../../authors/id/A/AR/ARISTOTLE
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= kuriyama@FreeBSD.org
+COMMENT= Perl extension to serve pre-gzipped content to capable clients
+
+RUN_DEPENDS= \
+ p5-Plack>0:${PORTSDIR}/www/p5-Plack
+BUILD_DEPENDS= ${RUN_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= Plack::Middleware::Precompressed.3
+
+.include <bsd.port.mk>
diff --git a/www/p5-Plack-Middleware-Precompressed/distinfo b/www/p5-Plack-Middleware-Precompressed/distinfo
new file mode 100644
index 00000000000..e3d720ac80f
--- /dev/null
+++ b/www/p5-Plack-Middleware-Precompressed/distinfo
@@ -0,0 +1,2 @@
+SHA256 (Plack-Middleware-Precompressed-1.003.tar.gz) = 019fb2829e02374341d454e189d2d3ef110db5b0d2d9bf5fbb6657bd80f31f2c
+SIZE (Plack-Middleware-Precompressed-1.003.tar.gz) = 10472
diff --git a/www/p5-Plack-Middleware-Precompressed/pkg-descr b/www/p5-Plack-Middleware-Precompressed/pkg-descr
new file mode 100644
index 00000000000..918e236a734
--- /dev/null
+++ b/www/p5-Plack-Middleware-Precompressed/pkg-descr
@@ -0,0 +1,13 @@
+Plack::Middleware::Precompressed is an alternative (or rather,
+complement) to middlewares like Deflater, which will compress response
+bodies on the fly. For dynamic resources, that behaviour is
+necessary, but for static resources it is a waste: identical entities
+will be compressed over and over. Instead, Precompressed allows you
+to compress static resources once, e.g. as part of your build process,
+and then serve the compressed resource in place of the uncompressed
+one for compression-enabled clients.
+
+To do so, it appends a .gz suffix to the request URI and tries to
+serve that. If that fails, it will try again with the unmodified URI.
+
+WWW: http://search.cpan.org/dist/Plack-Middleware-Precompressed/
diff --git a/www/p5-Plack-Middleware-Precompressed/pkg-plist b/www/p5-Plack-Middleware-Precompressed/pkg-plist
new file mode 100644
index 00000000000..8abbc1c7b7e
--- /dev/null
+++ b/www/p5-Plack-Middleware-Precompressed/pkg-plist
@@ -0,0 +1,4 @@
+%%SITE_PERL%%/%%PERL_ARCH%%/auto/Plack/Middleware/Precompressed/.packlist
+%%SITE_PERL%%/Plack/Middleware/Precompressed.pm
+@dirrm %%SITE_PERL%%/%%PERL_ARCH%%/auto/Plack/Middleware/Precompressed
+@dirrmtry %%SITE_PERL%%/%%PERL_ARCH%%/auto/Plack/Middleware