aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--graphics/gts/Makefile3
-rw-r--r--graphics/gts/pkg-descr5
2 files changed, 3 insertions, 5 deletions
diff --git a/graphics/gts/Makefile b/graphics/gts/Makefile
index 1045ed78a3d..dc9eaf0b118 100644
--- a/graphics/gts/Makefile
+++ b/graphics/gts/Makefile
@@ -26,6 +26,9 @@ INSTALLS_SHLIB= yes
CPPFLAGS= -I${LOCALBASE}/include
LDFLAGS= -L${LOCALBASE}/lib
+# Supports only i386 FP operation
+ONLY_FOR_ARCHS= i386
+
post-patch:
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's|-release \$$(LT_RELEASE)||g'
diff --git a/graphics/gts/pkg-descr b/graphics/gts/pkg-descr
index 38bd43fddd2..8ef6d9995ed 100644
--- a/graphics/gts/pkg-descr
+++ b/graphics/gts/pkg-descr
@@ -2,11 +2,6 @@ GTS stands for the GNU Triangulated Surface Library. It is an Open Source
Free Software Library intended to provide a set of useful functions to deal
with 3D surfaces meshed with interconnected triangles.
-The code is written entirely in C with an object-oriented approach based
-mostly on the design of GTK+. Careful attention is paid to performance related
-issues as the initial goal of GTS is to provide a simple and efficient library
-to scientists dealing with 3D computational surface meshes.
-
A brief summary of its main features:
- Simple object-oriented structure giving easy access to topological
properties.