aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.port.mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk/bsd.port.mk')
-rw-r--r--Mk/bsd.port.mk3
1 files changed, 3 insertions, 0 deletions
diff --git a/Mk/bsd.port.mk b/Mk/bsd.port.mk
index 8dc8076284b..4e3f3c9cd3c 100644
--- a/Mk/bsd.port.mk
+++ b/Mk/bsd.port.mk
@@ -1405,6 +1405,7 @@ ETCDIR?= ${PREFIX}/etc/${PORTNAME}
PACKAGES?= ${PORTSDIR}/packages
TEMPLATES?= ${PORTSDIR}/Templates
+KEYWORDS?= ${PORTSDIR}/Keywords
PATCHDIR?= ${MASTERDIR}/files
FILESDIR?= ${MASTERDIR}/files
@@ -5625,6 +5626,8 @@ generate-plist:
.endif
.if !defined(WITH_PKGNG)
@cd ${.CURDIR} && { ${MAKE} pretty-print-config | fold -sw 120 | ${SED} -e 's/^/@comment OPTIONS:/'; } >> ${TMPPLIST}
+ @${AWK} -f ${KEYWORDS}/pkg_install.awk ${TMPPLIST} > ${TMPPLIST}.keyword && \
+ ${MV} -f ${TMPPLIST}.keyword ${TMPPLIST}
.endif
.endif