aboutsummaryrefslogtreecommitdiffstats
path: root/Mk/bsd.xorg.mk
diff options
context:
space:
mode:
Diffstat (limited to 'Mk/bsd.xorg.mk')
-rw-r--r--Mk/bsd.xorg.mk14
1 files changed, 14 insertions, 0 deletions
diff --git a/Mk/bsd.xorg.mk b/Mk/bsd.xorg.mk
index 7d585780987..a2ba2517b29 100644
--- a/Mk/bsd.xorg.mk
+++ b/Mk/bsd.xorg.mk
@@ -104,6 +104,19 @@ RUN_DEPENDS+= ${LOCALBASE}/bin/mkfontdir:${PORTSDIR}/x11-fonts/mkfontdir \
. endif
post-install:
+.if defined(WITH_PKGNG)
+. for _fontdir in ${FONTDIR}
+. if ${INSTALLS_TTF} == yes && ${NEED_MKFONTFOO} == yes
+ @${ECHO_CMD} "@fcfontsdir lib/X11/fonts/${_fontdir}" >> ${TMPPLIST}
+. elif ${INSTALLS_TTF} == yes && ${NEED_MKFONTFOO} == no
+ @${ECHO_CMD} "@fc lib/X11/fonts/${_fontdir}" >> ${TMPPLIST}
+. elif ${NEED_MKFONTFOO} == yes
+ @${ECHO_CMD} "@fontsdir lib/X11/fonts/${_fontdir}" >> ${TMPPLIST}
+. else
+ @${ECHO_CMD} "@dirrmtry lib/X11/fonts/${_fontdir}" >> ${TMPPLIST}
+. endif
+. endfor
+.else
. if ${INSTALLS_TTF} == "yes"
. for _fontdir in ${FONTDIR}
@${ECHO_CMD} "@exec fc-cache -s %D/lib/X11/fonts/${_fontdir} 2>/dev/null || true" >> ${TMPPLIST}
@@ -123,6 +136,7 @@ post-install:
@${ECHO_CMD} "@unexec rmdir %D/lib/X11/fonts/${_fontdir} 2>/dev/null || true" >> ${TMPPLIST}
. endfor
. endif
+.endif
. if ${XORG_CAT} == "lib"
USES+= pathfix