aboutsummaryrefslogtreecommitdiffstats
path: root/astro/viking/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/viking/Makefile')
-rw-r--r--astro/viking/Makefile45
1 files changed, 45 insertions, 0 deletions
diff --git a/astro/viking/Makefile b/astro/viking/Makefile
new file mode 100644
index 00000000000..070bdbd02da
--- /dev/null
+++ b/astro/viking/Makefile
@@ -0,0 +1,45 @@
+# New ports collection makefile for: viking
+# Date created: 29 April 2008
+# Whom: David Le Brun <david@trucs.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= viking
+PORTVERSION= 0.9.4
+CATEGORIES= astro
+MASTER_SITES= SF
+
+MAINTAINER= david@trucs.org
+COMMENT= Program to manage GPS data (tracks, waypoints, etc)
+
+LIB_DEPENDS= curl.4:${PORTSDIR}/ftp/curl \
+ expat.6:${PORTSDIR}/textproc/expat2
+RUN_DEPENDS= gpsbabel:${PORTSDIR}/astro/gpsbabel
+
+USE_PERL5_RUN= yes
+USE_GMAKE= yes
+USE_GNOME= gtk20 libglade2
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+OPTIONS= GPSD "Enable realtime GPS tracking" off
+
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_GPSD)
+LIB_DEPENDS+= gps.17:${PORTSDIR}/astro/gpsd
+.else
+CONFIGURE_ARGS+= --disable-realtime-gps-tracking
+.endif
+
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+= --disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
+
+.include <bsd.port.post.mk>