aboutsummaryrefslogtreecommitdiffstats
path: root/astro/xmoontool/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'astro/xmoontool/Makefile')
-rw-r--r--astro/xmoontool/Makefile48
1 files changed, 48 insertions, 0 deletions
diff --git a/astro/xmoontool/Makefile b/astro/xmoontool/Makefile
new file mode 100644
index 00000000000..e64458b0d2c
--- /dev/null
+++ b/astro/xmoontool/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: xmoontool
+# Date created: 31 December 2005
+# Whom: Frank W. Josellis <frank@dynamical-systems.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xmoontool
+PORTVERSION= 3.0.1a
+CATEGORIES= astro
+MASTER_SITES= http://www.senax.net/xmoontool/
+
+MAINTAINER= frank@dynamical-systems.org
+COMMENT= A version of John Walker's classical moontool for X11/Motif
+
+USE_REINPLACE= yes
+USE_MOTIF= yes
+USE_X_PREFIX= yes
+
+MAN1= xmoontool.1
+PORTDOCS= NOTES
+PLIST_FILES= bin/xmoontool
+
+.include <bsd.port.pre.mk>
+
+pre-configure:
+.if !defined(WITHOUT_DEFAULT_COLOR)
+ @${ECHO_MSG} "For use with monochrome displays try to set WITHOUT_DEFAULT_COLOR"
+.endif
+
+do-configure:
+.if defined(WITHOUT_DEFAULT_COLOR)
+ @${REINPLACE_CMD} -e 's|-DDEFAULT_COLOR||g' ${WRKSRC}/Makefile
+.endif
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/xmoontool ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/xmoontool.1 ${PREFIX}/man/man1
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for i in ${PORTDOCS}
+ ${INSTALL_MAN} ${WRKSRC}/${i} ${DOCSDIR}
+.endfor
+.endif
+
+.include <bsd.port.post.mk>