aboutsummaryrefslogtreecommitdiffstats
path: root/audio/adplay/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/adplay/Makefile')
-rw-r--r--audio/adplay/Makefile9
1 files changed, 4 insertions, 5 deletions
diff --git a/audio/adplay/Makefile b/audio/adplay/Makefile
index e117c6e78ab..06bee6d1548 100644
--- a/audio/adplay/Makefile
+++ b/audio/adplay/Makefile
@@ -47,15 +47,14 @@ OPTIONS= SDL "Build with SDL output support" off
USE_SDL= sdl mixer
.endif
+.if ${OSVERSION} < 500000
+BROKEN= depends on audio/libadplug
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|^\(adplug_data_dir.*\)/.*|\1|' \
${WRKSRC}/src/Makefile.in
-
-.if ${OSVERSION} > 500000
@${RM} ${WRKSRC}/src/getopt.h
-.else
- @${CP} ${FILESDIR}/getopt.h ${WRKSRC}/src
-.endif
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/adplay ${PREFIX}/bin