aboutsummaryrefslogtreecommitdiffstats
path: root/audio/gtkpod/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/gtkpod/Makefile')
-rw-r--r--audio/gtkpod/Makefile21
1 files changed, 6 insertions, 15 deletions
diff --git a/audio/gtkpod/Makefile b/audio/gtkpod/Makefile
index 3957e42f5a5..8d62a8c7215 100644
--- a/audio/gtkpod/Makefile
+++ b/audio/gtkpod/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gtkpod
-PORTVERSION= 0.99.8
-PORTREVISION= 3
+PORTVERSION= 0.99.10
CATEGORIES= audio
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,16 +15,15 @@ MAINTAINER= danfe@FreeBSD.org
COMMENT= GUI for Apple iPods using GTK2
LIB_DEPENDS= id3tag.0:${PORTSDIR}/audio/libid3tag \
- gpod.1:${PORTSDIR}/audio/libgpod
+ gpod.2:${PORTSDIR}/audio/libgpod
RUN_DEPENDS= mp3gain:${PORTSDIR}/audio/mp3gain \
iconv:${PORTSDIR}/converters/libiconv
-USE_X_PREFIX= yes
-
USE_GETTEXT= yes
USE_GMAKE= yes
USE_GNOME= gtk20 libglade2
GNU_CONFIGURE= yes
+INSTALLS_ICONS= yes
OPTIONS= MPEG4IP "Enable AAC and H.264 support with MPEG4IP" off
@@ -46,20 +44,13 @@ pre-configure: .SILENT
# install locale correctly (share dir instead of lib dir)
${REINPLACE_CMD} -e 's|DATADIRNAME=lib|DATADIRNAME=share|' \
${WRKSRC}/configure
- ${REINPLACE_CMD} -e 's|(libdir)/locale|(datadir)/locale|' \
- ${WRKSRC}/po/Makefile.in.in
-# work-around a segfault when attempting to delete track from iPod
- ${REINPLACE_CMD} '83,85d' ${WRKSRC}/src/confirmation.c
-# catch up with recent libgpod update to version 0.4.2
- ${REINPLACE_CMD} -e 's|unk208|mediatype|g' ${WRKSRC}/src/file.c \
- ${WRKSRC}/src/file_itunesdb.c
post-install:
.if !defined(NOPORTDOCS)
@${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/ChangeLog ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/TODOandBUGS.txt ${DOCSDIR}
+.for f in ChangeLog README TODOandBUGS.txt TROUBLESHOOTING
+ ${INSTALL_DATA} ${WRKSRC}/${f} ${DOCSDIR}
+.endfor
.endif
.include <bsd.port.post.mk>