aboutsummaryrefslogtreecommitdiffstats
path: root/audio/py-pyacoustid/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'audio/py-pyacoustid/Makefile')
-rw-r--r--audio/py-pyacoustid/Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/audio/py-pyacoustid/Makefile b/audio/py-pyacoustid/Makefile
new file mode 100644
index 00000000000..f0883d4059d
--- /dev/null
+++ b/audio/py-pyacoustid/Makefile
@@ -0,0 +1,31 @@
+# Created by: Mark Felder <feld@feld.me>
+# $FreeBSD$
+
+PORTNAME= pyacoustid
+PORTVERSION= 0.7
+CATEGORIES= audio python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= feld@feld.me
+COMMENT= Bindings for Chromaprint acoustic fingerprinting and the Acoustid API
+
+LICENSE= MIT
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}setuptools>=0:${PORTSDIR}/devel/py-setuptools
+LIB_DEPENDS= chromaprint:${PORTSDIR}/audio/chromaprint
+
+USE_PYTHON= yes
+PLIST_FILES= %%PYTHON_SITELIBDIR%%/acoustid.py \
+ %%PYTHON_SITELIBDIR%%/chromaprint.py
+
+.include <bsd.port.pre.mk>
+
+do-build:
+ @(cd ${BUILD_WRKSRC}; ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} \
+ ${PYSETUP} build)
+
+do-install:
+ cd ${WRKSRC}/build/lib && ${COPYTREE_SHARE} \* ${PYTHONPREFIX_SITELIBDIR}/
+
+.include <bsd.port.post.mk>