aboutsummaryrefslogtreecommitdiffstats
path: root/audio/x11amp
diff options
context:
space:
mode:
Diffstat (limited to 'audio/x11amp')
-rw-r--r--audio/x11amp/Makefile4
-rw-r--r--audio/x11amp/pkg-plist1
2 files changed, 4 insertions, 1 deletions
diff --git a/audio/x11amp/Makefile b/audio/x11amp/Makefile
index ed3221c8421..6d41f9affe7 100644
--- a/audio/x11amp/Makefile
+++ b/audio/x11amp/Makefile
@@ -21,6 +21,7 @@ USE_XLIB= yes
USE_GNOME= gtk12 esound
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-static
CONFIGURE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}"
@@ -30,4 +31,7 @@ post-extract:
@${CP} ${FILESDIR}/main.xpm ${WRKSRC}/x11amp/defskin
@${CHMOD} a+x ${WRKSRC}/ltconfig
+post-patch:
+ @${REINPLACE_CMD} -e '/objformat=/s|=.*|=elf|' ${WRKSRC}/ltconfig
+
.include <bsd.port.post.mk>
diff --git a/audio/x11amp/pkg-plist b/audio/x11amp/pkg-plist
index cd32e9774f3..4a1b235f63d 100644
--- a/audio/x11amp/pkg-plist
+++ b/audio/x11amp/pkg-plist
@@ -3,7 +3,6 @@ bin/x11amp
include/x11amp/configfile.h
include/x11amp/plugin.h
include/x11amp/x11ampctrl.h
-lib/libx11amp.a
lib/libx11amp.la
lib/libx11amp.so
lib/libx11amp.so.9