aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/amp/Makefile4
1 files changed, 4 insertions, 0 deletions
diff --git a/audio/amp/Makefile b/audio/amp/Makefile
index 22575d7609c..bab3128377a 100644
--- a/audio/amp/Makefile
+++ b/audio/amp/Makefile
@@ -16,6 +16,10 @@ USES= gmake
PLIST_FILES= bin/amp \
man/man1/amp.1.gz
+post-configure:
+ @${REINPLACE_CMD} -e 's|-O6 -ffast-math -fomit-frame-pointer|${CFLAGS}|' \
+ -e 's|gcc|${CC}|' ${WRKSRC}/Makefile
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/amp ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/amp.1 ${STAGEDIR}${PREFIX}/man/man1