aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/cheesetracker/Makefile4
-rw-r--r--audio/ecawave/Makefile2
-rw-r--r--audio/jack/Makefile4
-rw-r--r--audio/lmms/Makefile4
-rw-r--r--audio/mixmos/Makefile8
-rw-r--r--audio/mixxx/Makefile8
-rw-r--r--audio/mp3stat/Makefile4
-rw-r--r--audio/mpmf20/Makefile8
-rw-r--r--audio/rezound/Makefile4
-rw-r--r--audio/shoutcast/Makefile10
-rw-r--r--audio/xmcd/Makefile8
-rw-r--r--audio/xmradio/Makefile6
12 files changed, 9 insertions, 61 deletions
diff --git a/audio/cheesetracker/Makefile b/audio/cheesetracker/Makefile
index a3cae6b1278..709c94557ab 100644
--- a/audio/cheesetracker/Makefile
+++ b/audio/cheesetracker/Makefile
@@ -40,10 +40,6 @@ BROKEN= Does not compile on alpha
LIB_DEPENDS+= gmp.7:${PORTSDIR}/math/libgmp4
.endif
-.if ${OSVERSION} < 600020
-BROKEN= Requires MSG_NOSIGNAL
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's|%%CXXFLAGS%%|${CXXFLAGS}| ; \
s|%%PTHREAD_CFLAGS%%|${PTHREAD_CFLAGS}|g ; \
diff --git a/audio/ecawave/Makefile b/audio/ecawave/Makefile
index 0fc4be73071..f5537c2198a 100644
--- a/audio/ecawave/Makefile
+++ b/audio/ecawave/Makefile
@@ -31,7 +31,7 @@ MAN1= ecawave.1
.include <bsd.port.pre.mk>
-.if ${ARCH} == "alpha" && ${OSVERSION} >= 502102
+.if ${ARCH} == "alpha"
BROKEN= Configure fails on alpha 5.x
.endif
diff --git a/audio/jack/Makefile b/audio/jack/Makefile
index 4f0a26b8709..0de92dcab41 100644
--- a/audio/jack/Makefile
+++ b/audio/jack/Makefile
@@ -47,10 +47,6 @@ CONFIGURE_ENV+= ac_cv_prog_HAVE_DOXYGEN="false"
PLIST_SUB+= DOCS="@comment "
.endif
-.if (${OSVERSION} < 502102 )
-BROKEN= Does not compile
-.endif
-
.if exists(${LOCALBASE}/lib/libreadline.so.5)
LIB_DEPENDS+= readline.5:${PORTSDIR}/devel/readline
.endif
diff --git a/audio/lmms/Makefile b/audio/lmms/Makefile
index 945763dd2e4..17eec054423 100644
--- a/audio/lmms/Makefile
+++ b/audio/lmms/Makefile
@@ -56,10 +56,6 @@ post-install:
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 600000
-BROKEN= fails to install
-.endif
-
.if ${OSVERSION} >= 700042 && ${ARCH} == "amd64"
BROKEN= does not compile
.endif
diff --git a/audio/mixmos/Makefile b/audio/mixmos/Makefile
index d5255066c4a..5d5069a55a5 100644
--- a/audio/mixmos/Makefile
+++ b/audio/mixmos/Makefile
@@ -21,10 +21,4 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
MAN1= mixmos.1
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 501105
-IGNORE= require SOUND_MIXER_INFO ioctl
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/mixxx/Makefile b/audio/mixxx/Makefile
index a45dd99c7d2..4fbcb861df7 100644
--- a/audio/mixxx/Makefile
+++ b/audio/mixxx/Makefile
@@ -36,12 +36,6 @@ CONFIGURE_ENV= QMAKESPEC="freebsd-g++"
CONFIGURE_ARGS= --prefix=${PREFIX}
MAKE_ENV= QTDIR="${QT_PREFIX}"
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 503001
-IGNORE= does not compile on FreeBSD < 5.3, due to lack of round() in libm
-.endif
-
post-patch:
@${REINPLACE_CMD} \
-e 's|/bin/bash|${LOCALBASE}&| ; \
@@ -60,4 +54,4 @@ post-install:
${INSTALL_DATA} ${WRKSRC}/Mixxx-Manual.pdf ${WRKSRC}/README ${DOCSDIR}
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/mp3stat/Makefile b/audio/mp3stat/Makefile
index 385974a95a5..a91e5cbc05f 100644
--- a/audio/mp3stat/Makefile
+++ b/audio/mp3stat/Makefile
@@ -36,10 +36,6 @@ OPTIONS= VORBIS "Ogg/Vorbis support" on
.include <bsd.port.pre.mk>
-.if ${OSVERSION} < 504000
-BUILD_DEPENDS+= ${LOCALBASE}/include/magic.h:${PORTSDIR}/sysutils/file
-.endif
-
.if defined(WITHOUT_VORBIS)
MAKE_ARGS+= VORBIS=""
.else
diff --git a/audio/mpmf20/Makefile b/audio/mpmf20/Makefile
index 5a5b21e4a4c..c6526431fd3 100644
--- a/audio/mpmf20/Makefile
+++ b/audio/mpmf20/Makefile
@@ -20,13 +20,7 @@ NOT_FOR_ARCHS= ia64 sparc64
MAKEFILE= makefile
PLIST_FILES= bin/mpmf20
-.include <bsd.port.pre.mk>
-
-.if ${ARCH} == i386 && ${OSVERSION} < 502108
-BROKEN= ffs() clash, see i386/41930
-.endif
-
do-install:
@${INSTALL_PROGRAM} ${WRKSRC}/mpmf20 ${PREFIX}/bin
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/rezound/Makefile b/audio/rezound/Makefile
index 0436d22566a..bc0bcde83f2 100644
--- a/audio/rezound/Makefile
+++ b/audio/rezound/Makefile
@@ -108,12 +108,8 @@ PLIST_SUB+= NLS="@comment "
post-patch: .SILENT
${REINPLACE_CMD} -e '/atoll/d' ${WRKSRC}/config/platform/bsd.h
-.if ${OSVERSION} > 502112
${REINPLACE_CMD} -e '/round/d' ${WRKSRC}/config/platform/bsd.h
-.endif
-.if ${OSVERSION} > 502120
${REINPLACE_CMD} -e '/nearbyint/d' ${WRKSRC}/config/platform/bsd.h
-.endif
${REINPLACE_CMD} -E 's,(_nl_expand_alias \()\),\1...),' ${WRKSRC}/configure
${REINPLACE_CMD} -e 's,$$(prefix)/doc,$$(datadir)/doc,' \
${WRKSRC}/config/am_include.mk ${WRKSRC}/Makefile.in \
diff --git a/audio/shoutcast/Makefile b/audio/shoutcast/Makefile
index 9b0f782cd13..c90eafdc4d9 100644
--- a/audio/shoutcast/Makefile
+++ b/audio/shoutcast/Makefile
@@ -13,6 +13,8 @@ DISTNAME= sc_serv_${PORTVERSION}_FreeBSD5
MAINTAINER= gabor@FreeBSD.org
COMMENT= Nullsoft's streaming audio server (binary port)
+LIB_DEPENDS= c.5:${PORTSDIR}/misc/compat5x
+
IA32_BINARY_PORT= YES
NO_BUILD= YES
RESTRICTED= Redistribution of the software is not allowed
@@ -23,12 +25,6 @@ USE_RC_SUBR= shoutcast.sh
PORTDOCS= README.TXT
WRKSRC= ${WRKDIR}
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 600000
-LIB_DEPENDS+= c.5:${PORTSDIR}/misc/compat5x
-.endif
-
post-patch:
@${REINPLACE_CMD} -e 's/[[:cntrl:]]*$$//' \
-e 's|=sc_serv.log|=/var/log/sc_serv.log|' \
@@ -53,4 +49,4 @@ do-install:
post-install:
@${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/xmcd/Makefile b/audio/xmcd/Makefile
index 5a0ab89ce33..8117705f02e 100644
--- a/audio/xmcd/Makefile
+++ b/audio/xmcd/Makefile
@@ -26,12 +26,6 @@ PLIST_SUB+= RELEASE=${OSREL:R:R} ARCH=${ARCH}
SUB_FILES= pkg-message
PKGMESSAGE= ${WRKDIR}/pkg-message
-.include <bsd.port.pre.mk>
-
-.if (${OSVERSION} < 600000 && ${ARCH} == "sparc64")
-BROKEN= Does not compile on FreeBSD 5.x sparc64
-.endif
-
LIBBINDIR= ${PREFIX}/lib/X11/xmcd/bin-FreeBSD_${OSREL:R:R}-${ARCH}
post-extract:
@@ -56,4 +50,4 @@ post-install:
@${CAT} ${PKGMESSAGE}
@${CP} ${WRKSRC}/xmcd_d/XMcd.ad ${PREFIX}/lib/X11/app-defaults/XMcd
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/audio/xmradio/Makefile b/audio/xmradio/Makefile
index fbd3bdf279f..8872d59e6dd 100644
--- a/audio/xmradio/Makefile
+++ b/audio/xmradio/Makefile
@@ -25,15 +25,11 @@ ONLY_FOR_ARCHS= i386 ia64
PLIST_FILES= bin/xmradio lib/X11/app-defaults/XMradio
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} > 502100
post-patch:
${REINPLACE_CMD} -e "s,machine/ioctl_bt848.h,dev/bktr/ioctl_bt848.h," \
${WRKSRC}/radio.c
-.endif
#
#post-install:
# ${STRIP_CMD} ${PREFIX}/bin/xmradio
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>