aboutsummaryrefslogtreecommitdiffstats
path: root/audio
diff options
context:
space:
mode:
Diffstat (limited to 'audio')
-rw-r--r--audio/Maaate/Makefile16
-rw-r--r--audio/Maaate/files/patch-configure12
-rw-r--r--audio/Maaate/pkg-descr2
-rw-r--r--audio/Maaate/pkg-plist5
4 files changed, 24 insertions, 11 deletions
diff --git a/audio/Maaate/Makefile b/audio/Maaate/Makefile
index 3c72f10c828..46339480025 100644
--- a/audio/Maaate/Makefile
+++ b/audio/Maaate/Makefile
@@ -3,26 +3,36 @@
PORTNAME= Maaate
PORTVERSION= 0.3.1
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= audio
MASTER_SITES= SF/${PORTNAME:L}/${PORTNAME:L}/${PORTNAME}-${PORTVERSION}.tar.gz
MAINTAINER= saper@saper.info
COMMENT= MPEG audio analysis toolkit
+LICENSE= GPLv2
+
USES= gmake
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+PORTDOCS= API.html ChangeLog THANKS applications.html
+
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|-ldl||g ; \
s|(CCLD|(CXXLD|g' ${WRKSRC}/demos/Makefile.in
post-install:
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${STAGEDIR}${DOCSDIR}
-.for file in API.html ChangeLog THANKS applications.html
- ${INSTALL_DATA} ${WRKSRC}/doc/${file} ${STAGEDIR}${DOCSDIR}
+.for f in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/doc/${f} ${STAGEDIR}${DOCSDIR}
.endfor
+.endif
.include <bsd.port.mk>
diff --git a/audio/Maaate/files/patch-configure b/audio/Maaate/files/patch-configure
index f6f93d570a5..8d8054f9723 100644
--- a/audio/Maaate/files/patch-configure
+++ b/audio/Maaate/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig Thu Sep 5 09:54:07 2002
-+++ configure Mon Sep 30 22:55:21 2002
+--- configure.orig 2002-10-09 03:30:34.000000000 +0200
++++ configure 2013-12-18 12:38:19.000000000 +0100
@@ -5691,6 +5691,7 @@
# This can be used to rebuild libtool when needed
@@ -8,3 +8,11 @@
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
+@@ -5699,7 +5700,6 @@
+
+
+
+-LDFLAGS="$LDFLAGS -lstdc++"
+
+ echo $ac_n "checking for cos in -lm""... $ac_c" 1>&6
+ echo "configure:5706: checking for cos in -lm" >&5
diff --git a/audio/Maaate/pkg-descr b/audio/Maaate/pkg-descr
index 9872ca5ddbe..86a80642bfa 100644
--- a/audio/Maaate/pkg-descr
+++ b/audio/Maaate/pkg-descr
@@ -9,4 +9,4 @@ parsing of the MPEG audio stream, the second tier implements the
content analysis on the extracted field, and the third tier includes
any applications that are based on the extracted content.
-WWW: http://www.cmis.csiro.au/maaate/
+WWW: http://maaate.sourceforge.net/
diff --git a/audio/Maaate/pkg-plist b/audio/Maaate/pkg-plist
index 268625fe637..9b904362a95 100644
--- a/audio/Maaate/pkg-plist
+++ b/audio/Maaate/pkg-plist
@@ -40,10 +40,5 @@ lib/libMaaateP.a
lib/libMaaateP.la
lib/libMaaateP.so
lib/libMaaateP.so.1
-%%PORTDOCS%%%%DOCSDIR%%/API.html
-%%PORTDOCS%%%%DOCSDIR%%/ChangeLog
-%%PORTDOCS%%%%DOCSDIR%%/THANKS
-%%PORTDOCS%%%%DOCSDIR%%/applications.html
-%%PORTDOCS%%@dirrm %%DOCSDIR%%
@dirrm lib/Maaate
@dirrm include/Maaate