aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/flowgrind/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks/flowgrind/Makefile')
-rw-r--r--benchmarks/flowgrind/Makefile27
1 files changed, 20 insertions, 7 deletions
diff --git a/benchmarks/flowgrind/Makefile b/benchmarks/flowgrind/Makefile
index a2d55756285..3e060e2b608 100644
--- a/benchmarks/flowgrind/Makefile
+++ b/benchmarks/flowgrind/Makefile
@@ -2,20 +2,33 @@
# $FreeBSD$
PORTNAME= flowgrind
-PORTVERSION= 0.6.1
-PORTREVISION= 1
+PORTVERSION= 0.7.1
CATEGORIES= benchmarks
-MASTER_SITES= https://launchpad.net/flowgrind/trunk/${PORTNAME}-0.6.1/+download/
MAINTAINER= lars@eggert.org
COMMENT= Measure throughput and other metrics for TCP
-LIB_DEPENDS= libxmlrpc++.so:${PORTSDIR}/net/xmlrpc-c \
+LICENSE= GPLv3
+
+BUILD_DEPENDS= pcap-config:${PORTSDIR}/net/libpcap
+LIB_DEPENDS= libpcap.so:${PORTSDIR}/net/libpcap \
libgsl.so:${PORTSDIR}/math/gsl \
- libpcap.so.1:${PORTSDIR}/net/libpcap
+ libxmlrpc.so:${PORTSDIR}/net/xmlrpc-c
+
+USE_GITHUB= yes
+GH_ACCOUNT= ${PORTNAME}
+GH_TAGNAME= ${PORTNAME}-${PORTVERSION}
+GH_COMMIT= 14b0578
-USES= tar:bzip2
+USE_AUTOTOOLS= aclocal autoconf
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-debug
+CONFIGURE_ARGS= --enable-pcap --enable-gsl
+
+post-patch:
+ @${RM} -rf ${WRKSRC}/build-aux
+ @${REINPLACE_CMD} -e 's|AC_LIB_RPATH||g' ${WRKSRC}/configure.ac
+
+pre-configure:
+ cd ${WRKSRC} && ${AUTORECONF} -i
.include <bsd.port.mk>