aboutsummaryrefslogtreecommitdiffstats
path: root/benchmarks/scimark2c/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'benchmarks/scimark2c/Makefile')
-rw-r--r--benchmarks/scimark2c/Makefile43
1 files changed, 43 insertions, 0 deletions
diff --git a/benchmarks/scimark2c/Makefile b/benchmarks/scimark2c/Makefile
new file mode 100644
index 00000000000..d24651f764f
--- /dev/null
+++ b/benchmarks/scimark2c/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: scimark2c
+# Date created: Sat Apr 05 2003
+# Whom: thierry@pompo.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= scimark2c
+PORTVERSION= 2.0
+CATEGORIES= benchmarks
+MASTER_SITES= http://math.nist.gov/scimark2/
+DISTNAME= ${PORTNAME}
+
+MAINTAINER= thierry@pompo.net
+COMMENT= An ANSI C version of the SciMark2 benchmark
+
+WRKSRC= ${WRKDIR}
+USE_REINPLACE= yes
+USE_ZIP= yes
+
+MALLOC2STD= kernel.c Stopwatch.c Random.c array.c
+
+post-patch:
+.for file in ${MALLOC2STD}
+ @${REINPLACE_CMD} -e "s|malloc.h|stdlib.h|" ${WRKSRC}/${file}
+.endfor
+
+do-install:
+ @${INSTALL_PROGRAM} ${WRKSRC}/scimark2 ${PREFIX}/bin
+
+post-install:
+ @${ECHO} "*****************************************************************************"
+ @${ECHO} ""
+ @${ECHO} " Just run scimark2 or scimark2 -large"
+ @${ECHO} ""
+ @${ECHO} " The first SciMark number reported is the composite score, followed by the an"
+ @${ECHO} " approximate Mflop rate for each kernel."
+ @${ECHO} ""
+ @${ECHO} " You may try to hack CC or CFLAGS in /etc/make.conf..."
+ @${ECHO} ""
+ @${ECHO} "*****************************************************************************"
+
+.include <bsd.port.mk>