aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/CJK/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/CJK/Makefile')
-rw-r--r--chinese/CJK/Makefile14
1 files changed, 8 insertions, 6 deletions
diff --git a/chinese/CJK/Makefile b/chinese/CJK/Makefile
index 71b9b6fde92..6df5794ddf3 100644
--- a/chinese/CJK/Makefile
+++ b/chinese/CJK/Makefile
@@ -1,34 +1,36 @@
# New ports collection makefile for: zh-CJK
# Version required: 4.3.0
# Date created: 5 Sep 1999
-# Whom: J.T. Jang (jtjang@gcn.net.tw)
+# Whom: Keith Jang (keith@freebsd.sinica.edu.tw)
#
# $FreeBSD$
#
DISTNAME= zh-CJK-4.3.0
CATEGORIES= chinese
-MASTER_SITES= ftp://ftp.ffii.org/pub/cjk/devel/
+MASTER_SITES= ftp://freebsd.sinica.edu.tw/pub/keith/
DISTFILES= cjk-current.tar.gz
-MAINTAINER= jtjang@gcn.net.tw
+MAINTAINER= keith@freebsd.sinica.edu.tw
BUILD_DEPENDS= latex:${PORTSDIR}/print/teTeX \
- ${X11BASE}/lib/X11/fonts/TrueType/moe_lishu.ttf:${PORTSDIR}/chinese/moettf \
+ ${X11BASE}/lib/X11/fonts/TrueType/bsmi00lp.ttf:${PORTSDIR}/chinese/arphicttf \
ttf2pk:${PORTSDIR}/print/freetype:build
LIB_DEPENDS= ttf.4:${PORTSDIR}/print/freetype
RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX
-NO_PACKAGE= Interactive
+NO_PACKAGE= "Needs ttf2pk source from FreeType"
USE_GMAKE= yes
WRKSRC= ${WRKDIR}/cjk-current
post-install:
.if !defined(NOPORTDOCS)
+ ${RM} -fr ${PREFIX}/share/doc/CJK
${CP} -R ${WRKSRC}/doc ${PREFIX}/share/doc/CJK
- ${CP} -R ${WRKSRC}/examples ${PREFIX}/share/examples/CJK
.endif
+ ${RM} -fr ${PREFIX}/share/examples/CJK
+ ${CP} -R ${WRKSRC}/examples ${PREFIX}/share/examples/CJK
MAN1= bg5conv.1 cef5conv.1 cefconv.1 cefsconv.1 extconv.1 \
hbf2gf.1 sjisconv.1 thaiconv.1 ttf2pk.1 ttf2tfm.1