aboutsummaryrefslogtreecommitdiffstats
path: root/chinese/celvis/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'chinese/celvis/Makefile')
-rw-r--r--chinese/celvis/Makefile30
1 files changed, 30 insertions, 0 deletions
diff --git a/chinese/celvis/Makefile b/chinese/celvis/Makefile
new file mode 100644
index 00000000000..1bafc3b93f2
--- /dev/null
+++ b/chinese/celvis/Makefile
@@ -0,0 +1,30 @@
+# New ports collection makefile for: celvis
+# Version required: 1.3
+# Date created: Thur Aug 15, 1996
+# Whom: David O'Brien (obrien@cs.ucdavis.edu)
+#
+# $Id: Makefile,v 1.1.1.1 1996/08/09 04:17:16 asami Exp $
+#
+
+DISTNAME= celvis
+PKGNAME= celvis-1.3
+CATEGORIES+= chinese editors
+MASTER_SITES= ftp://ftp.cs.purdue.edu/pub/ygz/ \
+ ftp://ftp.ifcss.org/pub/software/x-win/cxterm/
+
+MAINTAINER= obrien@cs.ucdavis.edu
+
+do-install:
+ @# install target in celvis Makefile is not too good -- this is easier
+ ${INSTALL_PROGRAM} ${WRKSRC}/celvis ${WRKSRC}/virec ${PREFIX}/bin
+ ln -sf ${PREFIX}/bin/celvis ${PREFIX}/bin/cvi
+ ${INSTALL_MAN} ${FILESDIR}/celvis.1 ${PREFIX}/man/man1/celvis.1
+.if !defined{NOMANCOMPRESS}
+ gzip -9nf ${PREFIX}/man/man1/celvis.1
+ ln -sf ${PREFIX}/man/man1/celvis.1.gz ${PREFIX}/man/man1/cvi.1.gz
+.else
+ ln -sf ${PREFIX}/man/man1/celvis.1 ${PREFIX}/man/man1/cvi.1
+.endif
+
+
+.include <bsd.port.mk>