aboutsummaryrefslogtreecommitdiffstats
path: root/comms/scmxx/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/scmxx/Makefile')
-rw-r--r--comms/scmxx/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/comms/scmxx/Makefile b/comms/scmxx/Makefile
new file mode 100644
index 00000000000..d55e8150960
--- /dev/null
+++ b/comms/scmxx/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: scmxx
+# Date created: 21.03.2002
+# Whom: Janos.Mohacsi@bsd.hu
+#
+# $FreeBSD$
+#
+
+PORTNAME= scmxx
+PORTVERSION= 0.6.1.5
+CATEGORIES= comms
+MASTER_SITES= http://ma2geo.mathematik.uni-karlsruhe.de/~hendrik/scmxx/download/
+
+MAINTAINER= janos.mohacsi@bsd.hu
+
+LIB_DEPENDS= gnugetopt.1:${PORTSDIR}/devel/libgnugetopt
+
+USE_BZIP2= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib -lgnugetopt"
+USE_GMAKE= yes
+
+MAN1= scmxx.1
+
+.ifndef(NOPORTDOCS)
+post-install:
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/docs/*.txt ${DOCSDIR}
+ @${MKDIR} ${EXAMPLESDIR}
+.for file in phonebook sms vCalendar
+ ${INSTALL_DATA} ${WRKSRC}/examples/${file} ${EXAMPLESDIR}
+.endfor
+.endif
+
+.include <bsd.port.mk>