aboutsummaryrefslogtreecommitdiffstats
path: root/comms/svxlink/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/svxlink/Makefile')
-rw-r--r--comms/svxlink/Makefile24
1 files changed, 12 insertions, 12 deletions
diff --git a/comms/svxlink/Makefile b/comms/svxlink/Makefile
index 53483be5fe9..5c935d40b1d 100644
--- a/comms/svxlink/Makefile
+++ b/comms/svxlink/Makefile
@@ -10,15 +10,15 @@ COMMENT?= General purpose ham radio voice services
LICENSE= GPLv2
-LIB_DEPENDS?= libgsm.so:${PORTSDIR}/audio/gsm \
- libspeex.so:${PORTSDIR}/audio/speex \
- libgpg-error.so:${PORTSDIR}/security/libgpg-error \
- libgcrypt.so:${PORTSDIR}/security/libgcrypt \
- libsigc-2.0.so:${PORTSDIR}/devel/libsigc++20 \
- libpopt.so:${PORTSDIR}/devel/popt \
- libopus.so:${PORTSDIR}/audio/opus
-BUILD_DEPENDS= pkg-config:${PORTSDIR}/devel/pkgconf \
- ${LOCALBASE}/include/linux/input.h:${PORTSDIR}/multimedia/v4l_compat
+LIB_DEPENDS?= libgsm.so:audio/gsm \
+ libspeex.so:audio/speex \
+ libgpg-error.so:security/libgpg-error \
+ libgcrypt.so:security/libgcrypt \
+ libsigc-2.0.so:devel/libsigc++20 \
+ libpopt.so:devel/popt \
+ libopus.so:audio/opus
+BUILD_DEPENDS= pkg-config:devel/pkgconf \
+ ${LOCALBASE}/include/linux/input.h:multimedia/v4l_compat
USE_GITHUB= yes
GH_ACCOUNT= sm0svx
@@ -41,7 +41,7 @@ STATIC_CMAKE_ON= -DBUILD_STATIC_LIBS=YES
OPTIONS_DEFAULT=OSS ALSA
OPTIONS_MULTI= SOUND
OPTIONS_MULTI_SOUND= ALSA OSS
-ALSA_LIB_DEPENDS= libasound.so:${PORTSDIR}/audio/alsa-lib
+ALSA_LIB_DEPENDS= libasound.so:audio/alsa-lib
ALSA_CMAKE_OFF= -DUSE_ALSA:BOOL=OFF
ALSA_CMAKE_ON= -DUSE_ALSA:BOOL=ON
OSS_CMAKE_OFF= -DUSE_OSS:BOOL=OFF
@@ -49,8 +49,8 @@ OSS_CMAKE_ON= -DUSE_OSS:BOOL=ON
.endif
DOCS_ALL_TARGET=doc
DOCS_CMAKE_OFF= -DCMAKE_DISABLE_FIND_PACKAGE_Doxygen:BOOL=TRUE
-DOCS_BUILD_DEPENDS= doxygen:${PORTSDIR}/devel/doxygen \
- dot:${PORTSDIR}/graphics/graphviz
+DOCS_BUILD_DEPENDS= doxygen:devel/doxygen \
+ dot:graphics/graphviz
OPTIONS_SUB= yes
PORTDOCS= *
fonts/libXft?h=gnome-3.28&id=aee43c825bdc903e20204b247f2b4180a506eb09'>Misc X.org port updates:kwm2015-04-182-2/+2 * - Drop @dirrm* from pkg-plistsamdmi32015-01-291-1/+0 * Update libXft to 2.3.2.kwm2015-01-164-22/+4 * When linking a library libA with a library libB using libtool, if libB.latijl2014-04-231-1/+1 * The FreeBSD x11@ and graphics team proudly presentszeising2014-04-172-0/+2 * Add patch to fix build with freetype 2.5.1.kwm2013-12-063-7/+22 * Add NO_STAGE all over the place in preparation for the staging support (cat: ...bapt2013-09-211-1/+1 * -Update to 2.3.1.mezz2013-03-204-13/+120 * - Remove WITH_FBSD10_FIX, is no longer neededmiwi2011-11-091-1/+0 * - Fix build on FreeBSD 10.0miwi2011-10-291-0/+1 * The vast majority of pkg-descr files had the following format when theydougb2011-10-241-2/+0 * - Get Rid MD5 supportmiwi2011-03-191-1/+0 * Back out until I re-gather error log.cracauer2010-02-131-1/+0 * Add missing dependency. This fixes a configure-time error.cracauer2010-02-131-0/+1 * Presenting GNOME 2.28.1 for FreeBSD. The official release notes for thismarcus2009-11-292-4/+4 * Update to 2.1.13.marcus2008-07-052-4/+4 * - Welcome X.org 7.2 \o/.flz2007-05-203-26/+13 * Portlint:mezz2007-03-271-1/+1 * - Remove support for xfree86-3pav2007-02-031-7/+1 * Use libtool port instead of included version to avoid objformat a.out botchkris2007-02-011-0/+1 * Disable the CJK patchset as it is no longer needed after the recentmarcus2006-11-012-9/+6 * portlint:mezz2006-05-161-4/+4 * Conversion to a single libtool environment.ade2006-02-232-1/+3 * Fixups after removal of separate mtree file for X_WINDOW_SYSTEM=XOrg case.lesi2006-01-222-7/+1 * - Add WITH_CJK patchespav2005-12-182-0/+10 * Mass-conversion to the USE_AUTOTOOLS New World Order. The code presentade2005-11-151-1/+1 * - Remove CJK patch; it does not compile anymorepav2005-11-102-9/+1 * - Update CJK patch to fix bug which caused Firefox to crash on startuppav2005-07-162-5/+6 * - Readd WITH_CJK knob with an updated patchpav2005-07-152-0/+8 * - Remove WITH_CJK knob and patch, it was merged into 2.1.7pav2005-07-142-8/+0 * - Restore distinfo for WITH_CJK knobpav2005-07-141-0/+2 * Update to 2.1.7.marcus2005-07-144-71/+5 * Fix up plist after modifications to mtree (BSD.x11-4.dist rev. 1.27).lesi2005-06-152-0/+7 * Fix a crash that can occur when using TrueType fonts. This should havemarcus2005-03-282-0/+13 * Update to the latest Firefly patchset. This patchset makes CJK TrueType fontsmarcus2005-03-161-1/+2 * Re-add the distinfo entries for the CJK patch.marcus2005-02-251-0/+2 * Use an alternate (working) MASTER_SITE which only has bzip2 distfiles.marcus2005-02-192-5/+4 * Add the Firefly font patchset. This patchset is mainly used to makemarcus2004-11-222-0/+7 * - Add the X_WINDOW_SYSTEM={xorg,xfree86-4,xfree86-3} variable to bsd.port.mk,anholt2004-07-241-2/+2 * Update to 2.1.6 with the official freetype2-2.1.7 fix.marcus2004-03-233-61/+3 * Revert a portion of the font rendering code that enforces strict bitmap fontmarcus2004-03-192-0/+58 * Add libXft after a repo-copy from Xft and update to 2.1.5. libXft is simplymarcus2004-03-172-6/+5 * Bump PORTREVISION on all ports that depend on gettext to aid with upgrading.marcus2004-02-041-0/+1 * USE_REINPLACE need be defined only when REINPLACE_CMD is used.trevor2003-11-171-1/+0 * Add a new MASTER_SITE since the Fontconfig site went away.marcus2003-09-181-1/+1 * Update to 2.1.2. This wraps up a lot of our patches, and fixes some othermarcus2003-05-1511-496/+60 * Add a patch to fix PCF glyph problems.marcus2003-04-252-1/+37 * Fix a segfault that can occur when mixing RENDER and non-RENDER fonts.marcus2003-04-072-1/+21 * fontconfig-config is no longer installed. Therefore, Xft wasn't beingmarcus2003-04-051-1/+2 * Revert previous commit since it caused an infinite recursion loopmarcus2003-04-052-20/+1 * Borrow a little from kdelibs3, and add a dependency on the scalable fonts.marcus2003-04-042-4/+21 * Make sure the include directory exists before trying to copy files intomarcus2003-03-29