aboutsummaryrefslogtreecommitdiffstats
path: root/comms/uird/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'comms/uird/Makefile')
-rw-r--r--comms/uird/Makefile15
1 files changed, 4 insertions, 11 deletions
diff --git a/comms/uird/Makefile b/comms/uird/Makefile
index 32dcaa041cc..5e369a8b4fe 100644
--- a/comms/uird/Makefile
+++ b/comms/uird/Makefile
@@ -11,8 +11,7 @@ EXTRACT_SUFX= .tgz
MAINTAINER= lx@FreeBSD.org
COMMENT= The Universal IR Receiver Daemon
-USE_GMAKE= yes
-USES= perl5
+USES= perl5 gmake
WRKSRC= ${WRKDIR}/${PORTNAME}
ALL_TARGET= ${PORTNAME}
@@ -20,21 +19,15 @@ ALL_TARGET= ${PORTNAME}
PLIST_FILES= bin/uird
PORTDOCS= Documentation
-NO_STAGE= yes
-
OPTIONS_DEFINE= DOCS
-.include <bsd.port.options.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's|gcc|$${CC}\ $${CFLAGS}|; /strip/d' \
${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/uird ${PREFIX}/bin
-.if ${PORT_OPTIONS:MDOCS}
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${DOCSDIR}
-.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/uird ${STAGEDIR}${PREFIX}/bin
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>