aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-DBIx-Class-Loader/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/p5-DBIx-Class-Loader/Makefile')
-rw-r--r--databases/p5-DBIx-Class-Loader/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/databases/p5-DBIx-Class-Loader/Makefile b/databases/p5-DBIx-Class-Loader/Makefile
new file mode 100644
index 00000000000..615714f1a50
--- /dev/null
+++ b/databases/p5-DBIx-Class-Loader/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: databases/p5-DBIx-Class-Loader
+# Date created: 16 Nov 2005
+# Whom: Lars Balker Rasmussen <lars@balker.dk>
+#
+# $FreeBSD$
+#
+
+PORTNAME= DBIx-Class-Loader
+PORTVERSION= 0.09
+CATEGORIES= databases perl5
+MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
+MASTER_SITE_SUBDIR= ../by-authors/id/S/SR/SRI
+PKGNAMEPREFIX= p5-
+
+MAINTAINER= lars@balker.dk
+COMMENT= Dynamic definition of DBIx::Class sub classes
+
+BUILD_DEPENDS= p5-DBI>=1.3:${PORTSDIR}/databases/p5-DBI \
+ p5-DBIx-Class>=0.03001:${PORTSDIR}/databases/p5-DBIx-Class \
+ p5-Lingua-EN-Inflect>=0:${PORTSDIR}/textproc/p5-Lingua-EN-Inflect \
+ p5-Test-Simple>=0.45:${PORTSDIR}/devel/p5-Test-Simple \
+ p5-Text-Balanced>=0:${PORTSDIR}/textproc/p5-Text-Balanced
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+PERL_CONFIGURE= yes
+
+MAN3= DBIx::Class::Loader.3 \
+ DBIx::Class::Loader::Generic.3 \
+ DBIx::Class::Loader::Pg.3 \
+ DBIx::Class::Loader::SQLite.3 \
+ DBIx::Class::Loader::Writing.3 \
+ DBIx::Class::Loader::mysql.3
+
+.include <bsd.port.pre.mk>
+.if ${PERL_LEVEL} <= 500800
+IGNORE= requires Perl 5.8. Install lang/perl5.8, and try again
+.endif
+.include <bsd.port.post.mk>