aboutsummaryrefslogtreecommitdiffstats
path: root/databases/p5-Ima-DBI/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'databases/p5-Ima-DBI/Makefile')
-rw-r--r--databases/p5-Ima-DBI/Makefile7
1 files changed, 6 insertions, 1 deletions
diff --git a/databases/p5-Ima-DBI/Makefile b/databases/p5-Ima-DBI/Makefile
index 781f7e716c5..8e9dd13ffff 100644
--- a/databases/p5-Ima-DBI/Makefile
+++ b/databases/p5-Ima-DBI/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= Ima-DBI
-PORTVERSION= 0.32
+PORTVERSION= 0.33
CATEGORIES= databases perl5
MASTER_SITES= ${MASTER_SITE_PERL_CPAN}
MASTER_SITE_SUBDIR= Class/TMTM
@@ -16,6 +16,7 @@ MAINTAINER= skv@FreeBSD.org
COMMENT= Database connection caching and organization
BUILD_DEPENDS= ${SITE_PERL}/Class/WhiteHole.pm:${PORTSDIR}/devel/p5-Class-WhiteHole \
+ ${SITE_PERL}/DBIx/ContextualFetch.pm:${PORTSDIR}/databases/p5-DBIx-ContextualFetch \
${SITE_PERL}/Class/Data/Inheritable.pm:${PORTSDIR}/devel/p5-Class-Data-Inheritable
RUN_DEPENDS= ${BUILD_DEPENDS}
@@ -33,4 +34,8 @@ BUILD_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
RUN_DEPENDS+= ${SITE_PERL}/${PERL_ARCH}/DBI.pm:${PORTSDIR}/databases/p5-DBI
.endif
+.if ${PERL_LEVEL} < 500702
+BUILD_DEPENDS+= ${SITE_PERL}/Test/More.pm:${PORTSDIR}/devel/p5-Test-Simple
+.endif
+
.include <bsd.port.post.mk>