aboutsummaryrefslogtreecommitdiffstats
path: root/databases/tora/files/patch-src_Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'databases/tora/files/patch-src_Makefile.am')
-rw-r--r--databases/tora/files/patch-src_Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/databases/tora/files/patch-src_Makefile.am b/databases/tora/files/patch-src_Makefile.am
new file mode 100644
index 00000000000..41fa30e2393
--- /dev/null
+++ b/databases/tora/files/patch-src_Makefile.am
@@ -0,0 +1,20 @@
+--- ./src/Makefile.am.orig 2008-03-09 21:03:09.000000000 +0100
++++ ./src/Makefile.am 2008-03-27 22:11:51.000000000 +0100
+@@ -16,7 +16,7 @@
+
+ AM_CPPFLAGS = -I$(top_srcdir)/ext/otl -I$(LOKIDIR_INC) $(KDE_INCLUDES) $(QT_INCLUDES) $(LTDLINCL)
+ AM_CPPFLAGS += $(PCRE_CFLAGS) \
+- -DDEFAULT_PLUGIN_DIR=\"$(libdir)\" \
++ -DDEFAULT_PLUGIN_DIR=\"$(docdir)\" \
+ -DTOVERSION=\"$(PACKAGE_VERSION)\" \
+ $(ORACLE_CXXFLAGS) \
+ $(QSCINTILLA_CXXFLAGS)
+@@ -42,7 +42,7 @@
+ # fix for annoying automake naming problems.
+ tora_CXXFLAGS = $(AM_CXXFLAGS)
+
+-tora_LDADD = $(ORACLE_LIBS) $(@TORA_LINK_OTHERS@)
++tora_LDADD = $(ORACLE_LIBS) $(@TORA_LINK_OTHERS@) $(LIBCOMPAT)
+
+ if HAVE_ORACLE
+ EXTRA_ORACLE_MONO_SOURCE = tooracleconnection.cpp \