aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/planner/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/planner/Makefile')
-rw-r--r--deskutils/planner/Makefile22
1 files changed, 15 insertions, 7 deletions
diff --git a/deskutils/planner/Makefile b/deskutils/planner/Makefile
index 75633a4de4e..00315a855f0 100644
--- a/deskutils/planner/Makefile
+++ b/deskutils/planner/Makefile
@@ -1,28 +1,36 @@
-# New ports collection makefile for: MrProject
+# New ports collection makefile for: Planner
# Date created: 15 July 2001
# Whom: Dmitry Sivachenko <demon@FreeBSD.org>
#
# $FreeBSD$
#
-PORTNAME= mrproject
-PORTVERSION= 0.10
+PORTNAME= planner
+PORTVERSION= 0.11
CATEGORIES= deskutils gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.10
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/0.11
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
COMMENT= Project management application for Gnome 2
-LIB_DEPENDS= mrproject.0:${PORTSDIR}/deskutils/libmrproject
-
USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= gnomeprefix gnomehack libgnomeui libgnomeprintui
+USE_GNOME= gnomeprefix gnomehack intlhack libgnomeui libgnomeprintui libgsf
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include ${PTHREAD_CFLAGS}" \
LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}"
+.if defined(WITH_POSTGRESQL)
+POSTGRESQL_PORT?= databases/postgresql7
+LIB_DEPENDS+= pq.3:${PORTSDIR}/${POSTGRESQL_PORT}
+CONFIGURE_ARGS+= --enable-postgres
+PLIST_SUB+= POSTGRESQL:=""
+.else
+CONFIGURE_ARGS+= --disable-postgres
+PLIST_SUB+= POSTGRESQL:="@comment "
+.endif
+
.include <bsd.port.mk>