aboutsummaryrefslogtreecommitdiffstats
path: root/deskutils/strigi/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'deskutils/strigi/Makefile')
-rw-r--r--deskutils/strigi/Makefile60
1 files changed, 26 insertions, 34 deletions
diff --git a/deskutils/strigi/Makefile b/deskutils/strigi/Makefile
index 727e11fb42f..8c10d12b4aa 100644
--- a/deskutils/strigi/Makefile
+++ b/deskutils/strigi/Makefile
@@ -2,44 +2,36 @@
# $FreeBSD$
PORTNAME= strigi
-PORTVERSION= 0.7.8
-PORTREVISION= 1
+PORTVERSION= ${STRIGI_VERSION}
+PORTREVISION= 2
CATEGORIES= deskutils
-MASTER_SITES= http://www.vandenoever.info/software/strigi/
+DISTFILES= #
MAINTAINER= kde@FreeBSD.org
-COMMENT= Desktop searching program
-
-LIB_DEPENDS= avcodec${FFMPEG_SUFFIX}:${PORTSDIR}/multimedia/ffmpeg${FFMPEG_SUFFIX} \
- clucene-core:${PORTSDIR}/textproc/clucene \
- dbus-1:${PORTSDIR}/devel/dbus \
- exiv2:${PORTSDIR}/graphics/exiv2
-
-USE_QT4= corelib gui dbus moc_build uic_build qmake_build rcc_build
-USE_BZIP2= yes
-USE_GNOME= libxml2
-USE_PKGCONFIG= build
-USE_FAM= yes
-USE_LDCONFIG= yes
-USES= cmake:outsource
-MAKE_JOBS_UNSAFE= yes
-
-# supported versions: ffmpeg, ffmpeg1, ffmpeg-devel
-# corresponding FFMPEG_SUFFIX: '', '1', '-devel'
-FFMPEG_SUFFIX?= #
-CMAKE_ARGS+= -DFFMPEG_SUFFIX:STRING="${FFMPEG_SUFFIX}"
-
-.if !empty(FFMPEG_SUFFIX)
-# Reorder include directories to allow build with multiple ffmpeg installed.
-# This patch must NOT be used, if ffmpeg headers are installed
-# directly to ${LOCALBASE}/include
-EXTRA_PATCHES+= ${FILESDIR}/extrapatch-libstreamanalyzer__plugins__endplugins__CMakeLists.txt
+COMMENT= Strigi desktop search (meta port)
+
+USE_KDE4= strigi_run
+NO_BUILD= yes
+
+OPTIONS_DEFINE= CLIENT DAEMON UTILITIES
+OPTIONS_DEFAULT= ${OPTIONS_DEFINE}
+
+.include <${.CURDIR}/Makefile.common>
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MCLIENT}
+RUN_DEPENDS+= ${LOCALBASE}/bin/strigiclient:${PORTSDIR}/deskutils/strigiclient
+.endif
+
+.if ${PORT_OPTIONS:MDAEMON}
+RUN_DEPENDS+= ${LOCALBASE}/bin/strigidaemon:${PORTSDIR}/deskutils/strigidaemon
+.endif
+
+.if ${PORT_OPTIONS:MUTILITIES}
+RUN_DEPENDS+= ${LOCALBASE}/bin/xmlindexer:${PORTSDIR}/deskutils/strigiutils
.endif
-post-patch:
- ${REINPLACE_CMD} -e \
- 's,$${LIB_DESTINATION}/pkgconfig,libdata/pkgconfig,' \
- ${WRKSRC}/libstreamanalyzer/CMakeLists.txt \
- ${WRKSRC}/libstreams/CMakeLists.txt
+do-install:
+ @${DO_NADA}
.include <bsd.port.mk>