aboutsummaryrefslogtreecommitdiffstats
path: root/devel/anjuta-devel/files
diff options
context:
space:
mode:
Diffstat (limited to 'devel/anjuta-devel/files')
-rw-r--r--devel/anjuta-devel/files/patch-Makefile.in28
-rw-r--r--devel/anjuta-devel/files/patch-configure24
-rw-r--r--devel/anjuta-devel/files/patch-data::Makefile.in14
-rw-r--r--devel/anjuta-devel/files/patch-doc-Makefile.in11
-rw-r--r--devel/anjuta-devel/files/patch-launcher-Makefile.in8
-rw-r--r--devel/anjuta-devel/files/patch-ltmain.sh43
-rw-r--r--devel/anjuta-devel/files/patch-plugins::class-gen::Makefile.in14
-rw-r--r--devel/anjuta-devel/files/patch-plugins::sample1::Makefile.in14
-rw-r--r--devel/anjuta-devel/files/patch-po::Makefile.in.in12
-rw-r--r--devel/anjuta-devel/files/patch-src-Makefile.in80
-rw-r--r--devel/anjuta-devel/files/patch-src::anjuta.c14
-rw-r--r--devel/anjuta-devel/files/patch-tagmanager::parse.h10
12 files changed, 201 insertions, 71 deletions
diff --git a/devel/anjuta-devel/files/patch-Makefile.in b/devel/anjuta-devel/files/patch-Makefile.in
index c863c25da03..7f42511f1ab 100644
--- a/devel/anjuta-devel/files/patch-Makefile.in
+++ b/devel/anjuta-devel/files/patch-Makefile.in
@@ -1,23 +1,23 @@
-
-$FreeBSD$
-
---- Makefile.in.orig Fri Jan 4 16:09:11 2002
-+++ Makefile.in Fri Jan 4 16:26:58 2002
-@@ -137,11 +137,11 @@
+--- Makefile.in.orig Fri Feb 15 17:25:54 2002
++++ Makefile.in Fri Feb 15 17:33:47 2002
+@@ -150,13 +150,13 @@
cxxflags_set = @cxxflags_set@
l = @l@
--SUBDIRS = intl po macros tagmanager global-tags scintilla ccview widgets manuals omf-install src pixmaps data doc launcher
-+SUBDIRS = intl po macros tagmanager global-tags ccview widgets manuals omf-install src pixmaps data launcher
+-SUBDIRS = intl po macros tagmanager global-tags scintilla \
++SUBDIRS = intl po macros tagmanager global-tags \
+ widgets manuals omf-install src pixmaps data \
+- doc launcher plugins scripts
++ launcher plugins scripts
anjutadocdir = ${prefix}/doc/anjuta
--anjutadoc_DATA = README COPYING AUTHORS ChangeLog INSTALL NEWS TODO ABOUT-NLS FUTURE
-+anjutadoc_DATA = # README COPYING AUTHORS ChangeLog INSTALL NEWS TODO ABOUT-NLS FUTURE
-
-
- EXTRA_DIST = anjuta.desktop.in.in anjuta.spec.in xml-i18n-extract.in xml-i18n-merge.in xml-i18n-update.in $(anjutadoc_DATA)
-@@ -416,7 +416,7 @@
+-anjutadoc_DATA = \
++anjutadoc_DATA = # \
+ README\
+ COPYING\
+ AUTHORS\
+@@ -448,7 +448,7 @@
install-exec-am:
install-exec: install-exec-recursive
diff --git a/devel/anjuta-devel/files/patch-configure b/devel/anjuta-devel/files/patch-configure
index 7bf2e921a14..ece49bb8864 100644
--- a/devel/anjuta-devel/files/patch-configure
+++ b/devel/anjuta-devel/files/patch-configure
@@ -1,8 +1,5 @@
-
-$FreeBSD$
-
---- configure.orig Fri Jan 4 15:39:12 2002
-+++ configure Fri Jan 4 16:07:50 2002
+--- configure.orig Thu Feb 14 22:13:15 2002
++++ configure Thu Feb 14 22:15:54 2002
@@ -8,6 +8,7 @@
# gives unlimited permission to copy, distribute and modify it.
@@ -11,7 +8,7 @@ $FreeBSD$
ac_help=
ac_default_prefix=/usr/local
# Any additions from configure.in:
-@@ -6391,10 +6392,10 @@
+@@ -10328,11 +10329,11 @@
packageprefix=${prefix}
fi
@@ -19,18 +16,18 @@ $FreeBSD$
-packagedocdir=doc/${PACKAGE}
+packagedatadir=share/gnome/${PACKAGE}
+packagedocdir=share/doc/${PACKAGE}
+ packageplugindir=lib/${PACKAGE}/plugins/${VERSION}
-packagepixmapsdir=share/pixmaps/${PACKAGE}
+packagepixmapsdir=share/gnome/pixmaps/${PACKAGE}
packagehelpdir=share/gnome/help/${PACKAGE}
packagemenudir=share/gnome/apps
-
-@@ -6557,12 +6558,10 @@
+ packageplugindir=lib/${PACKAGE}
+@@ -10505,11 +10506,9 @@
tagmanager/Makefile
tagmanager/include/Makefile
global-tags/Makefile
-scintilla/Makefile
- ccview/Makefile
widgets/Makefile
manuals/Makefile
omf-install/Makefile
@@ -38,20 +35,19 @@ $FreeBSD$
manuals/C/Makefile
manuals/C/anjuta-manual/Makefile
manuals/C/anjuta-faqs/Makefile
-@@ -6656,6 +6655,7 @@
+@@ -10625,6 +10624,7 @@
+ s%@GNOME_DOCKLETS_LIBS@%$GNOME_DOCKLETS_LIBS%g
s%@GNOME_CAPPLET_LIBS@%$GNOME_CAPPLET_LIBS%g
s%@cflags_set@%$cflags_set%g
- s%@GTK_CONFIG@%$GTK_CONFIG%g
+s%@GLIB_CONFIG@%$GLIB_CONFIG%g
+ s%@GTK_CONFIG@%$GTK_CONFIG%g
s%@GTK_CFLAGS@%$GTK_CFLAGS%g
s%@GTK_LIBS@%$GTK_LIBS%g
- s%@XPM_LIBS@%$XPM_LIBS%g
-@@ -6759,12 +6759,10 @@
+@@ -10730,11 +10730,9 @@
tagmanager/Makefile
tagmanager/include/Makefile
global-tags/Makefile
-scintilla/Makefile
- ccview/Makefile
widgets/Makefile
manuals/Makefile
omf-install/Makefile
diff --git a/devel/anjuta-devel/files/patch-data::Makefile.in b/devel/anjuta-devel/files/patch-data::Makefile.in
new file mode 100644
index 00000000000..63700064d2b
--- /dev/null
+++ b/devel/anjuta-devel/files/patch-data::Makefile.in
@@ -0,0 +1,14 @@
+--- data/Makefile.in.orig Fri Feb 15 17:24:52 2002
++++ data/Makefile.in Fri Feb 15 17:24:40 2002
+@@ -424,8 +424,8 @@
+ @rm -f system.tags
+
+ system.tags:
+- cd $(top_builddir)/tagmanager && make libctags.a
+- cd $(top_builddir)/global-tags && make system.tags
++ cd $(top_builddir)/tagmanager && $(MAKE) libctags.a
++ cd $(top_builddir)/global-tags && $(MAKE) system.tags
+ mv $(top_builddir)/global-tags/system.tags .
+
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.
+
diff --git a/devel/anjuta-devel/files/patch-doc-Makefile.in b/devel/anjuta-devel/files/patch-doc-Makefile.in
index 99bb77ee866..e4678caf302 100644
--- a/devel/anjuta-devel/files/patch-doc-Makefile.in
+++ b/devel/anjuta-devel/files/patch-doc-Makefile.in
@@ -1,10 +1,11 @@
---- doc/Makefile.in.orig Sat Mar 31 00:14:22 2001
-+++ doc/Makefile.in Sat Mar 31 00:24:25 2001
-@@ -112,7 +112,7 @@
+--- doc/Makefile.in.orig Thu Feb 14 22:16:50 2002
++++ doc/Makefile.in Thu Feb 14 22:17:06 2002
+@@ -152,8 +152,7 @@
- anjuta_docdir = ${prefix}/doc/anjuta
+ anjuta_docdir = $(prefix)/@NO_PREFIX_PACKAGE_DOC_DIR@
--anjuta_doc_DATA = ScintillaDoc.html
+-anjuta_doc_DATA = \
+- ScintillaDoc.html
+anjuta_doc_DATA =
diff --git a/devel/anjuta-devel/files/patch-launcher-Makefile.in b/devel/anjuta-devel/files/patch-launcher-Makefile.in
index 535d73f9456..7cfd3a350f3 100644
--- a/devel/anjuta-devel/files/patch-launcher-Makefile.in
+++ b/devel/anjuta-devel/files/patch-launcher-Makefile.in
@@ -1,5 +1,5 @@
---- launcher/Makefile.in.orig Thu Mar 29 15:54:01 2001
-+++ launcher/Makefile.in Thu Mar 29 15:54:45 2001
+--- launcher/Makefile.in.orig Thu Feb 14 22:17:29 2002
++++ launcher/Makefile.in Thu Feb 14 22:18:22 2002
@@ -12,6 +12,7 @@
@@ -8,7 +8,7 @@
srcdir = @srcdir@
top_srcdir = @top_srcdir@
-@@ -110,13 +111,13 @@
+@@ -150,13 +151,13 @@
cxxflags_set = @cxxflags_set@
l = @l@
@@ -20,7 +20,7 @@
anjuta_launcher_SOURCES = anjuta_launcher.c
-anjuta_launcher_LDFLAGS = `glib-config --libs`
-+anjuta_launcher_LDFLAGS = `$(GLIB_CONFIG) --libs`
++anjuta_launcher_LDFLAGS = `$(GLIB_CONFIG) --libs`
mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
CONFIG_HEADER = ../config.h
CONFIG_CLEAN_FILES =
diff --git a/devel/anjuta-devel/files/patch-ltmain.sh b/devel/anjuta-devel/files/patch-ltmain.sh
new file mode 100644
index 00000000000..f90e4759111
--- /dev/null
+++ b/devel/anjuta-devel/files/patch-ltmain.sh
@@ -0,0 +1,43 @@
+--- ltmain.sh.orig Wed Jan 23 11:38:40 2002
++++ ltmain.sh Sun Feb 3 01:44:17 2002
+@@ -1037,8 +1037,16 @@
+ continue
+ ;;
+
++ -pthread)
++ compile_command="$compile_command -pthread"
++ finalize_command="$finalize_command -pthread"
++ compiler_flags="$compiler_flags -pthread"
++ continue
++ ;;
++
+ -module)
+ module=yes
++ build_old_libs=no
+ continue
+ ;;
+
+@@ -2412,6 +2420,9 @@
+ *-*-netbsd*)
+ # Don't link with libc until the a.out ld.so is fixed.
+ ;;
++ *-*-freebsd*)
++ # FreeBSD doesn't need this...
++ ;;
+ *)
+ # Add libc to deplibs on all other systems if necessary.
+ if test "$build_libtool_need_lc" = "yes"; then
+@@ -4179,10 +4190,12 @@
+ fi
+
+ # Install the pseudo-library for information purposes.
++ if /usr/bin/false; then
+ name=`$echo "X$file" | $Xsed -e 's%^.*/%%'`
+ instname="$dir/$name"i
+ $show "$install_prog $instname $destdir/$name"
+ $run eval "$install_prog $instname $destdir/$name" || exit $?
++ fi
+
+ # Maybe install the static library, too.
+ test -n "$old_library" && staticlibs="$staticlibs $dir/$old_library"
+
diff --git a/devel/anjuta-devel/files/patch-plugins::class-gen::Makefile.in b/devel/anjuta-devel/files/patch-plugins::class-gen::Makefile.in
new file mode 100644
index 00000000000..feb611acefd
--- /dev/null
+++ b/devel/anjuta-devel/files/patch-plugins::class-gen::Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- plugins/class-gen/Makefile.in 2002/02/19 08:11:57 1.1
++++ plugins/class-gen/Makefile.in 2002/02/19 08:12:25
+@@ -192,7 +192,7 @@
+ CPPFLAGS = @CPPFLAGS@
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
+-libanjuta_clsGen_la_LDFLAGS =
++libanjuta_clsGen_la_LDFLAGS = -module -avoid-version
+ libanjuta_clsGen_la_LIBADD =
+ libanjuta_clsGen_la_OBJECTS = clsGen.lo
+ CFLAGS = @CFLAGS@
diff --git a/devel/anjuta-devel/files/patch-plugins::sample1::Makefile.in b/devel/anjuta-devel/files/patch-plugins::sample1::Makefile.in
new file mode 100644
index 00000000000..cd5e5ad60b2
--- /dev/null
+++ b/devel/anjuta-devel/files/patch-plugins::sample1::Makefile.in
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- plugins/sample1/Makefile.in 2002/02/19 08:11:57 1.1
++++ plugins/sample1/Makefile.in 2002/02/19 08:12:31
+@@ -193,7 +193,7 @@
+ CPPFLAGS = @CPPFLAGS@
+ LDFLAGS = @LDFLAGS@
+ LIBS = @LIBS@
+-libanjuta_sample1_la_LDFLAGS =
++libanjuta_sample1_la_LDFLAGS = -module -avoid-version
+ libanjuta_sample1_la_LIBADD =
+ libanjuta_sample1_la_OBJECTS = plugin-sample1.lo
+ CFLAGS = @CFLAGS@
diff --git a/devel/anjuta-devel/files/patch-po::Makefile.in.in b/devel/anjuta-devel/files/patch-po::Makefile.in.in
new file mode 100644
index 00000000000..7699b0d9999
--- /dev/null
+++ b/devel/anjuta-devel/files/patch-po::Makefile.in.in
@@ -0,0 +1,12 @@
+--- po/Makefile.in.in 2002/01/22 18:34:36 1.1
++++ po/Makefile.in.in 2002/01/22 18:34:45
+@@ -106,7 +106,7 @@
+ @catalogs='$(CATALOGS)'; \
+ for cat in $$catalogs; do \
+ cat=`basename $$cat`; \
+- lang=`echo $$cat | sed 's/\.gmo$$//'`; \
++ lang=`echo $$cat | sed 's/\.mo$$//'`; \
+ dir=$(localedir)/$$lang/LC_MESSAGES; \
+ $(mkinstalldirs) $(DESTDIR)$$dir; \
+ if test -r $$cat; then \
+
diff --git a/devel/anjuta-devel/files/patch-src-Makefile.in b/devel/anjuta-devel/files/patch-src-Makefile.in
index 2f0fd8759a7..17187147319 100644
--- a/devel/anjuta-devel/files/patch-src-Makefile.in
+++ b/devel/anjuta-devel/files/patch-src-Makefile.in
@@ -1,33 +1,73 @@
-
-$FreeBSD$
-
---- src/Makefile.in.orig Fri Jan 4 15:15:40 2002
-+++ src/Makefile.in Fri Jan 4 15:15:54 2002
-@@ -139,10 +139,10 @@
+--- src/Makefile.in.orig Fri Feb 15 17:01:26 2002
++++ src/Makefile.in Fri Feb 15 17:03:35 2002
+@@ -157,38 +157,17 @@
+ $(GNOME_INCLUDEDIR)\
+ $(EXTRA_GNOME_CFLAGS)\
+ $(EXTRA_ORBIT_CFLAGS)\
+- -I$(srcdir)/../scintilla/include \
++ -I$(prefix)/include/scintilla \
+ -I$(srcdir)/../tagmanager/include \
+ -I$(srcdir)/../widgets \
+ -I$(srcdir)/../pixmaps \
+ -I.. -I. \
+ -Wall -Wimplicit -Wreturn-type -Wunused -Wswitch -Wcomment\
+ -Wuninitialized -Wparentheses -Wpointer-arith\
+- -Wmissing-prototypes\
+- -O1\
+- -g
++ -Wmissing-prototypes
- EXTRA_DIST = glades.h Prj-skelimpl.c Prj-skels.c Prj-stubs.c
-
--INCLUDES = -I$(top_srcdir)/intl $(GNOME_INCLUDEDIR) $(EXTRA_GNOME_CFLAGS) $(EXTRA_ORBIT_CFLAGS) -I$(srcdir)/../scintilla/include -I$(srcdir)/../tagmanager/include -I$(srcdir)/../widgets -I$(srcdir)/../ccview -I$(srcdir)/../pixmaps -I.. -I. -Wall -Wimplicit -Wreturn-type -Wunused -Wswitch -Wcomment -Wuninitialized -Wparentheses -Wpointer-arith -Wmissing-prototypes -O1 -g
-+INCLUDES = -I$(top_srcdir)/intl $(GNOME_INCLUDEDIR) $(EXTRA_GNOME_CFLAGS) $(EXTRA_ORBIT_CFLAGS) -I$(prefix)/include/scintilla -I$(srcdir)/../tagmanager/include -I$(srcdir)/../widgets -I$(srcdir)/../ccview -I$(srcdir)/../pixmaps -I.. -I. -Wall -Wimplicit -Wreturn-type -Wunused -Wswitch -Wcomment -Wuninitialized -Wparentheses -Wpointer-arith -Wmissing-prototypes
-
-
--SCILEXERS = ../scintilla/StyleContext.o ../scintilla/LexCPP.o ../scintilla/LexConf.o ../scintilla/LexHTML.o ../scintilla/LexLua.o ../scintilla/LexOthers.o ../scintilla/LexPerl.o ../scintilla/LexPython.o ../scintilla/LexSQL.o ../scintilla/LexVB.o ../scintilla/LexPascal.o ../scintilla/LexAVE.o ../scintilla/LexCrontab.o ../scintilla/LexEiffel.o ../scintilla/LexLisp.o ../scintilla/LexRuby.o ../scintilla/LexBullant.o ../scintilla/LexAda.o
-+SCILEXERS = -lscintilla_lexers
+-
+-SCILEXERS = \
+- ../scintilla/StyleContext.o\
+- ../scintilla/LexCPP.o\
+- ../scintilla/LexConf.o\
+- ../scintilla/LexHTML.o\
+- ../scintilla/LexLua.o\
+- ../scintilla/LexOthers.o\
+- ../scintilla/LexPerl.o\
+- ../scintilla/LexPython.o\
+- ../scintilla/LexSQL.o\
+- ../scintilla/LexVB.o\
+- ../scintilla/LexPascal.o\
+- ../scintilla/LexAVE.o\
+- ../scintilla/LexCrontab.o\
+- ../scintilla/LexEiffel.o\
+- ../scintilla/LexLisp.o\
+- ../scintilla/LexRuby.o\
+- ../scintilla/LexBullant.o\
+- ../scintilla/LexAda.o\
+- ../scintilla/LexBaan.o
++SCILEXERS = -lscintilla_lexers
++SCINTILLA = -lscintilla
bin_PROGRAMS = anjuta
-@@ -198,14 +198,7 @@
- defaults.$(OBJEXT) resources.$(OBJEXT) notebook.$(OBJEXT) \
+@@ -387,9 +366,9 @@
+ $(GNOMEUI_LIBS)\
+ $(EXTRA_GNOME_LIBS)\
+ $(EXTRA_ORBIT_LIBS)\
+- $(top_builddir)/scintilla/libscintilla.a\
+ $(top_builddir)/tagmanager/libctags.a\
+ $(top_builddir)/widgets/libwidgets.a\
++ $(SCINTILLA)\
+ $(SCILEXERS)
+
+ mkinstalldirs = $(SHELL) $(top_srcdir)/mkinstalldirs
+@@ -441,16 +420,7 @@
+ compatibility_0.$(OBJEXT) defaults.$(OBJEXT) resources.$(OBJEXT) \
CORBA-Server.$(OBJEXT) Gladen-common.$(OBJEXT) glades.$(OBJEXT) \
Prj-common.$(OBJEXT) Gladen-stubs.$(OBJEXT) session.$(OBJEXT)
--anjuta_DEPENDENCIES = ../scintilla/StyleContext.o ../scintilla/LexCPP.o \
--../scintilla/LexConf.o ../scintilla/LexHTML.o ../scintilla/LexLua.o \
--../scintilla/LexOthers.o ../scintilla/LexPerl.o \
+-anjuta_DEPENDENCIES = $(top_builddir)/scintilla/libscintilla.a \
+-$(top_builddir)/tagmanager/libctags.a \
+-$(top_builddir)/widgets/libwidgets.a ../scintilla/StyleContext.o \
+-../scintilla/LexCPP.o ../scintilla/LexConf.o ../scintilla/LexHTML.o \
+-../scintilla/LexLua.o ../scintilla/LexOthers.o ../scintilla/LexPerl.o \
-../scintilla/LexPython.o ../scintilla/LexSQL.o ../scintilla/LexVB.o \
-../scintilla/LexPascal.o ../scintilla/LexAVE.o \
-../scintilla/LexCrontab.o ../scintilla/LexEiffel.o \
-../scintilla/LexLisp.o ../scintilla/LexRuby.o ../scintilla/LexBullant.o \
--../scintilla/LexAda.o
+-../scintilla/LexAda.o ../scintilla/LexBaan.o
+anjuta_DEPENDENCIES =
anjuta_LDFLAGS =
CXXFLAGS = @CXXFLAGS@
diff --git a/devel/anjuta-devel/files/patch-src::anjuta.c b/devel/anjuta-devel/files/patch-src::anjuta.c
deleted file mode 100644
index 39809a1af63..00000000000
--- a/devel/anjuta-devel/files/patch-src::anjuta.c
+++ /dev/null
@@ -1,14 +0,0 @@
-
-$FreeBSD$
-
---- src/anjuta.c 2002/01/04 13:31:53 1.1
-+++ src/anjuta.c 2002/01/04 13:34:07
-@@ -148,7 +148,7 @@
- app->fileselection = create_fileselection_gui (&fsd1);
-
- /* Set to the current dir */
-- fileselection_set_dir (app->fileselection, (gchar *)get_current_dir_name());
-+ fileselection_set_dir (app->fileselection, (gchar *)g_get_current_dir ());
-
- app->save_as_fileselection = create_fileselection_gui (&fsd2);
- app->save_as_build_msg_sel = create_fileselection_gui (&fsd3);
diff --git a/devel/anjuta-devel/files/patch-tagmanager::parse.h b/devel/anjuta-devel/files/patch-tagmanager::parse.h
new file mode 100644
index 00000000000..2647cdaff6d
--- /dev/null
+++ b/devel/anjuta-devel/files/patch-tagmanager::parse.h
@@ -0,0 +1,10 @@
+--- tagmanager/parse.h.orig Fri Feb 15 16:44:43 2002
++++ tagmanager/parse.h Fri Feb 15 16:44:54 2002
+@@ -13,6 +13,7 @@
+ /*
+ * INCLUDE FILES
+ */
++#include <sys/types.h>
+ #include "general.h" /* must always come first */
+
+ #include "parsers.h" /* contains list of parsers */