aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gconf2/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/gconf2/Makefile')
-rw-r--r--devel/gconf2/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/devel/gconf2/Makefile b/devel/gconf2/Makefile
index 9234b54663f..d80a3fac77b 100644
--- a/devel/gconf2/Makefile
+++ b/devel/gconf2/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gconf
-PORTVERSION= 0.5
+PORTVERSION= 0.7
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= unstable/sources/GConf
@@ -17,7 +17,7 @@ MAINTAINER= ade@FreeBSD.org
LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs \
xml.5:${PORTSDIR}/textproc/libxml \
popt.0:${PORTSDIR}/devel/popt \
- guile.6:${PORTSDIR}/lang/guile \
+ guile.9:${PORTSDIR}/lang/guile \
oaf.0:${PORTSDIR}/devel/oaf
RUN_DEPENDS= gnomecc:${PORTSDIR}/sysutils/gnomecontrolcenter
@@ -35,4 +35,11 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
GTK_CONFIG="${GTK_CONFIG}" \
LIBS="-L${LOCALBASE}/lib"
+post-extract:
+ @${PERL} -pi -e 's|-lpthread|-pthread|g ; \
+ s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
+ @find ${WRKSRC} -name "Makefile.in" | xargs ${PERL} -pi -e \
+ 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
+ s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
+
.include <bsd.port.mk>