aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gconfmm26/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/gconfmm26/Makefile')
-rw-r--r--devel/gconfmm26/Makefile20
1 files changed, 15 insertions, 5 deletions
diff --git a/devel/gconfmm26/Makefile b/devel/gconfmm26/Makefile
index 129a4881bdd..3f7290dfb6a 100644
--- a/devel/gconfmm26/Makefile
+++ b/devel/gconfmm26/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= gconfmm
-PORTVERSION= 2.0.2
+PORTVERSION= 2.6.1
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
@@ -15,14 +15,24 @@ DIST_SUBDIR= gnome2
MAINTAINER= bland@FreeBSD.org
COMMENT= C++ wrapper for gconf2 API library
-LIB_DEPENDS= gtkmm-2.0:${PORTSDIR}/x11-toolkits/gtk--2
-BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4
+LIB_DEPENDS= glibmm-2.4.1:${PORTSDIR}/devel/glibmm
+BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
+ ${X11BASE}/lib/libgtkmm-2.4.so.1:${PORTSDIR}/x11-toolkits/gtkmm24
+USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack lthack gconf2
-USE_LIBTOOL_VER= 13
+USE_GCC= 3.3
+USE_REINPLACE= yes
+USE_GNOME= gnomehack gconf2 lthack
+USE_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-static
+PLIST_SUB= VERSION="2.6" API_VERSION="2.6"
+
+post-patch:
+ @${REINPLACE_CMD} -e '/^SUBDIRS =/s/examples//' \
+ ${WRKSRC}/Makefile.in
+
.include <bsd.port.mk>