aboutsummaryrefslogtreecommitdiffstats
path: root/devel/gnome-vfsmm/Makefile
diff options
context:
space:
mode:
Diffstat (limited to 'devel/gnome-vfsmm/Makefile')
-rw-r--r--devel/gnome-vfsmm/Makefile16
1 files changed, 12 insertions, 4 deletions
diff --git a/devel/gnome-vfsmm/Makefile b/devel/gnome-vfsmm/Makefile
index 6986ce0c597..36a002449cf 100644
--- a/devel/gnome-vfsmm/Makefile
+++ b/devel/gnome-vfsmm/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= gnome-vfsmm
-PORTVERSION= 2.6.1
-PORTREVISION= 1
+PORTVERSION= 2.10.0
CATEGORIES= devel gnome
MASTER_SITES= ${MASTER_SITE_GNOME}
MASTER_SITE_SUBDIR= sources/${PORTNAME}/${PORTVERSION:R}
@@ -23,8 +22,8 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GCC= 3.4
USE_GMAKE= yes
-USE_GNOME= gnomehack lthack gnomevfs2
-USE_INC_LIBTOOL_VER=13
+USE_GNOME= gnomehack gnomevfs2
+USE_INC_LIBTOOL_VER=15
INSTALLS_SHLIB= yes
CONFIGURE_ARGS= --enable-static
@@ -34,4 +33,13 @@ post-patch:
@${REINPLACE_CMD} -e '/^SUBDIRS =/s/examples//' \
${WRKSRC}/Makefile.in
+patch-autotools:
+ @(cd ${PATCH_WRKSRC}; \
+ for file in ${LIBTOOLFILES}; do \
+ ${CP} $$file $$file.tmp; \
+ ${SED} -e "/^ltmain=/s^\$$ac_aux_dir/ltmain.sh^${LTMAIN}^g" \
+ $$file.tmp > $$file; \
+ ${RM} $$file.tmp; \
+ done);
+
.include <bsd.port.mk>